summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/GitPython
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.25.ebuild78
-rw-r--r--dev-python/GitPython/GitPython-3.1.26.ebuild78
-rw-r--r--dev-python/GitPython/GitPython-3.1.27.ebuild (renamed from dev-python/GitPython/GitPython-3.1.24-r1.ebuild)5
-rw-r--r--dev-python/GitPython/Manifest14
4 files changed, 6 insertions, 169 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.25.ebuild b/dev-python/GitPython/GitPython-3.1.25.ebuild
deleted file mode 100644
index 12f116358c54..000000000000
--- a/dev-python/GitPython/GitPython-3.1.25.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.9
-SMMAP_P=smmap-5.0.0
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # upstream reverted the changes needing py3.10's typing module
- # but did not update the dep
- sed -i -e '/typing-extensions/d' requirements.txt || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- sed -i -e '/addopts/d' pyproject.toml || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # performance tests are unreliable by design
- test/performance
- # unimpoortant and problematic
- test/test_installation.py
- # Internet
- test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
- # TODO
- test/test_submodule.py::TestSubmodule::test_base_rw
- test/test_submodule.py::TestSubmodule::test_root_module
- )
-
- epytest
-}
diff --git a/dev-python/GitPython/GitPython-3.1.26.ebuild b/dev-python/GitPython/GitPython-3.1.26.ebuild
deleted file mode 100644
index 12f116358c54..000000000000
--- a/dev-python/GitPython/GitPython-3.1.26.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.9
-SMMAP_P=smmap-5.0.0
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # upstream reverted the changes needing py3.10's typing module
- # but did not update the dep
- sed -i -e '/typing-extensions/d' requirements.txt || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- sed -i -e '/addopts/d' pyproject.toml || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # performance tests are unreliable by design
- test/performance
- # unimpoortant and problematic
- test/test_installation.py
- # Internet
- test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
- # TODO
- test/test_submodule.py::TestSubmodule::test_base_rw
- test/test_submodule.py::TestSubmodule::test_root_module
- )
-
- epytest
-}
diff --git a/dev-python/GitPython/GitPython-3.1.24-r1.ebuild b/dev-python/GitPython/GitPython-3.1.27.ebuild
index f045b8742135..dd1783145b6a 100644
--- a/dev-python/GitPython/GitPython-3.1.24-r1.ebuild
+++ b/dev-python/GitPython/GitPython-3.1.27.ebuild
@@ -3,14 +3,15 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.7
-SMMAP_P=smmap-4.0.0
+GITDB_P=gitdb-4.0.9
+SMMAP_P=smmap-5.0.0
DESCRIPTION="Library used to interact with Git repositories"
HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index d0a2bb2304a3..922afc161260 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,14 +1,6 @@
-DIST GitPython-3.1.24.gitbundle 9658020 BLAKE2B 4ac2c1a238de1d6e5be9f2d65ec486a1a48b38695946889f8ba1c7f0474216e251d6385737d0576be9ece09d3751a305d756b58a21dc20a279609a35553de0f0 SHA512 9f05b4c92b85fa80e9b774380758c1a6e0d4ada81c170ddd6c542a31fae1a047844a481e8478afc3472e3a226f8eca1a37a3ef7a6b9c06787fd84543cd073b1e
-DIST GitPython-3.1.24.tar.gz 191249 BLAKE2B b60f5186aea33434d77b63997e5e9dc277b49a97934bfe250795af9c0ed92d00c478dd4475a00faa2f5867882f81161dcd21ed46c86883a48b8397266b5318de SHA512 af2aa85574287827e5d2b78f7a19776be57518aa0b8af7a3fb92bef0d97c6a27b3272ed39adf2080b39cd5a9eb114164de7a2a9bbf73cfe1fe2647e0b053b092
-DIST GitPython-3.1.25.gitbundle 9683858 BLAKE2B 64dc43f6602f797830c6bf44d85ee0b5f870ca7f52626cc6f6f3e9e3a01faf3ad1fcb276e4f583eac9ff9add74fb7ea967e8df614f93434e56ef7b57963540c0 SHA512 2f1d6f839e80b2c70e892af48511403ffc229e8d61cf0faa6680d9b011363ceb2f0da750028f831d3099c2cdce16c375ef60ec94cc2f831e93f54e7728a78f12
-DIST GitPython-3.1.25.tar.gz 191824 BLAKE2B 95185d0e45cfefd4c74c98d9319aacbd678f942e87569beaf87052c4090947ab58a508f5248998d23952277ccae93effdaab2dc0647fd07964971fdc7f2ac9d7 SHA512 f5b29f2374c63d122e697fca8bc65d2db03f43eb21c70a903fdb3bb1667ab647cff9ad6b473213a47d124775fb7424b5abff7b8d76bf2748ac848dd4aebdd04a
-DIST GitPython-3.1.26.gitbundle 9711896 BLAKE2B 31c06bc713cabe11f0a1cb5fe0a94dbca628cc047de3ac29d83eb97370ebe112aae813ab93717618d4382f13a63bd9cc79709e493c99f77c7d0a2a505181e869 SHA512 99ea5bf310e5edb36f02b44b07729041c683bd1eea1b7af278d6a89147a0761c04aa6eeafbd488b1c84935d00ebf47e7c6230984a8caaccdeccd8c3878b094e4
-DIST GitPython-3.1.26.tar.gz 191901 BLAKE2B 365defa1947719273319bbf8b035710b6bfcecae19d5a8f452d4667b4227f1a5bce4238ff9377b2ac97eee27de97410b19882072b5b6673ec6a75638bd9c8751 SHA512 dcaa14b5bafb6d41c0d5afd57494146b309bcd9a7c65ed4ce56f71fc6e2399640147fac7319dd91b8ea4ae1ca38d02885d5a4b64eccb043c4b8a4347e27a1ecb
-DIST gitdb-4.0.7.gitbundle 1498536 BLAKE2B 1e0aff67259c04d2932dbdefb0ae07bd9fb51c5dcb99ee8431e78bf428095250ed45f5e12e2484b407bb4257050b0864e67096b3501d4829491cb7714a7b5ddf SHA512 f8b1b3de00f0597d65f528dd30495fd3dd9e1e4d494987899ef2064d23947ede799db391a59688dfa27e4fcdc9379b5352a378b39e6fb2421e6c850f81157bec
+DIST GitPython-3.1.27.gitbundle 9652508 BLAKE2B f81b6d94b302b1d4aec85096bb294df1a6a699eff4dd27a1d32083e73b031daf3ef58ec6aa6f98c7693ef187b21de9ea242fa37a88b1f51c0e17238dda978c5c SHA512 bf1011a765b51eb871f6b6a462c693e4e79bb0ba81103d4f268b780b86ab12112c44f74c1d68e93388d1f86c068f6c2336f33ea12dce2e0b2302c940ebb9c49f
+DIST GitPython-3.1.27.tar.gz 192188 BLAKE2B 3cab995a17d8eca8d4301367b1ee7a2c3c0a46a217f6e6d89e1bb4e62b733d21cd6d9210faac49c3c905343067e819f8c37ac9cc69d9fc33ce948b63fd53714e SHA512 6f855bcfc380c1a83a97807ca8ddcc4dfe8258f3aba0790142ef41f28befff44847aec925e523eaac47fd6c0078eb6296f52bb4b7d2be7d59ad95bbeb930fe28
DIST gitdb-4.0.9.gitbundle 1461448 BLAKE2B dad9efdc4e9711361c851f4745df2e3fa3b2360ab58cffea971a854429cf3e11862a267efb5afa3d9ff7668dc6d1bb7f11aa033172238bea61a6252d0488b746 SHA512 eb71e6dd380e67a96a9dcd50a3a3c82aab8c7f85b1ca4258a92202a5e4cb5a1535363599c94ab26884b4cd755ce30694c1b193a95e5cd5199b5d4e2cf8e72818
-DIST smmap-4.0.0.gitbundle 322820 BLAKE2B 20ac688cafa9ad036f3e21ac1bb9323ae55e618eb0806634fe4c885d2b12fe802779adcffb0fea3da9707e94109a168738d63abe990d1ce9b141c779aa6798d6 SHA512 03296099303eb38ac9ca46733255024355aed2e64a2f9409552ae34af76beb9685a6dd2458df986593fe426e428bc184617abe22c8b92ee01c8c7e1d98de8592
DIST smmap-5.0.0.gitbundle 338621 BLAKE2B 58c151245a1353d482e06313beb1cfbe7aa23d30733b284b1745b562da1da4e6f9b8acd7d4b967987e8c29a0cfbe6d3b27790f4683f6cbd86fc22a1416bc1c24 SHA512 94b827cdcfaf31b726b48b7b0a9036e852683046b07430b79e59a1339079ca078129d5eb02d9009979ce86892748b700d6cd281e401ddf6b0048252e2181fe1f
-EBUILD GitPython-3.1.24-r1.ebuild 2162 BLAKE2B 1279f12c0f2ead67e929735fc1b9309c34aa70d494bf885488b740a4de95c8cde571afe150f6b811936e0dc13e84df1a5fb41c8d38e20c75dc9440c2da7e93b5 SHA512 2166128c96a50089c3f4f3634e7561cd6e5c67e2fbc03dbd01587c03a8d1848b219c310b4936416da86b637bc975bbfd6ae67ee444f0cb8547b203ca1e4b5e32
-EBUILD GitPython-3.1.25.ebuild 2170 BLAKE2B 9fa3e1ce424291ff9fd5b0cadf5930fecd204eac21e2867c60da951440e078220bca8373500b06d54ce913c18e7c6edee1da7fee2054686fe2c65b3e4d637dfa SHA512 5642267ae8c2170c240ef435c6d075ce0541b11a76b34c21a89ce16bb6bb9ba027177f6d5178754fa28884b9a3bf3306888dfe9fcdeede50341914d64d915f57
-EBUILD GitPython-3.1.26.ebuild 2170 BLAKE2B 9fa3e1ce424291ff9fd5b0cadf5930fecd204eac21e2867c60da951440e078220bca8373500b06d54ce913c18e7c6edee1da7fee2054686fe2c65b3e4d637dfa SHA512 5642267ae8c2170c240ef435c6d075ce0541b11a76b34c21a89ce16bb6bb9ba027177f6d5178754fa28884b9a3bf3306888dfe9fcdeede50341914d64d915f57
+EBUILD GitPython-3.1.27.ebuild 2194 BLAKE2B e3eb55cdd9eca9cd6134898ffbe5af4540195b9d624c8c5765c7406d4b9a66bc8875d7018d1133745561b57fc350540bc6fe25728deb9c756b13981d8917aa78 SHA512 de0b04ca8fc63ac37280bffc23d1fbbee251abc6ab32780f0236646672d9b504ccc270173c24d4764985aabed378af5273f15e210535399f0e6ac8be98adfae8
MISC metadata.xml 407 BLAKE2B 49fd8d520d575be1489c299f22595120fad882f055b9cf2d02b87382c6d8f0ff38af694e5584b4da579aa84b82c2f1032e4afb64cafd9f4fe9212a6d67b4a752 SHA512 1bebe1e134eb86a4745cf7e297d45118a2bdd3d8a71d0034294b5c799a9cee763c63b61b34c6707c52f61058f727f4b827dd020d285fc297712b29eb7c1129ef