summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 21:35:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 21:35:53 +0100
commit26ed1f5a5b7138ff40e6ac14e66f198c40831424 (patch)
tree41b0c986a258b43e68bb831a7c2a384d882e0d59 /dev-python/GitPython
parent75949673f38270397841d9c2322dbb774ac41554 (diff)
gentoo auto-resync : 11:08:2023 - 21:35:53
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.31.ebuild83
-rw-r--r--dev-python/GitPython/GitPython-3.1.32.ebuild2
-rw-r--r--dev-python/GitPython/Manifest5
3 files changed, 2 insertions, 88 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.31.ebuild b/dev-python/GitPython/GitPython-3.1.31.ebuild
deleted file mode 100644
index 965792916bee..000000000000
--- a/dev-python/GitPython/GitPython-3.1.31.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.10
-SMMAP_P=smmap-5.0.0_p1
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="
- https://github.com/gitpython-developers/GitPython/
- https://pypi.org/project/GitPython/
-"
-SRC_URI+="
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # performance tests are unreliable by design
- test/performance
- # unimpoortant and problematic
- test/test_installation.py
- # Internet
- test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
- # requires which(1)
- # https://github.com/gitpython-developers/GitPython/pull/1525
- test/test_git.py::TestGit::test_refresh
- # TODO
- test/test_submodule.py::TestSubmodule::test_base_rw
- test/test_submodule.py::TestSubmodule::test_git_submodules_and_add_sm_with_new_commit
- test/test_submodule.py::TestSubmodule::test_list_only_valid_submodules
- test/test_submodule.py::TestSubmodule::test_root_module
- )
-
- epytest -o addopts= test
-}
diff --git a/dev-python/GitPython/GitPython-3.1.32.ebuild b/dev-python/GitPython/GitPython-3.1.32.ebuild
index 21ec22655d01..965792916bee 100644
--- a/dev-python/GitPython/GitPython-3.1.32.ebuild
+++ b/dev-python/GitPython/GitPython-3.1.32.ebuild
@@ -29,7 +29,7 @@ SRC_URI+="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-vcs/git
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index cace88bd1825..c2e9d055f12a 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,9 +1,6 @@
-DIST GitPython-3.1.31.gitbundle 9820824 BLAKE2B 47becdf80c8047c3de74f3ad2308f2003629dac970df961e97ae455719690afa8ca4fc08c85fdd01d351980cac5b79265164b92c16e993efb964e4c5d6e62810 SHA512 2b73a9bbe11bf24c1f0cfbc817b1226ae49c52a898f233d23aa8512cb7709adaba57c76afce8aa4416dcc4f16775d0d4138f0059ede51f59a6ccdd27d0f08cd3
-DIST GitPython-3.1.31.tar.gz 195822 BLAKE2B c5644a811e33da4e2983d5b41dc5e223bff23bb817027485fd24598163dc515d1823e8abc5f871a9ad4334827f097dbe7856cf618940cd3ddbe507728253ea2c SHA512 80d5f73db589e239dead268c99092b2429c4d0602e4f9a1e77cce5c68f2eade1651e3da9de68fd485021565f3a2d9b980c286b0d302c58e60011a443b4361e71
DIST GitPython-3.1.32.gitbundle 9676140 BLAKE2B e975f7949f3f3e25f66008b1f2be80dbecb96234405b07b7ef33cb119abde1be434d46deb3c5bed2ec26f4fe35d0f5a1e605c60727812ef4aef2116029f83abd SHA512 b54d5a8e335f6c1b6dfcdd6ccb9c79562ec222cd3d83fd196dab245bed90a9e02d20b191b46c5acdc300f2dede942c686694f0aa005fa5c5c2c2d3e81470a692
DIST GitPython-3.1.32.tar.gz 196978 BLAKE2B 914b0ceebe89b00e5d65c963055c1d64c3125699a4df80e04c5a0ca59181faac5357880767224d3b3cad9b884668299510ea055ae0c228648c1b1c2e5ec048d0 SHA512 b1a4ac7d98b9543454525819357afef4c45dde842a8a8689f5f059312cd45ee10a7a5b22e2417a0a7120b78c0a40addc4f9189789d70ca34d2bc21962fe44fb7
DIST gitdb-4.0.10.gitbundle 1485461 BLAKE2B 5a217c609a402cd7888da1502b25d217812503cd703cda8bce3c7159732c59d7f4bcd52688a5da457f43fde1645a6db79588a6fc8cc8dff5c58e9dcbaef79b9a SHA512 98dba48f75e28eaded791f91c611e07bef73c28a7f8ac58889b05d04f4b3699a85a5be1c829ea3e2f380507a9009f35bc552bb4260564127e2863807f9b4712a
DIST smmap-5.0.0_p1.gitbundle 324544 BLAKE2B 69098c7644abaec7f32226cad7ff3008e49d94c9f7349d0b815223249c20bfd2b51a50474e51864821f30c98f5982e5c35ce9217145a1e5d11326492c41faecc SHA512 4f36ca2c94ddfeb949c880fb52c3b1905d144dd59b95f2f05c93ed7b694dcb128218a2800ca23b721fbeff9a1920e8c3326675098e2ef0361ff6e90c8c2850ba
-EBUILD GitPython-3.1.31.ebuild 2269 BLAKE2B 72c76c3549fe1f7919b582af494621de467468aca72113bc650f71c1b857b10b6b8ee1c3e29c766e85edfca7f8a83668e7e7c05517b4852f69e7ca4b5f8308cf SHA512 9cdd279b2f2f554b59e4956199171095b3bfc5bb6c5d4e67692433ec69bc2d700fcb537b2885c232687104349e9eec58bc24ecf5ec205466b44b6e2f19855827
-EBUILD GitPython-3.1.32.ebuild 2277 BLAKE2B 49c15471a11e60a88b1ebc53c40d030d001e3854b209178fcabaed6ec9e4ec1cea0bbda626944d3e9fe10bbec918a22b80a79e951ce22ebe2c774de7ad0b948c SHA512 9795b18d28cc8fb661ca01f7eca2bc24780945d5bdfca4f35b82e5a7877f08a211e45b35673a83a74aec7cf714b9dd684c9bde34f9c1ed9525cfc4fc9902a8bf
+EBUILD GitPython-3.1.32.ebuild 2269 BLAKE2B 72c76c3549fe1f7919b582af494621de467468aca72113bc650f71c1b857b10b6b8ee1c3e29c766e85edfca7f8a83668e7e7c05517b4852f69e7ca4b5f8308cf SHA512 9cdd279b2f2f554b59e4956199171095b3bfc5bb6c5d4e67692433ec69bc2d700fcb537b2885c232687104349e9eec58bc24ecf5ec205466b44b6e2f19855827
MISC metadata.xml 407 BLAKE2B 49fd8d520d575be1489c299f22595120fad882f055b9cf2d02b87382c6d8f0ff38af694e5584b4da579aa84b82c2f1032e4afb64cafd9f4fe9212a6d67b4a752 SHA512 1bebe1e134eb86a4745cf7e297d45118a2bdd3d8a71d0034294b5c799a9cee763c63b61b34c6707c52f61058f727f4b827dd020d285fc297712b29eb7c1129ef