summaryrefslogtreecommitdiff
path: root/dev-python/GitPython/GitPython-2.1.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/GitPython/GitPython-2.1.11.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/GitPython/GitPython-2.1.11.ebuild')
-rw-r--r--dev-python/GitPython/GitPython-2.1.11.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/GitPython/GitPython-2.1.11.ebuild b/dev-python/GitPython/GitPython-2.1.11.ebuild
deleted file mode 100644
index c995e67a79ea..000000000000
--- a/dev-python/GitPython/GitPython-2.1.11.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="GitPython"
-MY_PV="${PV/_rc/.RC}"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# Tests only work with the GitPython repo
-RESTRICT="test"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb2-2.0.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"