summaryrefslogtreecommitdiff
path: root/dev-python/Faker
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-02 09:45:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-02 09:45:46 +0000
commita0c5e9067531830baf9160de325fe77145f02987 (patch)
tree7eaa500d69f3cea4dfb749d1c6e2eca49b71353f /dev-python/Faker
parentfd0a8825115ac9a61ceee1d37c0fdf4fd2e95b5f (diff)
gentoo auto-resync : 02:11:2023 - 09:45:46
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-19.10.0.ebuild40
-rw-r--r--dev-python/Faker/Faker-19.12.0.ebuild40
-rw-r--r--dev-python/Faker/Faker-19.6.1.ebuild40
-rw-r--r--dev-python/Faker/Faker-19.6.2.ebuild40
-rw-r--r--dev-python/Faker/Faker-19.7.0.ebuild40
-rw-r--r--dev-python/Faker/Faker-19.9.0.ebuild40
-rw-r--r--dev-python/Faker/Manifest12
7 files changed, 0 insertions, 252 deletions
diff --git a/dev-python/Faker/Faker-19.10.0.ebuild b/dev-python/Faker/Faker-19.10.0.ebuild
deleted file mode 100644
index 34d2cdd3a7af..000000000000
--- a/dev-python/Faker/Faker-19.10.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A Python package that generates fake data for you"
-HOMEPAGE="
- https://github.com/joke2k/faker/
- https://pypi.org/project/Faker/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- !dev-ruby/faker
-"
-BDEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},tiff]
- dev-python/validators[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
- epytest
-}
diff --git a/dev-python/Faker/Faker-19.12.0.ebuild b/dev-python/Faker/Faker-19.12.0.ebuild
deleted file mode 100644
index 34d2cdd3a7af..000000000000
--- a/dev-python/Faker/Faker-19.12.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A Python package that generates fake data for you"
-HOMEPAGE="
- https://github.com/joke2k/faker/
- https://pypi.org/project/Faker/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- !dev-ruby/faker
-"
-BDEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},tiff]
- dev-python/validators[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
- epytest
-}
diff --git a/dev-python/Faker/Faker-19.6.1.ebuild b/dev-python/Faker/Faker-19.6.1.ebuild
deleted file mode 100644
index 89d70c602459..000000000000
--- a/dev-python/Faker/Faker-19.6.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A Python package that generates fake data for you"
-HOMEPAGE="
- https://github.com/joke2k/faker/
- https://pypi.org/project/Faker/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc x86"
-
-RDEPEND="
- >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- !dev-ruby/faker
-"
-BDEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},tiff]
- dev-python/validators[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
- epytest
-}
diff --git a/dev-python/Faker/Faker-19.6.2.ebuild b/dev-python/Faker/Faker-19.6.2.ebuild
deleted file mode 100644
index 34d2cdd3a7af..000000000000
--- a/dev-python/Faker/Faker-19.6.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A Python package that generates fake data for you"
-HOMEPAGE="
- https://github.com/joke2k/faker/
- https://pypi.org/project/Faker/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- !dev-ruby/faker
-"
-BDEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},tiff]
- dev-python/validators[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
- epytest
-}
diff --git a/dev-python/Faker/Faker-19.7.0.ebuild b/dev-python/Faker/Faker-19.7.0.ebuild
deleted file mode 100644
index 34d2cdd3a7af..000000000000
--- a/dev-python/Faker/Faker-19.7.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A Python package that generates fake data for you"
-HOMEPAGE="
- https://github.com/joke2k/faker/
- https://pypi.org/project/Faker/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- !dev-ruby/faker
-"
-BDEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},tiff]
- dev-python/validators[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
- epytest
-}
diff --git a/dev-python/Faker/Faker-19.9.0.ebuild b/dev-python/Faker/Faker-19.9.0.ebuild
deleted file mode 100644
index 34d2cdd3a7af..000000000000
--- a/dev-python/Faker/Faker-19.9.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A Python package that generates fake data for you"
-HOMEPAGE="
- https://github.com/joke2k/faker/
- https://pypi.org/project/Faker/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- !dev-ruby/faker
-"
-BDEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},tiff]
- dev-python/validators[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
- epytest
-}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 879b28509b2b..e841ea91bd89 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,17 +1,5 @@
-DIST Faker-19.10.0.tar.gz 1680833 BLAKE2B dcb8e630597f195f5a2e365f7fb362dffecde3828c899e844d6e2ec36f4a4451bac58f3f5ec7f349e81da2ba94f2f0229f061a3b9eb1bd3afbca726e33dd3a09 SHA512 6bd787d3c511e82081869486d36c4512af066736345f293a4b1bba4afa680084d5c9ed2099d6a20aa4dd93c0255cc0623bf3972744280dae7c8492641f1612fe
DIST Faker-19.11.0.tar.gz 1694359 BLAKE2B 7e24dfa58136626e7dc82f458388749cb7d506a9a0ea14bccc13a302f4b89aad7eaf4703b5b59726588ef56e2f80de27496d53b8035ab27b5f0982d838ebbe0e SHA512 df1da4e1e02a612b755f5167941181df0e08d4701f31c52618915a0b5f3f92adbc05ba816d2e975d8123e1fe03ed8e1dbd600519ac7c37b1fa85c86022c39efa
-DIST Faker-19.12.0.tar.gz 1697656 BLAKE2B 630623b9563d1ac7d35977390b0ac6253af0d33833e96dca1abfe9e073bdeb2df522eca64b7aaead0d39ed98c7e4c9f09f1ba8f9bc3a2b31397505c0403f66b3 SHA512 c663f373bee5b435fb8b96c9bc089e4e924bfe3c31af90faa6007b74c7cd7de5d8fad9f22314c0712419b99057bafa97702d5aa3e14a72f212b784bad09f6547
DIST Faker-19.12.1.tar.gz 1697827 BLAKE2B 64398d85fa5492811c9a5319a88f17ecdda5707cd898d123b67c35fbd543ea3cd2c8063b5e1117a2764480d0974f59160e7deba393a1988ea91104aecbbe918e SHA512 2950a5f576733275a783e2b3243c92c2dab3c67939353b9436c8218bed8b1c1b20dbb7e62f20d06210d2c7051c2030a931a93faa6f49e74d10e7a2dc751d60d3
-DIST Faker-19.6.1.tar.gz 1668966 BLAKE2B 48e1d0c658e7cd482660b797e5ac8e107c84e7d2be9ab86e55cb5f0da662ed742565c1f5a3176d1f2588b8ffafcc37e7dbd072c78e5b1ab94bea8678ea9f1d48 SHA512 1511f03cb41f70a22784a8dc1cdb5b58fdc19fc6f67d4a414a9b15619d019ec6b6564b7fa50db03535aaa3650ae93e4c948c732ae65e61652d7469d9ad83db36
-DIST Faker-19.6.2.tar.gz 1680331 BLAKE2B 3453c531a1860c3e1782e24ad2d892d8291e1fafc698483639f43e7bdd281cee6e5c8bf7e60181db72011c1434ca3bc1c7f2a877ce136bf6e4f00286249033b9 SHA512 8a7929135ad562fafc2c95408ed644e7b965215d3e9ea2f2682e2aa2a5bab9759ab42d67380c7f8c89cf099cb65ad0dd13f6575c028f20550ef157f7db90102b
-DIST Faker-19.7.0.tar.gz 1680303 BLAKE2B 80169d818749003b6961adb85969eb025c38b81d8d333466b304815396aaf646b1a9e1fb9457e68292600576fa6a91ae1851af85e2bc3403dfa383f223fe49ab SHA512 f9b47d0bf52f5ba3a300222d45ad087eedbdf9ed7b1cae11cb600834f8919247e9000211157811dc016be7040925ec7930a407e8ea497ca87cae382d1edd2a56
-DIST Faker-19.9.0.tar.gz 1680879 BLAKE2B 64c7ea0e86a7c8032ec4c5172f369053d82252382fcc6b9d288d89229da53167fad016207843d2a7fc9b0c874b620aee183b8e471fce47ce419e65496d8a7c84 SHA512 f8445b15857e871ba703cd869e22681e0985065f2513f9916d59af61afd2f1de1a2947b692ea7487771d4f83e98ff574b23a8a5c833a4f406c68157adc0d251a
-EBUILD Faker-19.10.0.ebuild 852 BLAKE2B 6199226fba1ab7dd41d9ca1c41ecac47961e48a0f182f94b271fd63c917ccc0bc33fb32da7acd5de89e8a771bbf4f23ced52badbcfc10894884c0e2ed49a48c3 SHA512 e1b5a6c177d6aef7074bf5293b41b5e558850edbc2deb4c950c01a0586376fa0f824762ff50f468d7a21eb8461658524f2f5b26f77cbad21969db1d58ee79f90
EBUILD Faker-19.11.0.ebuild 850 BLAKE2B 8d3fd78b61d02c0b14c195f2e821971eaf28fbb41295d42347a4b0f2a4fce855f5a07e6922c1c54457bee26cdab39b9d4bd07cd0e239f8fa7c007fbebf630d37 SHA512 c0cc9bfc35275d202e43cc5b088c13808af9c2dc82a6a6a95f6d46aae6b851e0d303d337bb64290eedd841d2b2abaa1423e08c399dcaa4cd98701d6bafba3b17
-EBUILD Faker-19.12.0.ebuild 852 BLAKE2B 6199226fba1ab7dd41d9ca1c41ecac47961e48a0f182f94b271fd63c917ccc0bc33fb32da7acd5de89e8a771bbf4f23ced52badbcfc10894884c0e2ed49a48c3 SHA512 e1b5a6c177d6aef7074bf5293b41b5e558850edbc2deb4c950c01a0586376fa0f824762ff50f468d7a21eb8461658524f2f5b26f77cbad21969db1d58ee79f90
EBUILD Faker-19.12.1.ebuild 852 BLAKE2B 6199226fba1ab7dd41d9ca1c41ecac47961e48a0f182f94b271fd63c917ccc0bc33fb32da7acd5de89e8a771bbf4f23ced52badbcfc10894884c0e2ed49a48c3 SHA512 e1b5a6c177d6aef7074bf5293b41b5e558850edbc2deb4c950c01a0586376fa0f824762ff50f468d7a21eb8461658524f2f5b26f77cbad21969db1d58ee79f90
-EBUILD Faker-19.6.1.ebuild 843 BLAKE2B f7afed3a820435e2ac3dc3584d8054556c174b182b29dbce82e980a718d476c6b586e351177c60df8780521f91cc24bb75f3aa76811146cad6bb6f882fb04e66 SHA512 82841909516426e131179bb6f8c99c45e483bd450ace91472b530a5f97b6571e45df254f5d2b1d0d44207f08aa10421c05d280f027eb3c1dc3cfd1bbc677e98c
-EBUILD Faker-19.6.2.ebuild 852 BLAKE2B 6199226fba1ab7dd41d9ca1c41ecac47961e48a0f182f94b271fd63c917ccc0bc33fb32da7acd5de89e8a771bbf4f23ced52badbcfc10894884c0e2ed49a48c3 SHA512 e1b5a6c177d6aef7074bf5293b41b5e558850edbc2deb4c950c01a0586376fa0f824762ff50f468d7a21eb8461658524f2f5b26f77cbad21969db1d58ee79f90
-EBUILD Faker-19.7.0.ebuild 852 BLAKE2B 6199226fba1ab7dd41d9ca1c41ecac47961e48a0f182f94b271fd63c917ccc0bc33fb32da7acd5de89e8a771bbf4f23ced52badbcfc10894884c0e2ed49a48c3 SHA512 e1b5a6c177d6aef7074bf5293b41b5e558850edbc2deb4c950c01a0586376fa0f824762ff50f468d7a21eb8461658524f2f5b26f77cbad21969db1d58ee79f90
-EBUILD Faker-19.9.0.ebuild 852 BLAKE2B 6199226fba1ab7dd41d9ca1c41ecac47961e48a0f182f94b271fd63c917ccc0bc33fb32da7acd5de89e8a771bbf4f23ced52badbcfc10894884c0e2ed49a48c3 SHA512 e1b5a6c177d6aef7074bf5293b41b5e558850edbc2deb4c950c01a0586376fa0f824762ff50f468d7a21eb8461658524f2f5b26f77cbad21969db1d58ee79f90
MISC metadata.xml 498 BLAKE2B c9b7885dc7d34f2263068624a6b07ac6f1ec8078cc11abb6137612ba57edffefc48dae2708284aa83ecc941ebb2d3b8a87a143648e404a0683e75bb6c078f4e2 SHA512 0b385bbbfbb026803526e43c6c43965ff75f42d3ab133603708b187686aac29de508856e5e8ae7622a66b99032efa97f95c21625e10d074c858d8aff7446a312