summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-8.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/Faker/Faker-8.12.0.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/Faker/Faker-8.12.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-8.12.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-8.12.0.ebuild b/dev-python/Faker/Faker-8.12.0.ebuild
new file mode 100644
index 000000000000..12e618b6e887
--- /dev/null
+++ b/dev-python/Faker/Faker-8.12.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest