summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-8.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 11:59:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 11:59:22 +0100
commit6abaca02d36f161c81e2d5ee467719a89f88b2c5 (patch)
tree3caa7c096e2eccd186e20aa71bda508c5c50fb23 /dev-python/Faker/Faker-8.10.2.ebuild
parentb49088575eb777ced2551f484da86317332d6087 (diff)
gentoo resync (2) : 24.07.2021
Diffstat (limited to 'dev-python/Faker/Faker-8.10.2.ebuild')
-rw-r--r--dev-python/Faker/Faker-8.10.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-8.10.2.ebuild b/dev-python/Faker/Faker-8.10.2.ebuild
new file mode 100644
index 000000000000..ada44c6701ce
--- /dev/null
+++ b/dev-python/Faker/Faker-8.10.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest