summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-19.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-21 11:14:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-21 11:14:12 +0100
commit03633f33c2184a87f7a4cebae72542343cf0490c (patch)
tree51a044dec7586be070d68ebb95d563883b02c726 /dev-python/Faker/Faker-19.6.2.ebuild
parentc0e834f207174ee62c093753cea0176c947a9ba1 (diff)
gentoo auto-resync : 21:09:2023 - 11:14:12
Diffstat (limited to 'dev-python/Faker/Faker-19.6.2.ebuild')
-rw-r--r--dev-python/Faker/Faker-19.6.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-19.6.2.ebuild b/dev-python/Faker/Faker-19.6.2.ebuild
new file mode 100644
index 000000000000..fbbb3c11a92d
--- /dev/null
+++ b/dev-python/Faker/Faker-19.6.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}