summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-18.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-22 06:41:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-22 06:41:43 +0000
commitaaeed2da8906f11cba80355688015d74b01cc604 (patch)
tree5d714c0600fd3f185c0ddb96eef8dd41a5f3ec5e /dev-python/Faker/Faker-18.3.0.ebuild
parent23b767af73549eeb4dd3069e09d0f2fcb88669a8 (diff)
gentoo auto-resync : 22:03:2023 - 06:41:43
Diffstat (limited to 'dev-python/Faker/Faker-18.3.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-18.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-18.3.0.ebuild b/dev-python/Faker/Faker-18.3.0.ebuild
new file mode 100644
index 000000000000..f1e5f5fe409a
--- /dev/null
+++ b/dev-python/Faker/Faker-18.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest