summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-15.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 19:42:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 19:42:47 +0100
commit174cda0f83caffc0ee683143e9b2c501ef589cc1 (patch)
treee60c3821d3cb0c6c19deaf8ad9c846f57791f3bf /dev-python/Faker/Faker-15.1.1.ebuild
parent22b51dcc430fb550fd692463a56cdcd5b18efd61 (diff)
gentoo auto-resync : 13:10:2022 - 19:42:47
Diffstat (limited to 'dev-python/Faker/Faker-15.1.1.ebuild')
-rw-r--r--dev-python/Faker/Faker-15.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-15.1.1.ebuild b/dev-python/Faker/Faker-15.1.1.ebuild
new file mode 100644
index 000000000000..5db43c1f3c0f
--- /dev/null
+++ b/dev-python/Faker/Faker-15.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest