summaryrefslogtreecommitdiff
path: root/dev-python/ConfigArgParse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/ConfigArgParse
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/ConfigArgParse')
-rw-r--r--dev-python/ConfigArgParse/ConfigArgParse-1.5.3.ebuild35
-rw-r--r--dev-python/ConfigArgParse/Manifest3
-rw-r--r--dev-python/ConfigArgParse/metadata.xml13
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/ConfigArgParse/ConfigArgParse-1.5.3.ebuild b/dev-python/ConfigArgParse/ConfigArgParse-1.5.3.ebuild
new file mode 100644
index 000000000000..a65040b42d52
--- /dev/null
+++ b/dev-python/ConfigArgParse/ConfigArgParse-1.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
+HOMEPAGE="
+ https://github.com/bw2/ConfigArgParse/
+ https://pypi.org/project/ConfigArgParse/"
+SRC_URI="
+ https://github.com/bw2/ConfigArgParse/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}
diff --git a/dev-python/ConfigArgParse/Manifest b/dev-python/ConfigArgParse/Manifest
new file mode 100644
index 000000000000..d3856862d286
--- /dev/null
+++ b/dev-python/ConfigArgParse/Manifest
@@ -0,0 +1,3 @@
+DIST ConfigArgParse-1.5.3.gh.tar.gz 32732 BLAKE2B a9dec6b3ebbb7aed000651adf76ac76994b56d00236789a75f7da6ccc76e6b87e0dd292c260a768c0d402811b69e55d417b25032363429535cef4e09e0be5d00 SHA512 bdc0340bd92cfd5319743a4860af80fc2352f38b156031856c2b39b8c8ad59461281009030c4451dd464334a829b8143c765979cfc9b8ccbe9fbdcb0e08ac7b4
+EBUILD ConfigArgParse-1.5.3.ebuild 705 BLAKE2B 5adac39067b17eeeb9a379787be5b61223935caf9ee680ea21bf7f19f39cc6661b8137e81efaf0889c222d268416d0f74a0d538b46b46fc227ea9e34da7bb2ab SHA512 991a019756144ccbfc82c7a891d018487ca63bce9e38ebf527e8e2548071200cf817e6b7f5c48f0f2f89ac73aae7d20c22687ca5c07fcfffc964d6edfae52452
+MISC metadata.xml 413 BLAKE2B 06bc019926862278b7c7a0f602f737f0ee20df1271bfd4ccd2e96e602b537403ae641f4196496ed0af92830a457af330def85f4d4b30ae2733510b82c0589310 SHA512 df63096d97d9835ee72b03ee144cb1cbed4f29644380c8711718b570938e0ed1dff9bca15b77c91df052f3f68e10633d1880d553cb8c8d7e1827714355dd8593
diff --git a/dev-python/ConfigArgParse/metadata.xml b/dev-python/ConfigArgParse/metadata.xml
new file mode 100644
index 000000000000..f46051e99f5b
--- /dev/null
+++ b/dev-python/ConfigArgParse/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">ConfigArgParse</remote-id>
+ <remote-id type="github">bw2/ConfigArgParse</remote-id>
+ </upstream>
+</pkgmetadata>