summaryrefslogtreecommitdiff
path: root/dev-python/Babel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/Babel
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.5.0.ebuild49
-rw-r--r--dev-python/Babel/Babel-2.5.3-r1.ebuild52
-rw-r--r--dev-python/Babel/Babel-2.5.3.ebuild49
-rw-r--r--dev-python/Babel/Babel-2.6.0.ebuild50
-rw-r--r--dev-python/Babel/Babel-2.7.0.ebuild43
-rw-r--r--dev-python/Babel/Babel-2.8.0.ebuild2
-rw-r--r--dev-python/Babel/Manifest11
7 files changed, 2 insertions, 254 deletions
diff --git a/dev-python/Babel/Babel-2.5.0.ebuild b/dev-python/Babel/Babel-2.5.0.ebuild
deleted file mode 100644
index 97b799640078..000000000000
--- a/dev-python/Babel/Babel-2.5.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Babel-2.5.3-r1.ebuild b/dev-python/Babel/Babel-2.5.3-r1.ebuild
deleted file mode 100644
index 874d265301f3..000000000000
--- a/dev-python/Babel/Babel-2.5.3-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x TZ=UTC
-
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test -vv || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Babel-2.5.3.ebuild b/dev-python/Babel/Babel-2.5.3.ebuild
deleted file mode 100644
index f7f8ed3fbd8f..000000000000
--- a/dev-python/Babel/Babel-2.5.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Babel-2.6.0.ebuild b/dev-python/Babel/Babel-2.6.0.ebuild
deleted file mode 100644
index 2befd155de20..000000000000
--- a/dev-python/Babel/Babel-2.6.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x TZ=UTC
-
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test -vv || die
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
diff --git a/dev-python/Babel/Babel-2.7.0.ebuild b/dev-python/Babel/Babel-2.7.0.ebuild
deleted file mode 100644
index f5e3d5e4db18..000000000000
--- a/dev-python/Babel/Babel-2.7.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- test? ( dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx docs
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x TZ=UTC
-
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/Babel/Babel-2.8.0.ebuild b/dev-python/Babel/Babel-2.8.0.ebuild
index cdfad7184e95..f5221330d97c 100644
--- a/dev-python/Babel/Babel-2.8.0.ebuild
+++ b/dev-python/Babel/Babel-2.8.0.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index b5c767deb31b..58cb928b3795 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,12 +1,3 @@
-DIST Babel-2.5.0.tar.gz 6612353 BLAKE2B 85268f0226f1db019fb906da0dfbbc6b6aa199ab491e9d767c932fb5ca77cb6d86328ebaa9c6eb61fb8d28c8e566babd435cdcee9b900c3c680d0dfb49c2bcac SHA512 b24b74121695e0068fb28a6294d4b5b2065e94dcd62ca0d70c8fde3a00cb5ff111480505594460989c6f67a75935f55e153b1b493f917317d2c5ee0f0d7921fc
-DIST Babel-2.5.3.tar.gz 6611941 BLAKE2B 99b71642b00a853fea844220c0ce5ef2fe425906cbdd1618e31f39b60d16382d54ff5e00c493153eee2be8894edc8c96e57fc2703620db5bafcf7b7a4f1b72ef SHA512 1a41f69141da9f66e27110e7a1a5955f76d8ae9353ff7e54182c5bb6ca16e8b4799031e4df1049af54de513da9f101e171e4312b2e7775f2cab9116d5b50c0fb
-DIST Babel-2.6.0.tar.gz 7960433 BLAKE2B 0edc3b3391eb3d479eae9a223668af96e1ec47b84b13d0bb66c0e1772dc5de8321ee06f0d0dfeb6c9364a724286d0ee50a3ab4c2ea789894057fca39bb11dc46 SHA512 a87f26c25f1e48a64d1e7ee112bc0c325a6268e0e716a81cb6814a53f0add8f3d579babd2ba064f160298ebe3ac9711aa5d28f112582ee287767b6ed8427b6e0
-DIST Babel-2.7.0.tar.gz 8244870 BLAKE2B 515f1e033d408e4f5fdcf1d1720a58e429523611a2a01d62bab95b96a2187ed0594e4c05678ac3311d6570bca2bf90b08818c233bf28a2fb03fdba923f5e6401 SHA512 96314c7b26f6915a825e0344fa06e4f1d9a71b97a52b16f2f696c2e81c69318974547620135912b11edb95668a717ec49f1be68eef5a4753092d8e4cdc39a1e5
DIST Babel-2.8.0.tar.gz 8444381 BLAKE2B ea3757182464770f47d3253e77bece7b64c84558e7a19fc55759198bfa55c6d8156d27e9de7b796b62eefd93e458c7e00b2014dd23e4ed7383f5bc9785d1a332 SHA512 f9687b36176c146a8ace073197111463d24fca343bb1dbee8b0e37a7f37b68b4cd77ffbe3bf14a20f8f64c701aa860e0b5e6076658a95dbee2556f0688d68d91
-EBUILD Babel-2.5.0.ebuild 1464 BLAKE2B ce80e90c1217ec30b80a19ddc0d4cf67072901caf948924ba55154ea11ad3d5a94af5ce178da8e15dda005c7546bd78be7bbb9d70434ac59daa79fa85ed40e10 SHA512 b004b7ca8660576dd2574ccf1bb23b98abce41e27d5cc693aead50dc19b20b460236f2064162a0f841c9f6caed241b5c663a8738b7fd9ea207e5af81b1c9baef
-EBUILD Babel-2.5.3-r1.ebuild 1527 BLAKE2B a9d04c8ee8b1e76b7b483eb22d0094344eec25f3ff1ca1cab2482d2e49b2a47e2024ff1dce922b2041d8c56cf267ca9e2e3f9763d4cb93709d2ab754cfa68c5e SHA512 a5e17cce811b51f244b56f8af450af787571d6b5c5aec06aac2d01789ea734106188144748fe7ea4e7084f222488e6b27a30ccccabc3116a412f9c61934cee84
-EBUILD Babel-2.5.3.ebuild 1465 BLAKE2B f8794d2bc25d250a1bd6c7cc4c4fe7c8ed724c34bf40b545affebf4c1095203eb6a25a82cdea46aba90f125654bd73609553107bc23cd01cd9ebbfdd47a81302 SHA512 be4f71205977fae78da1bb2dbaf055f61d61a8fac526da8480d4c33cb0f3c1842ab21b500493f6477cd8c5cb3395251e175d3616dc156c605c6747b56d66c117
-EBUILD Babel-2.6.0.ebuild 1463 BLAKE2B 081b26496e6270df6e783dbfc7ff9083e7bcfc53c8d1424796a0ebe256da725553374e92aa131b3bd3e5eff57cad94a631b9637f9c974c799f03c9ee4f949ac3 SHA512 8840f0784d069431b4ab9e992c526c962b4a8d9f86a3a6036ab3f635106cb88042d950536148b2799528aebadb08584cb2d0b53d206b49f90a47d9ead42d9760
-EBUILD Babel-2.7.0.ebuild 1320 BLAKE2B d4e045f9ba204312145087e35316aff7904eb5b1f78c7516424ee5c4fef2be67f76b53dad428030e2ac3feebd3959b8c78d34287cfff51c1510e591b704bb2f3 SHA512 a10fc839616239843862f5abaa6322b2cb614609a1bcf9d1d6a6a1d60d9bc8754fc862ee0eff0b934d49bf14b71f213e42a9f0bad1bae64d452bdb1f87a9f05e
-EBUILD Babel-2.8.0.ebuild 810 BLAKE2B cae9e5a7ed2efa7549d7d0daa5ce25faba1e4130be727801fae5fabde0f88bbafb3bb5d0008614baab6bab4699c555399d797306a05c7d60e48c32654bfbaeba SHA512 b538ead11d8a19180849c0f9542ee6ebc034c6d7fc06c38387ad7faec9ded5f5ab599b1484a044a2179559a5014e19a607335843139978b457f31ceb07d59af4
+EBUILD Babel-2.8.0.ebuild 797 BLAKE2B f6c8f495f99ec5718c09f8da40825430d5900723c09737a046d1a99c927a8392ba0903c2611334f20a6582cdf230734327c5c4eaf1c3bcdf5ad9fa0e8e642d06 SHA512 29e5664f4728fa6bacc9f791ef29bad5e7f80b3de6b3c18b9bcd58b830f374564ed622c93bc3d74a836c34514427ec6d2372f5c3b71cda048b0651ce80ad7035
MISC metadata.xml 839 BLAKE2B d9916ce88ce8436bb28d15300e78013e1c9e0f88f385a369c0ad6840f0fe81ad136052a3c257cef50a2fd86500bcde2b652ad0ed664f95d6affa4ccc8770445b SHA512 3688c1488c552b84c685d0aeb6251aea4f9d41be3db3aeb226291655107e1332df13445545b3742587e133de7468a40f22ca53fa67fd8d2e0db570069498654f