summaryrefslogtreecommitdiff
path: root/dev-python/Babel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/Babel
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.1.1.ebuild49
-rw-r--r--dev-python/Babel/Babel-2.3.4.ebuild52
-rw-r--r--dev-python/Babel/Babel-2.4.0.ebuild48
-rw-r--r--dev-python/Babel/Babel-2.5.0.ebuild48
-rw-r--r--dev-python/Babel/Manifest12
-rw-r--r--dev-python/Babel/files/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch30
-rw-r--r--dev-python/Babel/metadata.xml19
7 files changed, 258 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.1.1.ebuild b/dev-python/Babel/Babel-2.1.1.ebuild
new file mode 100644
index 000000000000..8d2b76ef7aba
--- /dev/null
+++ b/dev-python/Babel/Babel-2.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ export BUILD_DIR
+ py.test || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Babel/Babel-2.3.4.ebuild b/dev-python/Babel/Babel-2.3.4.ebuild
new file mode 100644
index 000000000000..c333bf32f4e1
--- /dev/null
+++ b/dev-python/Babel/Babel-2.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch
+)
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ py.test || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Babel/Babel-2.4.0.ebuild b/dev-python/Babel/Babel-2.4.0.ebuild
new file mode 100644
index 000000000000..9ec087d4bd7e
--- /dev/null
+++ b/dev-python/Babel/Babel-2.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ py.test || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Babel/Babel-2.5.0.ebuild b/dev-python/Babel/Babel-2.5.0.ebuild
new file mode 100644
index 000000000000..a126cf190d9e
--- /dev/null
+++ b/dev-python/Babel/Babel-2.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ py.test || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
new file mode 100644
index 000000000000..281316bc011b
--- /dev/null
+++ b/dev-python/Babel/Manifest
@@ -0,0 +1,12 @@
+AUX 2.3-Fix-the-way-local-time-is-constructed-in-tests.patch 1297 SHA256 9a408f99a8dda51105b57bbde07eccab7fd81cce6e28bd4090a6f00be42b4c5f SHA512 271219651c716d5224887de5ea2c1f49cba9d4a9f2177a3f902bf59cb32a639803db39cb5b4af4e4fc201d1188ca94d0a27bd0ec0a583562eb02bbfc263e4147 WHIRLPOOL ea08cc2e472a45ae52ae4e43721396a98f2e64867e9af27e26fb1fc26b750733535122ff124b8dd3ef6ded76626c51c420404cda4358792b7eaffb60557217ba
+DIST Babel-2.1.1.tar.gz 3437647 SHA256 7fb6d50effe88a087feb2036cb972fd7a893bf338361516f1a55a820bf7b5248 SHA512 ec7ebb8648101588eecc72913adc45c0593ed6ee5f10874edcd4b932959f9552edcecc8e2ec966dae6ef5e8adb23341f1a4f87ea2d9e6cbba57a9b8b0a352a94 WHIRLPOOL 812badf14a74fa391851aaae048ec5d815d6d8f7abce8b918f036243cc45d91ca97281614c2ef139797719077ef4880cfafce88e9d718b3cd633ed7303e4cfd7
+DIST Babel-2.3.4.tar.gz 6866920 SHA256 c535c4403802f6eb38173cd4863e419e2274921a01a8aad8a5b497c131c62875 SHA512 1fdba01946e7a8ebe3fef23843e23707cd060b0a179d775e29f938318d824e8779df2852fb8bbd18f61fc47de33af5d988c509dc67f54ea4cb3a4a66767869a5 WHIRLPOOL ea265abb1a9f6de890c6fa8e78ef49eab2adbd47916f30d19d3d807220c6598c14a93527ba85b92b8e6fbc40571c706cf233d17d7ee65448e3270ead38b7c71a
+DIST Babel-2.4.0.tar.gz 6607513 SHA256 8c98f5e5f8f5f088571f2c6bd88d530e331cbbcb95a7311a0db69d3dca7ec563 SHA512 4e1341144dfb319c172a446facc47204c9b9f49972c8646b62e082975d8ec41c35e503e610d7114ef5346a5c073e87ed8d40a65a60d9540fb7ca947681cc0beb WHIRLPOOL 58184100c060640316a1517ce70db2b5f9143fa10fb24b2b9d4069c8ecb638b914fbe405d0ab8a51628b98a00a7db4c462d6faff8b2b98a4cb5cd4ca3e7f5abf
+DIST Babel-2.5.0.tar.gz 6612353 SHA256 754177ee7481b6fac1bf84edeeb6338ab51640984e97e4083657d384b1c8830d SHA512 b24b74121695e0068fb28a6294d4b5b2065e94dcd62ca0d70c8fde3a00cb5ff111480505594460989c6f67a75935f55e153b1b493f917317d2c5ee0f0d7921fc WHIRLPOOL a13f570ba56282699eb71825c4210b0f57b731e5d105109a2fbd4b92bb3929c5435fe7defdf9121f071cf4129d5bbdd93a8a9633f6dd7e8762df1b1a6b5fb788
+EBUILD Babel-2.1.1.ebuild 1495 SHA256 15f12cf7b13f2cab4e5f7aa4530db3e3813c750524fdb0730b6ded7495169419 SHA512 85b81166d42016f337e903680a762f4eb7affc4eda2318b59cdc96552ba75185486eaa1071a82a13a60946e8a90fcbd7fb89cadfb538310bdd8fb2cd6c7fb5dc WHIRLPOOL ca9b6544b816967d05d2a283969ac9a83eaa75d73b3817b21547ef6cc0a77750c3cad3c4fcc04a2cb1641b5b5d5261e70d1ce7a1b38b7ea22b4dfd6802a5b68c
+EBUILD Babel-2.3.4.ebuild 1560 SHA256 772044f20b33d47022458cbc331d94155082f28273e65c5a162c7df9b7334589 SHA512 a88248213a2e4aaf0a9573b361fc1630546ffc2a2663dccba5ca069532a58196b05e144be534a26f20a11cc1b4ae3683ec42f035d4ae1bacaebf80c92221da7e WHIRLPOOL ee161d098d84481a0a024e494d4b02983d1a874904d4863431058c94a5b39d942a36a78f0e2ebd36b339ff775b64b2329bd07120e585248c947ae6f0c6ff5b52
+EBUILD Babel-2.4.0.ebuild 1474 SHA256 928436341df76d87e8cbfe09c20b4095d11da9a564e4d28d4dfdb606df625c27 SHA512 1afd189043b07ad3881de87fd5c38c1432dfae22b4375457dc7135d420a4fd3e0f12062f7011828835ce580de81263865255c83ee25ecaf66e1742005388f93d WHIRLPOOL 2fa54b13307db50a7860547cbd2fcaba020c49015049c8ee5ee6d3ddbc32d5eccdc198e44e63ddadc7f70ebd459c8db4cfbf5e15c92ca2d425f871b66cd6a687
+EBUILD Babel-2.5.0.ebuild 1478 SHA256 8acd82e6691122d20b4a8156057772ce681d50db9af35cdb59b617e74973f912 SHA512 ba5ca1a1b6f0d2c4fcb9cd99c2b884e1b2538e6da545cc3d7b5d20c2ae7b2e4aedcfd910ba128401a970215d21851a6919765008e37e38e4ad1e1fa38160abc4 WHIRLPOOL b4795b93bfa11103e2c0ec1bd08dc11c9969ba5d3073694be16ce0d1aac5420d07679f6f942b226d1006f4e1f894966f6cbf712cac0ebcb780f1f9db8556dbef
+MISC ChangeLog 6102 SHA256 87748b8a8870e0bb618efbad76e80d2a0bbfa9346959e3f65eaa3bd14cb60696 SHA512 632d4605205c5cfd82b561c35a51c00ba2cefa3d60c30829a108b7c001642663228ef63ec8b54d39ac2d23482d9bd6f6d62bd760280e580f649e19ecd989096e WHIRLPOOL c797ddb6a88883a0f971e812266eef59998b796e52cfa1e303468f89113270689d88cf7ee7b7e60185668dcaa897a0b2c842092ffa0c9a4bedc83a7368758c4f
+MISC ChangeLog-2015 8689 SHA256 ecc462e7e34189d36faa9ea697605f1244348b67f11ffb6cd7d583a745abdf86 SHA512 857b2c63f47d46918241e51a8eca25d53cc13a2c0335775a3314fa3e15d819c05fe3cd7708ee8be2f7be0bc88a8abe913d61f403726efc94a6412d654e114409 WHIRLPOOL e22a0a1136f0e01d76ea94aaa4106dfb208bf42757f676177f595716c3401f36c7e744123d9664a4062acaf4da9a2c4804a32432cd7e14e946953bd7cddf98c8
+MISC metadata.xml 691 SHA256 11a8c01d89f13c9d7bbb9a48bcfd473dd13a189c149b8e4c611d2600a2ceba59 SHA512 91b4f1fa5ceebae1ded51ef3bee9a5c47380709eb3ededd83f8cbb20a85c45acd0603fb8c7244910c15037036056047b074b79c5d6668f68c44d29cb507e76e7 WHIRLPOOL 863e24d10729a4622ed94fb85f2305ebe291bba75b729869f91d34514eb3585a903e907ec7a4543b2e33e2cad49b1d1fea74c3774ed42d407e1ecd340d65c651
diff --git a/dev-python/Babel/files/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch b/dev-python/Babel/files/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch
new file mode 100644
index 000000000000..fdfb31d7c62a
--- /dev/null
+++ b/dev-python/Babel/files/2.3-Fix-the-way-local-time-is-constructed-in-tests.patch
@@ -0,0 +1,30 @@
+From 476515c2418039e471656f47efbfc43e5230c1fd Mon Sep 17 00:00:00 2001
+From: Isaac Jurado <diptongo@gmail.com>
+Date: Sun, 29 May 2016 10:50:42 +0200
+Subject: [PATCH] Fix the way local time is constructed in tests
+
+In summer time zones, the test for "get_timezone_name" failed because the
+construct used to obtain a local time did not deal properly with DST offsets.
+As recommended by pytz, it is better to convert to local time from UTC.
+---
+ tests/test_dates.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tests/test_dates.py b/tests/test_dates.py
+index 3bb9e8b..b0d093e 100644
+--- a/tests/test_dates.py
++++ b/tests/test_dates.py
+@@ -624,8 +624,9 @@ def test_get_timezone_name():
+ assert dates.get_timezone_name(tz, locale='en', width='long',
+ zone_variant='daylight') == u'Pacific Daylight Time'
+
++ localnow = datetime.utcnow().replace(tzinfo=timezone('UTC')).astimezone(dates.LOCALTZ)
+ assert (dates.get_timezone_name(None, locale='en_US') ==
+- dates.get_timezone_name(datetime.now().replace(tzinfo=dates.LOCALTZ), locale='en_US'))
++ dates.get_timezone_name(localnow, locale='en_US'))
+
+ assert (dates.get_timezone_name('Europe/Berlin', locale='en_US') == "Central European Time")
+
+--
+2.13.0
+
diff --git a/dev-python/Babel/metadata.xml b/dev-python/Babel/metadata.xml
new file mode 100644
index 000000000000..c57331eb483e
--- /dev/null
+++ b/dev-python/Babel/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ A collection of tools for internationalizing Python applications
+ Babel is composed of two major parts:
+ - tools to build and work with gettext message catalogs
+ - a Python interface to the CLDR (Common Locale Data Repository),
+ providing access to various locale display names, localized number
+ and date formatting, etc.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">Babel</remote-id>
+ </upstream>
+</pkgmetadata>