summaryrefslogtreecommitdiff
path: root/dev-python/Babel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/Babel
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.5.0.ebuild48
-rw-r--r--dev-python/Babel/Babel-2.5.3-r1.ebuild51
-rw-r--r--dev-python/Babel/Babel-2.5.3.ebuild48
-rw-r--r--dev-python/Babel/Babel-2.6.0.ebuild49
-rw-r--r--dev-python/Babel/Manifest8
-rw-r--r--dev-python/Babel/metadata.xml22
6 files changed, 0 insertions, 226 deletions
diff --git a/dev-python/Babel/Babel-2.5.0.ebuild b/dev-python/Babel/Babel-2.5.0.ebuild
deleted file mode 100644
index f764c52dc983..000000000000
--- a/dev-python/Babel/Babel-2.5.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Babel-2.5.3-r1.ebuild b/dev-python/Babel/Babel-2.5.3-r1.ebuild
deleted file mode 100644
index bbc2fbebb31f..000000000000
--- a/dev-python/Babel/Babel-2.5.3-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x TZ=UTC
-
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test -vv || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Babel-2.5.3.ebuild b/dev-python/Babel/Babel-2.5.3.ebuild
deleted file mode 100644
index f056341ba246..000000000000
--- a/dev-python/Babel/Babel-2.5.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Babel/Babel-2.6.0.ebuild b/dev-python/Babel/Babel-2.6.0.ebuild
deleted file mode 100644
index aaf13989c173..000000000000
--- a/dev-python/Babel/Babel-2.6.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Make the tests use implementation-specific datadir,
- # because they try to write in it.
- sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
- -i tests/messages/test_frontend.py || die
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x TZ=UTC
-
- # Create implementation-specific datadir for tests.
- cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test -vv || die
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
deleted file mode 100644
index abfa44fcc470..000000000000
--- a/dev-python/Babel/Manifest
+++ /dev/null
@@ -1,8 +0,0 @@
-DIST Babel-2.5.0.tar.gz 6612353 BLAKE2B 85268f0226f1db019fb906da0dfbbc6b6aa199ab491e9d767c932fb5ca77cb6d86328ebaa9c6eb61fb8d28c8e566babd435cdcee9b900c3c680d0dfb49c2bcac SHA512 b24b74121695e0068fb28a6294d4b5b2065e94dcd62ca0d70c8fde3a00cb5ff111480505594460989c6f67a75935f55e153b1b493f917317d2c5ee0f0d7921fc
-DIST Babel-2.5.3.tar.gz 6611941 BLAKE2B 99b71642b00a853fea844220c0ce5ef2fe425906cbdd1618e31f39b60d16382d54ff5e00c493153eee2be8894edc8c96e57fc2703620db5bafcf7b7a4f1b72ef SHA512 1a41f69141da9f66e27110e7a1a5955f76d8ae9353ff7e54182c5bb6ca16e8b4799031e4df1049af54de513da9f101e171e4312b2e7775f2cab9116d5b50c0fb
-DIST Babel-2.6.0.tar.gz 7960433 BLAKE2B 0edc3b3391eb3d479eae9a223668af96e1ec47b84b13d0bb66c0e1772dc5de8321ee06f0d0dfeb6c9364a724286d0ee50a3ab4c2ea789894057fca39bb11dc46 SHA512 a87f26c25f1e48a64d1e7ee112bc0c325a6268e0e716a81cb6814a53f0add8f3d579babd2ba064f160298ebe3ac9711aa5d28f112582ee287767b6ed8427b6e0
-EBUILD Babel-2.5.0.ebuild 1471 BLAKE2B c9c9e00923f2b27400a7898c0bb69025840bf058569f52220699cd468980f17132faebca0b5710f9fd797fd4857d49d8d5768ef05d4768908b7dbaa41245e36a SHA512 eb9807bb50fe367a92cff89826189f29135c08006e77aff84d0228ecf6e772011050148aa4e655636206aaca7ba7281818ee448a7d457084f38c8ac7bfd7c511
-EBUILD Babel-2.5.3-r1.ebuild 1539 BLAKE2B 6842ee24132b2aa410561db4fb283deaab493d07b9300c4e619090ac9aac0a4e43142d0c966af537814f3a4a2478e9587c43bb2005f3402c3f2ee56cdc6417c0 SHA512 2964da6282dcb0b301be414d89c3e665dc573a8d6574590f1b941d69f250ee29ee2669fc9685f2f624727df6910f61b660495ab8cc82a88de7359b32564ef0f7
-EBUILD Babel-2.5.3.ebuild 1472 BLAKE2B 130348dc2960f5ce61e4708069826ef73fb18c0e24117e514a0329843448037fd0534cf649c18af2fe6b04452b1b777c5b64bff37cc23c071d4a7b56827674a2 SHA512 6a23c39ef56ec915b73128eafefb895fa19a1743159a5578d24ad77cd291328127324a95b5687483f9a2cb51aab982bc117d9b4fe6940f170bf4383af15b0f33
-EBUILD Babel-2.6.0.ebuild 1477 BLAKE2B 7175cd34d55957aca7504228796b4cea67fcff1eae1a5bc3273ec4f1f63e4d054a17eccff7c23d04d2731a426b49b3a4d483bdb6c46ee19f3843f9988fb723e0 SHA512 4a4fb579eb2cb0be946fa770705b0cf968229beeef367fbc4dde652604d7fbaaa411abcec59b5df213fb4503c0b3349d31cdb28e9a65efc3925c71abf507be5b
-MISC metadata.xml 839 BLAKE2B d9916ce88ce8436bb28d15300e78013e1c9e0f88f385a369c0ad6840f0fe81ad136052a3c257cef50a2fd86500bcde2b652ad0ed664f95d6affa4ccc8770445b SHA512 3688c1488c552b84c685d0aeb6251aea4f9d41be3db3aeb226291655107e1332df13445545b3742587e133de7468a40f22ca53fa67fd8d2e0db570069498654f
diff --git a/dev-python/Babel/metadata.xml b/dev-python/Babel/metadata.xml
deleted file mode 100644
index 4f8d2872452f..000000000000
--- a/dev-python/Babel/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- A collection of tools for internationalizing Python applications
- Babel is composed of two major parts:
- - tools to build and work with gettext message catalogs
- - a Python interface to the CLDR (Common Locale Data Repository),
- providing access to various locale display names, localized number
- and date formatting, etc.
- </longdescription>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">Babel</remote-id>
- <remote-id type="github">python-babel/babel</remote-id>
- <bugs-to>https://github.com/python-babel/babel/issues</bugs-to>
- </upstream>
-</pkgmetadata>