summaryrefslogtreecommitdiff
path: root/dev-python/APScheduler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-29 09:35:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-29 09:35:43 +0000
commit704343381e435b306648a2d85a77a58e34478643 (patch)
tree009e24c29e03885a4bd7bb17b673f62567395237 /dev-python/APScheduler
parenteb147001d2176fe9850e42017a6b1284baf865ff (diff)
gentoo auto-resync : 29:10:2023 - 09:35:42
Diffstat (limited to 'dev-python/APScheduler')
-rw-r--r--dev-python/APScheduler/APScheduler-3.10.1.ebuild64
-rw-r--r--dev-python/APScheduler/APScheduler-3.10.2.ebuild63
-rw-r--r--dev-python/APScheduler/APScheduler-3.10.3.ebuild63
-rw-r--r--dev-python/APScheduler/APScheduler-3.10.4.ebuild2
-rw-r--r--dev-python/APScheduler/Manifest8
5 files changed, 2 insertions, 198 deletions
diff --git a/dev-python/APScheduler/APScheduler-3.10.1.ebuild b/dev-python/APScheduler/APScheduler-3.10.1.ebuild
deleted file mode 100644
index 28f2bd56e4f2..000000000000
--- a/dev-python/APScheduler/APScheduler-3.10.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="In-process task scheduler with Cron-like capabilities"
-HOMEPAGE="
- https://github.com/agronholm/apscheduler/
- https://pypi.org/project/APScheduler/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# imports pkg_resources
-RDEPEND="
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/tzlocal-4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # disable test fixtures using external servers (mongodb, redis...)
- # these fixtures are using markers in git master, so the patch
- # should be no longer necessary with next major bump
- "${FILESDIR}"/APScheduler-3.8.1-external-server-tests.patch
-)
-
-EPYTEST_DESELECT=(
- tests/test_jobstores.py::test_repr_mongodbjobstore
- tests/test_jobstores.py::test_repr_redisjobstore
- tests/test_jobstores.py::test_repr_zookeeperjobstore
-)
-
-python_prepare_all() {
- # suppress setuptools warning #797751
- sed -e 's|^upload-dir|upload_dir|' -i setup.cfg || die
- sed -e '/addopts/d' -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -p tornado
-}
diff --git a/dev-python/APScheduler/APScheduler-3.10.2.ebuild b/dev-python/APScheduler/APScheduler-3.10.2.ebuild
deleted file mode 100644
index c5cde2e53f6b..000000000000
--- a/dev-python/APScheduler/APScheduler-3.10.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="In-process task scheduler with Cron-like capabilities"
-HOMEPAGE="
- https://github.com/agronholm/apscheduler/
- https://pypi.org/project/APScheduler/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/tzlocal-4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # disable test fixtures using external servers (mongodb, redis...)
- # these fixtures are using markers in git master, so the patch
- # should be no longer necessary with next major bump
- "${FILESDIR}"/APScheduler-3.8.1-external-server-tests.patch
-)
-
-EPYTEST_DESELECT=(
- tests/test_jobstores.py::test_repr_mongodbjobstore
- tests/test_jobstores.py::test_repr_redisjobstore
- tests/test_jobstores.py::test_repr_zookeeperjobstore
- tests/test_executors.py::test_broken_pool
-)
-
-python_prepare_all() {
- # suppress setuptools warning #797751
- sed -e 's|^upload-dir|upload_dir|' -i setup.cfg || die
- sed -e '/addopts/d' -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -p tornado
-}
diff --git a/dev-python/APScheduler/APScheduler-3.10.3.ebuild b/dev-python/APScheduler/APScheduler-3.10.3.ebuild
deleted file mode 100644
index e88623d277c7..000000000000
--- a/dev-python/APScheduler/APScheduler-3.10.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="In-process task scheduler with Cron-like capabilities"
-HOMEPAGE="
- https://github.com/agronholm/apscheduler/
- https://pypi.org/project/APScheduler/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/tzlocal-4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # disable test fixtures using external servers (mongodb, redis...)
- # these fixtures are using markers in git master, so the patch
- # should be no longer necessary with next major bump
- "${FILESDIR}"/APScheduler-3.8.1-external-server-tests.patch
-)
-
-EPYTEST_DESELECT=(
- tests/test_jobstores.py::test_repr_mongodbjobstore
- tests/test_jobstores.py::test_repr_redisjobstore
- tests/test_jobstores.py::test_repr_zookeeperjobstore
- tests/test_executors.py::test_broken_pool
-)
-
-python_prepare_all() {
- # suppress setuptools warning #797751
- sed -e 's|^upload-dir|upload_dir|' -i setup.cfg || die
- sed -e '/addopts/d' -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -p tornado
-}
diff --git a/dev-python/APScheduler/APScheduler-3.10.4.ebuild b/dev-python/APScheduler/APScheduler-3.10.4.ebuild
index e88623d277c7..87a03126829a 100644
--- a/dev-python/APScheduler/APScheduler-3.10.4.ebuild
+++ b/dev-python/APScheduler/APScheduler-3.10.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
diff --git a/dev-python/APScheduler/Manifest b/dev-python/APScheduler/Manifest
index 8183f80f2d46..bab9b16fe68b 100644
--- a/dev-python/APScheduler/Manifest
+++ b/dev-python/APScheduler/Manifest
@@ -1,10 +1,4 @@
AUX APScheduler-3.8.1-external-server-tests.patch 1424 BLAKE2B 20eced0b88b1141eb1317eed5d42e8eda8156808b28e15bf37403cc896326830ca906f66fd372e75861ca65f0061b809de31a8bbce2888628dcebc87536c0691 SHA512 e1ddcf95bd12f10cea7e19eb4d347b980c97c2600f4462a039b4b78788b9ab6ee6280da5168ac4f60fe79a58b48ffed599e8c924ea9cfdd5a0be0cc1b85f2236
-DIST APScheduler-3.10.1.tar.gz 100376 BLAKE2B 6b5aed1197ec6cdcf2c82d73c2809d9fd304401ad5ac482cdd0dfc310356248b9ba5f0cf611f5484f4098c92d7b6f8b81f117fe5fd645b5d20ba0fbb7f1d6c97 SHA512 bba68c97d2e7cda6503a8471a61bf57c11b9c8b6dde4d1da65f7d134bf72f631b3f70815ac7db3f75313833c780ee6ded0b8d0e1c9a86e05e741788bcd041008
-DIST APScheduler-3.10.2.tar.gz 100853 BLAKE2B 540517028af71f8325c74d9fc87c44aeb20440be5a670aaa488069090acec5d19c950ab2df67e55e83b52140343e384a1214d7c7390ce50d3d5fca99bac492c8 SHA512 42a1c7df47ab41c06f87e9d0828950c78abe50e1f6648d5eda425db74edf1d07473129d1a1b9a4a82c32dfadacba9b3dca2e5b2772ba733007c502b31c34d43d
-DIST APScheduler-3.10.3.tar.gz 100837 BLAKE2B 62bd62937bf8a73e082812df6436200a8ea7352dda960d946cc3ef1257f75a63e211a252554e0aba2098289e2d50b7b32e91ab95cbe94ba53f899f11e041c9b2 SHA512 b061678cadff769e1908dea00e9687abec7f8d92ed9a0201fc630c569160a0cc19c7b880842625660e368f486f4c288e2dc005518d1b92eb674f8c06920e32c7
DIST APScheduler-3.10.4.tar.gz 100832 BLAKE2B d519a85c54951e4b5a09449f1ceda1afe8ff0120c4a7cfab4f72fb9dacc41ac73bb66bedd6615cf126f53b590eb02617ac739bac078f21dd503c2e081a057cec SHA512 44b78e60b7349437fb8d6e5ad3bbd764cfa653fdd65685b586119225e8daaff9b150871887812a1f3d4cd67b942c70e99d1606d38b83685953fb1bb1a82742fe
-EBUILD APScheduler-3.10.1.ebuild 1601 BLAKE2B 6f029cff40ac52a972cc654a603d78c68ced03b87bdf34b267e8454772a12b91f6ef986836d040e7c5ebc80d6716c73276a2b433561ee69221a7b0e394e59ec0 SHA512 d3ad82d92562826e6162b7b0b164c6ce987fe776fa4b635d5891b31f817f58df8f68b8cea47cee839b719a768e9c4f1530eef3f72ab27842455c2fe54582d67b
-EBUILD APScheduler-3.10.2.ebuild 1579 BLAKE2B fb69587509d80535650cdacc50da94e406e41babc3bb4817e0c4509e2cfd2d36bb28eb46efcfe8e82d4cb5ea3a229e0f528ffdafde98e6e509cebc41ed5dd908 SHA512 2d29bf8062e9faa9df328e432753e0d959c32afae0b06c909d6dfbc453e26f904f131a25e2cd1273a590e6626f2f59384b74c94fe2c8734dd54644c116dd3fea
-EBUILD APScheduler-3.10.3.ebuild 1580 BLAKE2B eee6c0b383b61c8740200ac3b04d4532a076051c97e855831c7106941b8d627fabab09c2782277a97c40e17c1d34f3613e5ed834f5885e3f4b47ac958d05836e SHA512 5a944fcb7360e83a984be99af0fd1ad7cbfb575092a55e46363ddf95717316859cefbc1d0054636b554baa4be6a9ee41078caa2938cb75aa61fbdb9facc7f5a6
-EBUILD APScheduler-3.10.4.ebuild 1580 BLAKE2B eee6c0b383b61c8740200ac3b04d4532a076051c97e855831c7106941b8d627fabab09c2782277a97c40e17c1d34f3613e5ed834f5885e3f4b47ac958d05836e SHA512 5a944fcb7360e83a984be99af0fd1ad7cbfb575092a55e46363ddf95717316859cefbc1d0054636b554baa4be6a9ee41078caa2938cb75aa61fbdb9facc7f5a6
+EBUILD APScheduler-3.10.4.ebuild 1580 BLAKE2B a8d28c198189e219416e92cb40bb8ad478abdbd66381e0a602933834007c8dee8ec65b6cf699f1d59bbf122d28895fc6da10a0bcff6652503e77f806a565bd7a SHA512 cd1a0c197eed1c2f0a48c07f2d8d02392e24750fc5ed4ede2ba9965e85f3c958bbc71fad22cbe23994f113e75ea32eb4b57b21661c963f28197722e44e2964ea
MISC metadata.xml 505 BLAKE2B 514e61811ac55e4e276059e8b61d2704ceb4825f96c9503166f388a8432c7397dec9769bf606216b8a6121a101479fc4e60dcccc83e74f0d3135d0d102146aa6 SHA512 07d75dfa6887da2323a02cdb448ceedab77317b34745bb54539d0f3f63a789e9c48c2db26137729969b574632855df76793b4aba0d2f75fd82c57363f4dd0f28