summaryrefslogtreecommitdiff
path: root/dev-php
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-10 06:41:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-10 06:41:31 +0000
commitf9d8ddaae80afb8fa0924cd3f769f9b37dd373e1 (patch)
treed8962e6446d606b8c95329b4b78932a65f928a5f /dev-php
parentd94fef9a5708b8e64f363f4a71f0b56caef5efe4 (diff)
gentoo auto-resync : 10:01:2025 - 06:41:30
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/Manifest.gzbin18965 -> 19137 bytes
-rw-r--r--dev-php/PEAR-Net_IMAP/Manifest3
-rw-r--r--dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.4.ebuild45
-rw-r--r--dev-php/PEAR-Net_IMAP/metadata.xml14
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-php/Manifest.gz b/dev-php/Manifest.gz
index 87a17984eed7..a59f84f56e85 100644
--- a/dev-php/Manifest.gz
+++ b/dev-php/Manifest.gz
Binary files differ
diff --git a/dev-php/PEAR-Net_IMAP/Manifest b/dev-php/PEAR-Net_IMAP/Manifest
new file mode 100644
index 000000000000..b9993293632b
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/Manifest
@@ -0,0 +1,3 @@
+DIST Net_IMAP-1.1.4.tgz 40723 BLAKE2B 0e6b7bc01301f26464afdee148318549e239c6bb8fc5646f13fc728b0e581ae8c9bc9961e83065138f31df0a81e4ed79794420be4d3a7c43b6bacc619ed672ad SHA512 2747cdb3d7f11dc4e9bc5c531c4c49cbd1b65b0ff71b30f46f06a4ad10aae341c1323a7c4a9ffb4fa3b8694a75cf60fdcb9cf433c765f29e17bd1e86c5fa929d
+EBUILD PEAR-Net_IMAP-1.1.4.ebuild 1219 BLAKE2B e94476f7a1518f16b4158aff7579b911e2a35dabeb433122e98ffbca02c1c52d6123e54c1c42855e5caeda79d2daf3fff948e03a4b1929693105870e8c541394 SHA512 6f088c03a8303019174161235f8210f78dd2148722bdd7cb3bde7f9d48722e4c398602f525a1d2243ce6b752e5f7b3f465839539e7106fe5b63385d43281c033
+MISC metadata.xml 406 BLAKE2B bd3e228417608bda769aae68e2689f0cc71bdfd575fde4f2ae924832c9875a2503f9fd553fd81516b268087a88e5f3b24748291839d1eb80c9670e4e710f1956 SHA512 eb5b52f8ac1a99a60c961398b6d8b9ad5455cb3c1bc995ab7d3280149d2fcbf04bcf529d48f44e4235fe6e1fffa9e2e23e0106e5507c590d4d2f6ac753426441
diff --git a/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.4.ebuild b/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.4.ebuild
new file mode 100644
index 000000000000..345cf489d8c1
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides an implementation of the IMAP protocol"
+HOMEPAGE="https://pear.php.net/package/Net_IMAP
+ https://github.com/pear/Net_IMAP"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="sasl"
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Net_Socket
+ dev-php/PEAR-PEAR
+ sasl? ( dev-php/PEAR-Auth_SASL )"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Net
+ dodoc docs/*
+ insinto /usr/share/php/.packagexml
+ newins "${WORKDIR}/package.xml" "${MY_P}.xml"
+}
+
+pkg_postinst() {
+ # It is not critical to complete so only warn on failure
+ if [[ -f "${EROOT}/usr/share/php/.packagexml/${MY_P}.xml" && \
+ -x "${EROOT}/usr/bin/peardev" ]] ; then
+ "${EROOT}/usr/bin/peardev" install -nrO --force \
+ "${EROOT}/usr/share/php/.packagexml/${MY_P}.xml" 2> /dev/null \
+ || ewarn "Failed to insert package into local PEAR database"
+ fi
+}
+
+pkg_postrm() {
+ if [[ -x "${EROOT}/usr/bin/peardev" ]]; then
+ "${EROOT}/usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
+ fi
+}
diff --git a/dev-php/PEAR-Net_IMAP/metadata.xml b/dev-php/PEAR-Net_IMAP/metadata.xml
new file mode 100644
index 000000000000..86cdbad4cb33
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/Net_IMAP</remote-id>
+ </upstream>
+</pkgmetadata>