summaryrefslogtreecommitdiff
path: root/dev-php
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-php
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/Manifest.gzbin40236 -> 40401 bytes
-rw-r--r--dev-php/swoole/Manifest3
-rw-r--r--dev-php/swoole/metadata.xml12
-rw-r--r--dev-php/swoole/swoole-4.0.1.ebuild68
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-php/Manifest.gz b/dev-php/Manifest.gz
index dda4fb644d5b..dfd95ac449df 100644
--- a/dev-php/Manifest.gz
+++ b/dev-php/Manifest.gz
Binary files differ
diff --git a/dev-php/swoole/Manifest b/dev-php/swoole/Manifest
new file mode 100644
index 000000000000..40acb3ad6c11
--- /dev/null
+++ b/dev-php/swoole/Manifest
@@ -0,0 +1,3 @@
+DIST swoole-4.0.1.tgz 899395 BLAKE2B 7e7320905cb83794115280977031cc5254a4947781fde05db6e7803f34ff0f5c0ecad84f8aa86adc3c21320b031fa3104fb6c953e9060791dbd9d5c497edbcfc SHA512 0df6ae1bf28ec52abebf1a597c0774e7e5de4bb8378c916a46896c7f84822c8466bbb0d3d188e671e7c39faafa94d2dc2245a468dacb2711c7f0fa617dc42aa8
+EBUILD swoole-4.0.1.ebuild 1695 BLAKE2B 7720c6946b04a5c35c012187873a351919f02a4c9b8cf041b20f4777b57db65e8f2376a1cd121af0203d802227bedae046fd1aa3b3ea3c0fecc6c677f9f029ce SHA512 fa2a870086d261175ff9ed262bd3051a62bd12ba979a384d8fbfca121ba9cba74ffe55cf8f84c687eec4b449d57904d73232c637d87fb6cd5d42e7d1bff19ee5
+MISC metadata.xml 424 BLAKE2B abaaecb73dd8caf77e25775dc2b3307efa430399d197b24f3ade567b93989108c70216949327677f5c9540e6aaafaf2f77d9af17b01f99de2ac6f04a95abb03b SHA512 52dc7ac48b61458b810ba467bbe5cfaeaef808ae7db72f58ba4ad4dd8723c7149995e43e94c8b4552e7dfc38cd1c3e627dd5c9854652ee656f421f345dd72471
diff --git a/dev-php/swoole/metadata.xml b/dev-php/swoole/metadata.xml
new file mode 100644
index 000000000000..067ddccde379
--- /dev/null
+++ b/dev-php/swoole/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+<email>php-bugs@gentoo.org</email>
+<name>PHP Project</name>
+</maintainer>
+<use>
+<flag name="http2">Add support for HTTP/2 protocol via <pkg>net-libs/nghttp2</pkg></flag>
+<flag name="redis">Add support for redis via <pkg>dev-libs/hiredis</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/dev-php/swoole/swoole-4.0.1.ebuild b/dev-php/swoole/swoole-4.0.1.ebuild
new file mode 100644
index 000000000000..8a332f5938d2
--- /dev/null
+++ b/dev-php/swoole/swoole-4.0.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="swoole"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libaio
+ dev-libs/boost:0=
+ dev-libs/libpcre
+ http2? ( net-libs/nghttp2:0= )
+ redis? ( dev-libs/hiredis:0= )
+ ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:0= ) )
+ php_targets_php7-0? ( dev-lang/php:7.0[cli,sockets?] )
+ php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
+ php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
+ mysql? (
+ php_targets_php7-0? ( dev-lang/php:7.0[mysql,mysqli(+)] )
+ php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
+ php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug http2 libressl mysql redis sockets ssl threads"
+
+src_configure() {
+ # PostgreSQL disabled due to Gentoo's slot system
+ local PHP_EXT_ECONF_ARGS=(
+ --with-swoole
+ --disable-coroutine-postgresql
+ $(use_enable debug swoole-debug)
+ $(use_enable http2)
+ $(use_enable mysql mysqlnd)
+ $(use_enable redis async_redis)
+ $(use_enable ssl openssl)
+ $(use_with ssl openssl-dir "${EROOT%/}/usr")
+ $(use_enable threads thread)
+ $(use_enable sockets)
+ )
+
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+ done
+}