summaryrefslogtreecommitdiff
path: root/dev-php
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 17:11:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 17:11:03 +0100
commit50878a9089d38edec91fb6a8035f9681695189b7 (patch)
treeb388d2365545b4ea6b37568668dacd90f22b3f48 /dev-php
parent81b8f20732954c4508baf2f77472b5435e3f851f (diff)
gentoo auto-resync : 14:09:2022 - 17:11:02
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/Manifest.gzbin39699 -> 39704 bytes
-rw-r--r--dev-php/smarty/Manifest2
-rw-r--r--dev-php/smarty/smarty-4.2.1.ebuild40
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/Manifest.gz b/dev-php/Manifest.gz
index cc5de31db6de..92ec7a2e6ce8 100644
--- a/dev-php/Manifest.gz
+++ b/dev-php/Manifest.gz
Binary files differ
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index 0f14a7c6b90b..44773c71ce4e 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,4 +1,6 @@
DIST manual-en.3.1.14.zip 408414 BLAKE2B 03d4e7a386eb3bd5b19e5c555ec34b86812838a5b5fac8ec0ab9701fba89a5867714da57d950f68224a89bbe2267c18d638ee850681860de309c74bbfb3d0a0b SHA512 d384e3856b45ed3f992f3732a5465120abe9fb947cdf13ff67a9c4264f72987d24885ee61cd7309b728e64cdfe4f34c3e7f757096d35de56d962f3b78def9e58
DIST smarty-4.1.1.tar.gz 235624 BLAKE2B c624812ebebb1a8d09a5d80e2826b4e0e90310f6f53f903c9e962542b41b5c150ede1031f66c290e4dc2bb336eb532fd3305a3d97c7e43768d45f57df6815448 SHA512 93e601959651a00bdf9be9c9ddcfea6b189f70270ec8ab4764d2759c0c4de07c74a79cf4e42ee97d16c246130d6f1da5c8601fa60e5194906fe3b416934d1ef5
+DIST smarty-4.2.1.tar.gz 236881 BLAKE2B 4014178cfc4411a9ded3120d0e3e977af0190bc03f6ed21bbd2c484ca8fb4e5aa79fe9c606ee13be87db94c17a00d7d0399cb04fe09c4b439b95bc7b9331d675 SHA512 0d55ab1d329aaa0853a1c40b5b0207d3ddc8b0c25d863a217b3c4ac8bb0a796bb60eda2919b5dda569565b03b8dd44dff67b55d8fafc005164f2848bb481d131
EBUILD smarty-4.1.1.ebuild 1344 BLAKE2B 80344cc79df6ab8d1afcf0dedf442cebbb23bd3d14e2e3aaaff58de681fd1d444e1887448e1c72f65e2a22bb101ccfc3f56ec1a1b499c79d19e5534bef1d3a32 SHA512 47bfdd8491f4eb1ac7c46670c91539a20a880af791eefab712c9230ba9b27b8ac8193098967b90441bd497fbf41242b963fb98b22c756477e764f4dfb26e105a
+EBUILD smarty-4.2.1.ebuild 1303 BLAKE2B 69c95b412d1fb2e3e021db7ee322bd2d8fdd7143bc6dd79fe6ebb7607fade37a731b31b037ce196880a27bcf49b65c3c5b79786cabb77175c1c3677730edf699 SHA512 eaaea0b1d9d2e0b0d16af01fa7bbc28af8e9584493011aebf58b99ba78ce936abb56a597e184d2c382d03bc7fc1fc8fb51295c7ef88a0ed238c8858e65ba0c48
MISC metadata.xml 742 BLAKE2B 2e882a2cd16715923bd3b93e032b2680fe07853bc0a1a03a62690f57a0254373611e5dd323dec285ac3d051dfdfd167f114c68ad4ca2caa916a76262d71e4725 SHA512 3589fb45084564c669e97fdebab3964ced2500dea7a53dd452961e71a3a2d5070cb71467dc3489a4a2474858ebf8f4d05d8b01728382e08215752b535b6a3681
diff --git a/dev-php/smarty/smarty-4.2.1.ebuild b/dev-php/smarty/smarty-4.2.1.ebuild
new file mode 100644
index 000000000000..d19caaedccde
--- /dev/null
+++ b/dev-php/smarty/smarty-4.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="https://www.smarty.net/ https://github.com/smarty-php/smarty/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ # The smarty docs and examples aren't part of the tarball,
+ # https://github.com/smarty-php/smarty/issues/799
+ local DOCS=( CHANGELOG.md README.md SECURITY.md )
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}