summaryrefslogtreecommitdiff
path: root/dev-php
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-22 20:57:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-22 20:57:19 +0100
commit351b26cfd42c558fa0f8eef51960c87bb0674026 (patch)
tree19be050f75237a56215cb686bc0880a10c92aa0e /dev-php
parent8c467dbe810a74c33c44f975c2dd5fd3a8f9bda1 (diff)
gentoo auto-resync : 22:05:2023 - 20:57:18
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/Manifest.gzbin38237 -> 38236 bytes
-rw-r--r--dev-php/pecl-uploadprogress/Manifest3
-rw-r--r--dev-php/pecl-uploadprogress/files/php-debug-testfix.patch74
-rw-r--r--dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2-r1.ebuild (renamed from dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2.ebuild)7
4 files changed, 81 insertions, 3 deletions
diff --git a/dev-php/Manifest.gz b/dev-php/Manifest.gz
index 497e120b6581..3f126f1d31a7 100644
--- a/dev-php/Manifest.gz
+++ b/dev-php/Manifest.gz
Binary files differ
diff --git a/dev-php/pecl-uploadprogress/Manifest b/dev-php/pecl-uploadprogress/Manifest
index 95f7bb93ad89..fb3fccf14183 100644
--- a/dev-php/pecl-uploadprogress/Manifest
+++ b/dev-php/pecl-uploadprogress/Manifest
@@ -1,3 +1,4 @@
+AUX php-debug-testfix.patch 3125 BLAKE2B b7481ae979c468d0770d6ad2452cbac58b04a32845a0aa447eadf762f752cf6e363777760104d810a0ace60166f00ad003a23fa1363d0e1213c8cbada3288981 SHA512 de822c759a901c66ba9834090911703cf71623d5499723fc0ddc87e45176393ed94edc15b41029ce9d725320b8588646d877d060f8425cf1f77821b382a3ccf7
DIST uploadprogress-2.0.2.tgz 19969 BLAKE2B 148cac83b00eb6b4f23861a04829280346957cdfc5bdbe94d687d0efb5da97b5f48162c59b07e0830a67350c7a2aa9a3085a4575f07b32016b01845301f04843 SHA512 b9ee5a09c3de78d58abd34da2d25d7b0cad38416309a9a69192f07e0c3fe2259de261bb3dee571e64e042753f861738ebcd67fa7fafeb595ec32ed3034c773cd
-EBUILD pecl-uploadprogress-2.0.2.ebuild 670 BLAKE2B b3b6a18e60014cf65551c19786cc1da1aceda3c5d261ef1274d5badea28b188042d56463d52dd9658df8935cd01393449c7d6cec9df9469a8b9eb85ce6b1c793 SHA512 059534127bbf73894e80b3b869fcfea39a84686733e400350cafb6e2f0eff9782575cdf9e0abe07419ad1a2807d21a87fa132b44cf67a973089ebbbd607a052a
+EBUILD pecl-uploadprogress-2.0.2-r1.ebuild 838 BLAKE2B abdc8dab65d91dc6b83cea116e5f2e8e3b3953d5695301af28320ba395c50e4578531ae8cc6cf45ba74cbf3d02ba0f6f60343534bda8408a3ec4167e91128469 SHA512 2784fcbda726ddc5b8f68903d1c098e25b4557754e97f8954f5bb205426541d52463183a2b50e5cf9eacacec90a07004e669fd26505de54af886585d85eccffd
MISC metadata.xml 711 BLAKE2B 6f64caf4b0734172e21382f36ea71f7e9f07e998eaad39045ef975dc16c75201508532056d15b3d1f87b241651a2d4d207e23f9c04494954f09a1c0e2d6536c2 SHA512 9edb41bdb677b1a9360676db7bb54dcf00860a1c71c9129fffe75944f6f7b02473911088bb759009d33f7aa72c388d9c73a0a6c1935ee0426aef706dbbe1818e
diff --git a/dev-php/pecl-uploadprogress/files/php-debug-testfix.patch b/dev-php/pecl-uploadprogress/files/php-debug-testfix.patch
new file mode 100644
index 000000000000..febc989ab79b
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/files/php-debug-testfix.patch
@@ -0,0 +1,74 @@
+From 57f3c17c684a4e5607a322a24be306eb98d340ac Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 22 May 2023 10:18:29 -0400
+Subject: [PATCH 1/1] tests: skip tests that fail with --enable-debug.
+
+With PHP debugging enabled, a few tests fail. The root cause of this
+is that uploadprogress_get_contents() can return FALSE to indicate
+that an error has occurred, but its declared type is string. It
+would probably be better if the function raised an error rather
+than abusing the return value, but that's a decision upstream
+would have to agree too (see: Github issue 17). For now we just
+skip the tests if PHP_DEBUG is defined.
+---
+ tests/uploadprogress_get_contents_error001.phpt | 2 ++
+ tests/uploadprogress_get_contents_error003.phpt | 2 ++
+ tests/uploadprogress_get_contents_variation002.phpt | 2 ++
+ tests/uploadprogress_get_contents_variation006.phpt | 2 ++
+ 4 files changed, 8 insertions(+)
+
+diff --git a/tests/uploadprogress_get_contents_error001.phpt b/tests/uploadprogress_get_contents_error001.phpt
+index 63f4f5d..c3e10d9 100644
+--- a/tests/uploadprogress_get_contents_error001.phpt
++++ b/tests/uploadprogress_get_contents_error001.phpt
+@@ -5,6 +5,8 @@ uploadprogress_get_contents - Warns when function is disabled
+ <?php
+ if (!extension_loaded('uploadprogress')) exit('skip extension not loaded');
+
++if (PHP_DEBUG) exit('skip test throws a fatal error with --enable-debug');
++
+ --INI--
+ uploadprogress.get_contents = Off
+
+diff --git a/tests/uploadprogress_get_contents_error003.phpt b/tests/uploadprogress_get_contents_error003.phpt
+index 1ea19b8..65d94c1 100644
+--- a/tests/uploadprogress_get_contents_error003.phpt
++++ b/tests/uploadprogress_get_contents_error003.phpt
+@@ -5,6 +5,8 @@ uploadprogress_get_contents - Warns when maxlength is less than zero
+ <?php
+ if (!extension_loaded('uploadprogress')) exit('skip extension not loaded');
+
++if (PHP_DEBUG) exit('skip test throws a fatal error with --enable-debug');
++
+ --INI--
+ uploadprogress.get_contents = On
+
+diff --git a/tests/uploadprogress_get_contents_variation002.phpt b/tests/uploadprogress_get_contents_variation002.phpt
+index b4bf458..67b1b89 100644
+--- a/tests/uploadprogress_get_contents_variation002.phpt
++++ b/tests/uploadprogress_get_contents_variation002.phpt
+@@ -5,6 +5,8 @@ uploadprogress_get_contents - File contents not found
+ <?php
+ if (!extension_loaded('uploadprogress')) exit('skip extension not loaded');
+
++if (PHP_DEBUG) exit('skip test throws a fatal error with --enable-debug');
++
+ --INI--
+ uploadprogress.get_contents = On
+
+diff --git a/tests/uploadprogress_get_contents_variation006.phpt b/tests/uploadprogress_get_contents_variation006.phpt
+index e19f8d5..ec70c78 100644
+--- a/tests/uploadprogress_get_contents_variation006.phpt
++++ b/tests/uploadprogress_get_contents_variation006.phpt
+@@ -5,6 +5,8 @@ uploadprogress_get_contents - When contents file cannot be read
+ <?php
+ if (!extension_loaded('uploadprogress')) exit('skip extension not loaded');
+
++if (PHP_DEBUG) exit('skip test throws a fatal error with --enable-debug');
++
+ --INI--
+ uploadprogress.get_contents = On
+
+--
+2.39.3
+
diff --git a/dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2.ebuild b/dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2-r1.ebuild
index 99572c452134..49f75395edd0 100644
--- a/dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2.ebuild
+++ b/dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_PHP="php7-4 php8-0 php8-1"
+USE_PHP="php7-4 php8-0 php8-1 php8-2"
PHP_EXT_SAPIS="apache2 fpm"
inherit php-ext-pecl-r3
@@ -14,8 +14,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
+PATCHES=( "${FILESDIR}/php-debug-testfix.patch" )
+
RDEPEND="
php_targets_php7-4? ( || ( dev-lang/php:7.4[apache2(-),fileinfo(-)] dev-lang/php:7.4[fileinfo(-),fpm(-)] ) )
php_targets_php8-0? ( || ( dev-lang/php:8.0[apache2(-),fileinfo(-)] dev-lang/php:8.0[fileinfo(-),fpm(-)] ) )
php_targets_php8-1? ( || ( dev-lang/php:8.1[apache2(-),fileinfo(-)] dev-lang/php:8.1[fileinfo(-),fpm(-)] ) )
+ php_targets_php8-2? ( || ( dev-lang/php:8.2[apache2(-),fileinfo(-)] dev-lang/php:8.2[fileinfo(-),fpm(-)] ) )
"