summaryrefslogtreecommitdiff
path: root/dev-php
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-13 02:01:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-13 02:01:50 +0000
commit2a3e0d61b3d88306b6fae46756f9ba7d230222ae (patch)
treea0d3259dd259861a49a2d3e6e9220beaa8ec39c2 /dev-php
parent39c32f4d5dca9f6293fccb69e9d50baf494c8de4 (diff)
gentoo auto-resync : 13:12:2024 - 02:01:50
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/Manifest.gzbin18955 -> 18965 bytes
-rw-r--r--dev-php/pecl-http/Manifest4
-rw-r--r--dev-php/pecl-http/pecl-http-4.2.6.ebuild (renamed from dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild)11
-rw-r--r--dev-php/pecl-raphf/Manifest2
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.1-r3.ebuild (renamed from dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild)10
5 files changed, 13 insertions, 14 deletions
diff --git a/dev-php/Manifest.gz b/dev-php/Manifest.gz
index 72d61e0d85bc..87a17984eed7 100644
--- a/dev-php/Manifest.gz
+++ b/dev-php/Manifest.gz
Binary files differ
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index 5015c7d5c534..530c4a63e8ed 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1,3 +1,3 @@
-DIST pecl_http-4.2.2.tgz 224436 BLAKE2B 26ef3bb38778f0374938ba3f3bddba37c3a2044c7b9ffe2aacbca2566251d26d37882bf66773b8ed62d46855e8f14ad9b577cdb1ef3db9eba9850c0b30e57284 SHA512 1203367d590c7d80ffe7a21e7ac352ba053e3daeb778bf99e08fc13582e665e1429f850e51e36304bdec15e6646b648f2c444b46fa263e5441d008ac41a00f4b
-EBUILD pecl-http-4.2.2-r1.ebuild 1564 BLAKE2B ee5a88e6315b60813e925b54c357dd92e9e5a31b1a4635fcfafeb2688249d9f6bfe47b5e8df5781887488bb05d5c0da8bfca3cec829ecdeb0c6620c6b83d32a7 SHA512 6a7e50ca9b2f702349a254f0e68f3e9b114aed5f3a3b482545cda04598e8a48d2ff567b8fd4104ba1f3d6c3c512bc7aa534dd2a657a9769648656b3cb8f14be1
+DIST pecl_http-4.2.6.tgz 225503 BLAKE2B 834c5a38de2ec5525472fbe3a2c92804e3d471cdbd2f0791990bbde3001a4ba63822e9e4600b1a692f117f4fb941c86a78cd533512b7c5cacdad87f055160cfd SHA512 50c921d11e035281bd55152e449ee47d203c839d654b097fcbc5d6d93faf91a6111817b8a7157715de0af9f15c713974a53a2ab318eddd840bc3a7e6b2b50e11
+EBUILD pecl-http-4.2.6.ebuild 1783 BLAKE2B ef8de0593ab665f3dc9006685097d04f64f755dea1fb5c9aca4a59abb6cc297894c0d021a54b8edc8a9512a40c76dfda283e3b1cdb0d6ac024962f03fe6276d4 SHA512 1296d47c96756fb42ecad1a9232df22669cde5a35f811b36e1484b9bd6c291fe431dcd7f8d9d1756a086a8feb89d0c8a098b02e1ddfd67f97bf419378247818e
MISC metadata.xml 318 BLAKE2B 42b746a7e1bece2295d3350d90feb75bde0fe414baaacc84b996483724f381a281299345debc2bf320488e3eaff141c1f12bbcc929de95a2fbc3caac2957cc06 SHA512 a47c085f27b112dce6f2fdabb1d14c5f9b65ce6453dc8500bc63be4862211ab83ace06ce7303afc4c65e2971cc6ddb468c1aea633f543399db57e1f9d4fb4017
diff --git a/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild b/dev-php/pecl-http/pecl-http-4.2.6.ebuild
index 976d95d6c8fa..c37376e61578 100644
--- a/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild
+++ b/dev-php/pecl-http/pecl-http-4.2.6.ebuild
@@ -9,27 +9,28 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"
-USE_PHP="php8-1"
+USE_PHP="php8-1 php8-2 php8-3"
inherit php-ext-pecl-r3
-KEYWORDS="amd64 x86"
-
DESCRIPTION="Extended HTTP Support for PHP"
LICENSE="BSD-2 MIT"
SLOT="8"
+KEYWORDS="amd64 x86"
IUSE="ssl curl_ssl_gnutls +curl_ssl_openssl"
COMMON_DEPEND="app-arch/brotli:=
dev-libs/libevent
- >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-1(-)?]
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-1(-)?,php_targets_php8-2(-)?,php_targets_php8-3(-)?]
net-dns/libidn2
sys-libs/zlib
ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=] )
!ssl? ( net-misc/curl[-ssl] )
"
DEPEND="
- php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )"
+ php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )
+ php_targets_php8-2? ( ${COMMON_DEPEND} dev-lang/php:8.2[session(-),iconv(-)] )
+ php_targets_php8-3? ( ${COMMON_DEPEND} dev-lang/php:8.3[session(-),iconv(-)] )"
RDEPEND="${DEPEND}"
PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps
diff --git a/dev-php/pecl-raphf/Manifest b/dev-php/pecl-raphf/Manifest
index 66b3c1cc8649..5e1e38d52165 100644
--- a/dev-php/pecl-raphf/Manifest
+++ b/dev-php/pecl-raphf/Manifest
@@ -1,3 +1,3 @@
DIST raphf-2.0.1.tgz 16003 BLAKE2B 4eaf9f89e6572e17e0df347543dc99221f68d45103444f89e59862b9078574722278fbb1e2841b0a5952ffd6dfc4ea0fa81298f2014ffbe8a6b51ed6887f6692 SHA512 0a609fc21a62880963e7afb75297eb75a2598aab2c816cb61e84d665b0453e4952aa9bf25fe2c818cc94492a4b94aed965053c67899fdb984d88661364fffb1e
-EBUILD pecl-raphf-2.0.1-r2.ebuild 399 BLAKE2B dd9cb9203a26f11241d9b2193dc718d58a559785e2741343882c0ab60e092e2b35207fbc51094e8148741a89bc1a38b494d16c9cdc9098f935a0d4f82dbf50ec SHA512 35cb0ed1c3ff0eb990fda29a2d9d64ae33db8fc1f164458285f3200507ec67d31613b0079169f0cd8e1039a9073573bf1dcd90c5f729880726e03f2ad42439a2
+EBUILD pecl-raphf-2.0.1-r3.ebuild 404 BLAKE2B 2de892fa9e6e402bddd0cc9c02ae42945102a1f8e1db4e6f9c2648e8a91f2a7bbb597b715e8a6f59fb00f2051059f77e36dcf43e100bc7dc14ec7eb9daabd1bf SHA512 e3bd7d5b1f1acf16ef2f324258ed53b523dd506050cf39ce810749c13a7107d09130c59aaa4bcd833ca28a23c49cfae38e542822c22da66e4fc1bbb149f03ee3
MISC metadata.xml 240 BLAKE2B f60f325331d493a555e53c29c7cf2742a415356da28a467505f1441f3fd790fd0d59050df84854bdc379d19d94a46121216479807975a2922d5a2fefde83416b SHA512 fada9d69055f2be962b95aac82f260ec5db7a3f4392d10f0458a1d125938fa17539f7ec486000f3a95cff85a3fbb6bbf1f6f4fe6c2de7aa420a7543a3e89d03e
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.1-r3.ebuild
index 3d7ea2841257..31c27d50de84 100644
--- a/dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild
+++ b/dev-php/pecl-raphf/pecl-raphf-2.0.1-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
PHP_EXT_NAME="raphf"
PHP_EXT_INI="yes"
@@ -9,13 +9,11 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_ECONF_ARGS=""
PHP_INI_NAME="30-${PHP_EXT_NAME}"
-USE_PHP="php8-1"
+USE_PHP="php8-1 php8-2 php8-3"
inherit php-ext-pecl-r3
-KEYWORDS="amd64 x86"
-
DESCRIPTION="A reusable, persistent handle and resource factory API"
LICENSE="BSD-2"
SLOT="7"
-IUSE=""
+KEYWORDS="amd64 x86"