summaryrefslogtreecommitdiff
path: root/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-php/zetacomponents-Base/zetacomponents-Base-1.9.3.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-php/zetacomponents-Base/zetacomponents-Base-1.9.3.ebuild')
-rw-r--r--dev-php/zetacomponents-Base/zetacomponents-Base-1.9.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.3.ebuild b/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.3.ebuild
new file mode 100644
index 000000000000..03ece24351ac
--- /dev/null
+++ b/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="Base"
+
+DESCRIPTION="Base package for any Zeta component"
+HOMEPAGE="https://github.com/zetacomponents/Base"
+SRC_URI="https://github.com/zetacomponents/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ insinto /usr/share/php/ezc/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}"/autoload.php
+
+ einstalldocs
+}