summaryrefslogtreecommitdiff
path: root/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild')
-rw-r--r--dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild b/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild
new file mode 100644
index 000000000000..a1c68a7472bd
--- /dev/null
+++ b/dev-php/zetacomponents-Base/zetacomponents-Base-1.9.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="Base"
+
+DESCRIPTION="Base package for any Zeta component"
+HOMEPAGE="https://github.com/zetacomponents/Base"
+SRC_URI="https://github.com/zetacomponents/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ insinto /usr/share/php/ezc/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}"/autoload.php
+
+ einstalldocs
+}