summaryrefslogtreecommitdiff
path: root/dev-php/webmozart-assert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/webmozart-assert
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/webmozart-assert')
-rw-r--r--dev-php/webmozart-assert/Manifest4
-rw-r--r--dev-php/webmozart-assert/files/autoload.php8
-rw-r--r--dev-php/webmozart-assert/metadata.xml11
-rw-r--r--dev-php/webmozart-assert/webmozart-assert-1.2.0.ebuild26
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/webmozart-assert/Manifest b/dev-php/webmozart-assert/Manifest
new file mode 100644
index 000000000000..8a5629fa0f1b
--- /dev/null
+++ b/dev-php/webmozart-assert/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 248 BLAKE2B c849a044a627ed56e60c90aa46711a63507f3eaa5837234d0ed02136f1c99f55d28d7c216830d9ed71290bcfabd7ce4ba47ff1f84d454e98181bbdb809eead27 SHA512 3fcb244b4801ae29b4972d3e1008570f2bd392339539d0d6cff465b0724f9df581935a0d2e2ad4369bf7350678e24d624ec63a2ce966ded0cb4f60d5c02becbd
+DIST webmozart-assert-1.2.0.tar.gz 11866 BLAKE2B 86cb0f299efff9822ea79964153b17337eac3e17a968b5201680186cfb3f6721b2ca561e041e71b304c6d29d227b446f7f52b65d5a6fc490c8535dd4fee0160c SHA512 36bae648cfe5bbd258d738574a820ea3de2e95b59700d556dd5eadbb1657bc09a7e73000e3436d020e060ecd2a99944199795f315a278acbeeea90570b0a4a22
+EBUILD webmozart-assert-1.2.0.ebuild 656 BLAKE2B 876df828e35c9e84848f171301aa64867490bf509767c1fdd53083d1034f056494e96a84663d80f9cca78d5578e924d2459ba9d73bd63dbef80965975dfb88dd SHA512 acc975f88ae8bc24f9e0ebf5f2cf716cb693b139f7b8e171ac7cfeedacbd6c685f2aba4721c7fc65f729e1d80bf5b1c0f87c65bb28972eb28fedd07492ca842a
+MISC metadata.xml 314 BLAKE2B 4fd853abe0d4a1c6d7f1e64b55116e8e02d4b800ec5ef7d7026a004d634b5c50dc40f8f826465dae59138cc1bad91ff842cb0cca348fb8d8acc9b3a75ca8cb4c SHA512 fad867b572c3a97beb2cc361fccb6cbfe6ca7c9bd421937c99783f25287cd2017df54b8d7b5f067a1f65528d3bb284140a9decc3701e2ef753cf6eaa4c2511a1
diff --git a/dev-php/webmozart-assert/files/autoload.php b/dev-php/webmozart-assert/files/autoload.php
new file mode 100644
index 000000000000..45ece0641b6b
--- /dev/null
+++ b/dev-php/webmozart-assert/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for dev-php/webmozart-assert */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+Fedora\Autoloader\Autoload::addPsr4('Webmozart\\Assert\\', __DIR__);
diff --git a/dev-php/webmozart-assert/metadata.xml b/dev-php/webmozart-assert/metadata.xml
new file mode 100644
index 000000000000..9e8b6de4665e
--- /dev/null
+++ b/dev-php/webmozart-assert/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">webmozart/</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/webmozart-assert/webmozart-assert-1.2.0.ebuild b/dev-php/webmozart-assert/webmozart-assert-1.2.0.ebuild
new file mode 100644
index 000000000000..c91ad43b1a53
--- /dev/null
+++ b/dev-php/webmozart-assert/webmozart-assert-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/webmozart-//}"
+
+DESCRIPTION="Assertions to validate method input/output with nice error messages"
+HOMEPAGE="https://github.com/webmozart/assert"
+SRC_URI="https://github.com/webmozart/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/Webmozart/Assert
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}