summaryrefslogtreecommitdiff
path: root/dev-php/webmozart-assert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /dev-php/webmozart-assert
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'dev-php/webmozart-assert')
-rw-r--r--dev-php/webmozart-assert/Manifest2
-rw-r--r--dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/webmozart-assert/Manifest b/dev-php/webmozart-assert/Manifest
index 8a5629fa0f1b..a31fc96d808b 100644
--- a/dev-php/webmozart-assert/Manifest
+++ b/dev-php/webmozart-assert/Manifest
@@ -1,4 +1,6 @@
AUX autoload.php 248 BLAKE2B c849a044a627ed56e60c90aa46711a63507f3eaa5837234d0ed02136f1c99f55d28d7c216830d9ed71290bcfabd7ce4ba47ff1f84d454e98181bbdb809eead27 SHA512 3fcb244b4801ae29b4972d3e1008570f2bd392339539d0d6cff465b0724f9df581935a0d2e2ad4369bf7350678e24d624ec63a2ce966ded0cb4f60d5c02becbd
DIST webmozart-assert-1.2.0.tar.gz 11866 BLAKE2B 86cb0f299efff9822ea79964153b17337eac3e17a968b5201680186cfb3f6721b2ca561e041e71b304c6d29d227b446f7f52b65d5a6fc490c8535dd4fee0160c SHA512 36bae648cfe5bbd258d738574a820ea3de2e95b59700d556dd5eadbb1657bc09a7e73000e3436d020e060ecd2a99944199795f315a278acbeeea90570b0a4a22
+DIST webmozart-assert-1.4.0.tar.gz 9241 BLAKE2B bbe5d42732c99700f11db6a3a8b6d6753d60b3e6fbfb8412383459199139f31e3ec55e4abee03295adea19c9c48edb0f13a11597b654fdd0de0a7823ed545586 SHA512 1ed2328de800bb98b7c00264009182934006ae146d86aa313f3478b9f3a7e6eed9dee026ed80d18393724840711ecd9891ee34178676470d12cac8124f819309
EBUILD webmozart-assert-1.2.0.ebuild 656 BLAKE2B 876df828e35c9e84848f171301aa64867490bf509767c1fdd53083d1034f056494e96a84663d80f9cca78d5578e924d2459ba9d73bd63dbef80965975dfb88dd SHA512 acc975f88ae8bc24f9e0ebf5f2cf716cb693b139f7b8e171ac7cfeedacbd6c685f2aba4721c7fc65f729e1d80bf5b1c0f87c65bb28972eb28fedd07492ca842a
+EBUILD webmozart-assert-1.4.0.ebuild 664 BLAKE2B 25dadb510d384925f306eef2a41fc326c0368ebd45b06eb29b4ad4d1a165e4ac0cbf9fe7a5a4575439c5c4e899bac0ef8968f7c2406cd1e46c8d1a436f277036 SHA512 a34367b866bbfc1ee923fcd179282070c5b044550b45b1fec6082596b53bf2756a95d3ac5279ed131794f401d4fbfa64114dddf52469b6f9bd76cdda200bbc5f
MISC metadata.xml 314 BLAKE2B 4fd853abe0d4a1c6d7f1e64b55116e8e02d4b800ec5ef7d7026a004d634b5c50dc40f8f826465dae59138cc1bad91ff842cb0cca348fb8d8acc9b3a75ca8cb4c SHA512 fad867b572c3a97beb2cc361fccb6cbfe6ca7c9bd421937c99783f25287cd2017df54b8d7b5f067a1f65528d3bb284140a9decc3701e2ef753cf6eaa4c2511a1
diff --git a/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild b/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
new file mode 100644
index 000000000000..77df9aa06b41
--- /dev/null
+++ b/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="${PN/webmozart-//}"
+
+DESCRIPTION="Assertions to validate method input/output with nice error messages"
+HOMEPAGE="https://github.com/webmozart/assert"
+SRC_URI="https://github.com/webmozart/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/Webmozart/Assert
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}