summaryrefslogtreecommitdiff
path: root/dev-php/twig
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
commit1173ad5704ce725916e0c332416aff326d850d06 (patch)
treed48d60977ce19864893dfb2222bf2982ffb4262a /dev-php/twig
parent8c364c784966be1700ea39ae45028f3e9be9cae0 (diff)
gentoo resync : 29.03.2018
Diffstat (limited to 'dev-php/twig')
-rw-r--r--dev-php/twig/Manifest2
-rw-r--r--dev-php/twig/twig-1.35.3.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-php/twig/Manifest b/dev-php/twig/Manifest
index 06a35a4c4285..fba00734fe8a 100644
--- a/dev-php/twig/Manifest
+++ b/dev-php/twig/Manifest
@@ -1,3 +1,5 @@
DIST twig-1.31.0.tar.gz 242247 BLAKE2B f11195b235c5dd8cda5373394d94306c81810d46c155194cc11bfcb832778b03085bf05de10b636ebda9223876ab9b752214e8676c000578c702f6d9b832ffe1 SHA512 c8c25139b2568d40c9d1b14d8f489047abe13b1598c9d3292ddd3898a685ac69ede00a516c12c4f22805314fca4712991cd27e39dd9c4f57e5576f86e2746401
+DIST twig-1.35.3.tar.gz 256758 BLAKE2B e96f6651fddd2fab3a1d379a2996ded594942bcb511548d419a56e8e4cc6c6b30e6a0a96b44211351ce9b3d2f36cde6b1c85acd46e51d5c2e19793703fccecc4 SHA512 c27d4407b5ad0e51724599fe0371a5951e8a8654df443ca6ac817a9c6958c3235b4d56a396eeceb71eaf707887420a6beace10ca42f1c09882988039c932fe7b
EBUILD twig-1.31.0.ebuild 2521 BLAKE2B 3bca6d375823553584cda2bdd243f19dbe8854bdb80ea6a8a62aae9e33e651c7b1a0e73c26fbcf938c03c9c9a182f1ef8c8e69f29fda5c039934f4276c3facca SHA512 83e3df9db7d32fdf7c7cb29c30d43422aaffc04f55976b8267781e2f0c383a6a69605ba4ed6369a8ff65e8819418db76bcd1a0035291727287d1d82a512845a3
+EBUILD twig-1.35.3.ebuild 2521 BLAKE2B 1422899758d8b3c8bcc9877e954ddd1f7cf8c09c4e6c43cb840120f1dd45ab1f2f332d3ebc0321a7bf5618d185df0fe3da7999dede68d339443b9ea0cb947893 SHA512 aeb548e3ce955ec8f4a75e5a830ec45cde36ce535b8b9df87a3e6503436f0763e8d9d0ab02d7680fab83d352ad829a4b4a4f2f7873e26ca7fadf3016b0ab09b2
MISC metadata.xml 545 BLAKE2B ccc89ed2677959e71586c28951a718dc42b2dbce61803762b75198606407ed8ed4eebbcd18cee00591fb6c9f22e422c8e026d4a5cd4814db3af47b8f31eb88ad SHA512 7374d514d449d55037c8c57a0fb95162bb11b9ad80cb9896510cc1fddad6a984c19fff5431ce4f2d9ecd49dad72cd54edc25e521c986c4347a841c1a4b8435de
diff --git a/dev-php/twig/twig-1.35.3.ebuild b/dev-php/twig/twig-1.35.3.ebuild
new file mode 100644
index 000000000000..b4bbd806de7e
--- /dev/null
+++ b/dev-php/twig/twig-1.35.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="Twig"
+USE_PHP="php5-6"
+S="${WORKDIR}/${MY_PN}-${PV}"
+PHP_EXT_S="${S}/ext/${PN}"
+PHP_EXT_NAME="${PN}"
+PHP_EXT_OPTIONAL_USE="extension"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="PHP templating engine with syntax similar to Django"
+HOMEPAGE="http://twig.sensiolabs.org/"
+SRC_URI="https://github.com/twigphp/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc extension test"
+
+DEPEND="test? ( dev-php/phpunit )"
+
+# We always require *some* version of PHP; the eclass (conditionally)
+# requires *specific* versions.
+RDEPEND="dev-lang/php"
+
+src_prepare(){
+ # We need to call eapply_user ourselves, because it may be skipped
+ # if either the "extension" USE flag is not set, or if the user's
+ # PHP_TARGETS is essentially empty (does not contain "php5-6"). In
+ # the latter case, the eclass src_prepare does nothing. We only call
+ # the eclass phase conditionally because the correct version of
+ # e.g. "phpize" may not be there unless USE=extension is set.
+ eapply_user
+ use extension && php-ext-source-r3_src_prepare
+}
+
+src_configure() {
+ # The eclass phase will try to run the ./configure script even if it
+ # doesn't exist (in contrast to the default src_configure), so we
+ # need to skip it if the eclass src_prepare (that creates said
+ # script) is not run.
+ use extension && php-ext-source-r3_src_configure
+}
+
+src_compile() {
+ # Avoids the same problem as in src_configure.
+ use extension && php-ext-source-r3_src_compile
+}
+
+src_install(){
+ use extension && php-ext-source-r3_src_install
+
+ cd "${S}" || die
+ # The autoloader requires the 'T' in "Twig" capitalized.
+ insinto "/usr/share/php/${MY_PN}"
+ doins -r lib/"${MY_PN}"/*
+
+ # The eclass src_install calls einstalldocs, so we may install a few
+ # files twice. Doing so should be harmless.
+ dodoc README.rst CHANGELOG
+
+ # This installs the reStructuredText source documents. There's got
+ # to be some way to turn them into HTML using Sphinx, but upstream
+ # doesn't provide for it.
+ use doc && dodoc -r doc
+}
+
+src_test(){
+ phpunit --bootstrap test/bootstrap.php || die "test suite failed"
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/${MY_PN}/."
+ elog "To use it in a script, require('${MY_PN}/Autoloader.php'),"
+ elog "and then run \"Twig_Autoloader::register();\". Most of"
+ elog "the examples in the documentation should work without"
+ elog "further modification."
+}