summaryrefslogtreecommitdiff
path: root/dev-php/theseer-tokenizer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-php/theseer-tokenizer
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-php/theseer-tokenizer')
-rw-r--r--dev-php/theseer-tokenizer/Manifest2
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/Manifest b/dev-php/theseer-tokenizer/Manifest
index ba343f82d7c6..3575d7a4be32 100644
--- a/dev-php/theseer-tokenizer/Manifest
+++ b/dev-php/theseer-tokenizer/Manifest
@@ -1,6 +1,8 @@
AUX autoload.php 740 BLAKE2B 1776060d0cbd86a165e293cf24ba31c7c6eef748f7d34681d110f1f99f62909f6619f4917743a995c2c9f2edc5de99b5762d3997d09f14c66a6bfe3569f5e17a SHA512 23ec36f9afc24a4df46a866376db86727127351a1c6d9c16f864804ff31fe64c0c0c8a8306fb1a91fce0dd165cbf5fb02cbe545b4f00dc96bcff2dcce7a82b7c
DIST theseer-tokenizer-1.1.0.tar.gz 10163 BLAKE2B b2360f901d60f784db2045912707a8e293a55967d60d4e72168a1c4b0c9a2d5bdb739fbed9bfec02075476e7bf6762eb1cc7e36870b84fcc341b609527579ca2 SHA512 8b500565dc0d6c8513db3aa72a7ee1fa04510a712ce9b0977feccddc6b2dae53825e39182d43508e196f326776115789e81697116418f6f9f63d08f0c05d0543
DIST theseer-tokenizer-1.1.3.tar.gz 10553 BLAKE2B 4bed1623abe110cec432a97fbd28752618420a188b450c935c77b5771d6986be9a51c8f100fd81a89d892b0c1e2b46b0124e3c35e3cbe2138eee2d520c74933a SHA512 e29fd41b311bac8021f4c0593d79a9c1bde4b6ccf4774e94d27a0e8a97bac3844109f9312c4aab6e239365630394b602b56a084c291dc13fb439dc8ac22944e3
+DIST theseer-tokenizer-1.2.0.tar.gz 7156 BLAKE2B 61474e3ebed5262b4d250f0057fbe68df6b2b2d6026cba28efbfc35c865bc9491e3b3f7871591a7aa52383c3bb748cf5dfb95f36d680bdbb9755b585b5b8f4f8 SHA512 e0deeffc151a1831cc7226037c75b534aa0d28d9639de45a1f0a6f5865d3df3cfbd7225e075b094603d512b0beb449e91205f40366ef1c7c865c8994e0710ff7
EBUILD theseer-tokenizer-1.1.0.ebuild 834 BLAKE2B 79ca12311b476cf6528502bfb4302b7e4d65a96c20e9c5c18494bb52d898181099730d78dbffaa6d0e2060c993b85c2629c84269c1e9629df396058c5f2b80ce SHA512 9cb0686954506ccdc4ce6a2e972bf54c482e260205700e521085609872c88f7d59fc966077a1ba062d621502a2f59d5048f2af2279ef08061f7b42a19df655e2
EBUILD theseer-tokenizer-1.1.3.ebuild 834 BLAKE2B 02ed175c1a5d4c8395b1d049125316dc19a1b87404ca27950869a0ea7e98972bee58ea656f386341f6d623627c797722e69861f59dc96c280296423cbdfb3ac2 SHA512 9b5fff439ac870a1cb80cab1bd048207616bd810e627e4c8c1ab72080565888e12b626d670292d68574a814444a6e299c4feaf073aef1b6e4df0407e9656c95d
+EBUILD theseer-tokenizer-1.2.0.ebuild 811 BLAKE2B 1689dc331b3c96ef1e4667efda296a684dd87c11a365c3857628d02f3ff2f6a23c83f8069571e494832fcc9b626046e1f5b90819d3f0ea41317f6c680f5e2df5 SHA512 20bc503ed195238f76665df069083ed9736487aed15e54db9de5d99a460272a4663f9db724ce8cdfa903d1428370eb4ce097c5ee9df028143e2af6faf3914c87
MISC metadata.xml 321 BLAKE2B c4c16164af66494e41a3bfe90f4943c905560440eaea9de1a4f82148e1cdc353f9b6871efb618af4ab7ddb8c9fa1dfd931e0610b79c41750744aa6e5dd70580d SHA512 75a4155fe11d88a9d1bde7d46f68954c175c2b8d89872bd53496f11ffd22aa4cbf9f487e36217522e7201aae85c089422a3c7bea3fdec21fc3048b20aad6e5a9
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild
new file mode 100644
index 000000000000..20e9ed3dcae2
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src || die
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins -r src/*
+
+ einstalldocs
+}