summaryrefslogtreecommitdiff
path: root/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild')
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
new file mode 100644
index 000000000000..2f736a8e8645
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.0:*[tokenizer,xmlwriter]"
+
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_prepare() {
+ cp "${FILESDIR}/autoload.php" src/ || die
+ default
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins src/*.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit || die "Unit testing failed!"
+}