summaryrefslogtreecommitdiff
path: root/dev-php/theseer-DirectoryScanner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-php/theseer-DirectoryScanner
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-php/theseer-DirectoryScanner')
-rw-r--r--dev-php/theseer-DirectoryScanner/Manifest3
-rw-r--r--dev-php/theseer-DirectoryScanner/metadata.xml11
-rw-r--r--dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.2.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/theseer-DirectoryScanner/Manifest b/dev-php/theseer-DirectoryScanner/Manifest
new file mode 100644
index 000000000000..9626c871d9e4
--- /dev/null
+++ b/dev-php/theseer-DirectoryScanner/Manifest
@@ -0,0 +1,3 @@
+DIST theseer-DirectoryScanner-1.3.2.tar.gz 9262 BLAKE2B 5b16781d9ccd030ea779b286b9d22c528468db52e39c6761e91e0f9f83d4a50e1775382eca4eea0f027cc508f7dd35e416664451f83bdfae8607cf074e5ed9cb SHA512 720db8baa40983918e5c0d7cfac194e26d877becf6e55868ca21c1ab0a4366b86a8aad2c700e38a6360e280d372db0f1be6c80dbb81d279c277bf9f56a6cbadf
+EBUILD theseer-DirectoryScanner-1.3.2.ebuild 575 BLAKE2B 6c233dcda193944db141003e063764782fde04ffd2d2481521f451f2d669f7d58107a840d9c9624e52d47e8cb80a9cb46e05a56d10a7dbc0895451aff74a5c92 SHA512 88ea31f44ea0862d16152e15dccdb738f3ac108db0b914e21121577c2132c44edd19956b0b1caeced62f484e3cae8b42d8cffa7ef92c1867b805bed8d8a7890b
+MISC metadata.xml 328 BLAKE2B 52cb56d1dbe749e10f4d9ebf124b10b7482e783321d81dd4138c2819e06bcce21e2dec6a813e640125ef9d95eac89260e3c51b8966de5c4a1c9201713a237617 SHA512 db1eab2608e388e6bcb80c05937bccf7744d1bc2b348e172613f99d418ff588dcf68728386e72742f9d735965bc6cab674de1a02dd571394124b4b270e61e290
diff --git a/dev-php/theseer-DirectoryScanner/metadata.xml b/dev-php/theseer-DirectoryScanner/metadata.xml
new file mode 100644
index 000000000000..2146686530f9
--- /dev/null
+++ b/dev-php/theseer-DirectoryScanner/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">theseer/DirectoryScanner</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.2.ebuild b/dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.2.ebuild
new file mode 100644
index 000000000000..beb2fd3ab07f
--- /dev/null
+++ b/dev-php/theseer-DirectoryScanner/theseer-DirectoryScanner-1.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="DirectoryScanner"
+
+DESCRIPTION="A recursive directory scanner and filter"
+HOMEPAGE="https://github.com/theseer/DirectoryScanner"
+SRC_URI="https://github.com/theseer/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ insinto /usr/share/php/TheSeer/${MY_PN}
+ doins -r src/*
+
+ einstalldocs
+}