summaryrefslogtreecommitdiff
path: root/dev-php/tcpdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/tcpdf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/tcpdf')
-rw-r--r--dev-php/tcpdf/Manifest3
-rw-r--r--dev-php/tcpdf/metadata.xml11
-rw-r--r--dev-php/tcpdf/tcpdf-6.2.16.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-php/tcpdf/Manifest b/dev-php/tcpdf/Manifest
new file mode 100644
index 000000000000..606d9ad1f551
--- /dev/null
+++ b/dev-php/tcpdf/Manifest
@@ -0,0 +1,3 @@
+DIST tcpdf-6.2.16.tar.gz 17006033 BLAKE2B a4a9b502812bca3babe9d89bc215e75c951a2f3649ac01cf7327d5e13ccfd36e9586eb15a712fd48245f504ace2bcf7075413f9ee06526f4dec5c7d6c3e34b9d SHA512 302022636cd2c178e2d015b702188d59b608855110928e253daf7dd14e117a6770ad85385023c7970f13347142c60cc62a8fbdcee471364c47cb499fc3fbaa6c
+EBUILD tcpdf-6.2.16.ebuild 1016 BLAKE2B 7bc6a2f7a8d6eddb96ef8dbea07e6303d9557de293324c7541d455756f9003e91e339f6a1ed2cc7c8b0bb0f49c6e916c1ecfed56380e78139623a566b45ad635 SHA512 901a4fad0c30a5b8d76d78f0f60621f17f593dfa999a9482390ffd04f6e79f11d00c28d9fad57654dbf89a3eca5ea10a98bdf5c8255f6517a75c55daa70b3473
+MISC metadata.xml 320 BLAKE2B 74e0f7eb2cfc2dbbea9b1c275a52625a8d649aa2f5ae467c2df348f034ba51cadc4a6b34f66c2c8dc7752dc62e17441c0d92edacc065e5f2b295bada6c4928cd SHA512 b4f9bc199e0af92d393023cefbb7879bcf1631f6043f400254d948aba10b90a858c6d3a7a41f9ad14334a653ece24d1036acd0e18d7ae06363c1ae6364a0a120
diff --git a/dev-php/tcpdf/metadata.xml b/dev-php/tcpdf/metadata.xml
new file mode 100644
index 000000000000..40391479723e
--- /dev/null
+++ b/dev-php/tcpdf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tecnickcom/TCPDF</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/tcpdf/tcpdf-6.2.16.ebuild b/dev-php/tcpdf/tcpdf-6.2.16.ebuild
new file mode 100644
index 000000000000..5b1b109e8504
--- /dev/null
+++ b/dev-php/tcpdf/tcpdf-6.2.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="TCPDF is a FLOSS PHP class for generating PDF documents"
+HOMEPAGE="http://www.tcpdf.org/"
+SRC_URI="https://github.com/tecnickcom/TCPDF/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Main source is LGPL-3+, some included fonts have other licenses
+LICENSE="LGPL-3+ GPL-3 BitstreamVera GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php"
+
+S="${WORKDIR}/${P^^}"
+
+src_install() {
+ insinto /etc
+ doins config/tcpdf_config.php
+ # Create a symlink for the config file, because the library will only
+ # look for it in its own source tree (not in /etc where we've put it).
+ dosym ../../../../../etc/tcpdf_config.php "/usr/share/php/${PN}/config/tcpdf_config.php"
+
+ exeinto "/usr/share/php/${PN}/tools"
+ doexe tools/tcpdf_addfont.php
+
+ insinto "/usr/share/php/${PN}"
+ doins tcpdf*.php
+ doins -r include fonts
+ dodoc CHANGELOG.TXT README.md
+
+ use examples && dodoc -r examples
+}