summaryrefslogtreecommitdiff
path: root/dev-php/tcpdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-php/tcpdf
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-php/tcpdf')
-rw-r--r--dev-php/tcpdf/Manifest2
-rw-r--r--dev-php/tcpdf/tcpdf-6.2.26.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/tcpdf/Manifest b/dev-php/tcpdf/Manifest
index ced383ee9657..16db1a660679 100644
--- a/dev-php/tcpdf/Manifest
+++ b/dev-php/tcpdf/Manifest
@@ -1,3 +1,5 @@
DIST tcpdf-6.2.25.tar.gz 17006366 BLAKE2B f95d9d4931d56459d5ae9ea9bcaad72a31abaa8e9404fea17bc69089fb93b89d94a027512568282b6b8758651c3d347c3190a38db7ee200939cc045b9f12650b SHA512 d2e2bdf080c0a6af918a14c4f5704ee4bf7adad76044c89c3165afe392e39fa7bf98271da976cec7f024e3047e1df49090cb0206084efa77bb5b76708d6524c8
+DIST tcpdf-6.2.26.tar.gz 17004923 BLAKE2B bd99f036a808c0063d0cb48e59dab09f313d1dd19095d8131b38c161876f325736da73745a9e47d1ecc4b29b4e961db13761037cfa453d16127761c3518a9c96 SHA512 8ea2b1f2b3cfaa07a903cf286a63ab6b7e5e49881395f905e35740bcecf2ea8ffb1fd569d5dd4f6908918c8be1467be3051dff912416bc8ec80b8848068066be
EBUILD tcpdf-6.2.25.ebuild 1035 BLAKE2B 14abfbe7799e79ed77c39c212aeaa9ac1a21afc36a1b513efd198851cea8aba113ca6aef271c5b0e28558c60df17325adc0499fd4c7e13f24fb41996c04ac2bb SHA512 54f9ed75ac4aea625b96195b42ba3516a23e9a0c0acd518300712af9423c70c2a7079dc733d26d8c9bbe1b189bfd5a27b9d40a13f95df9df0d7a5a6d9a4a6bd2
+EBUILD tcpdf-6.2.26.ebuild 1035 BLAKE2B f60ee81bc0aaccdef90c9ad4c2549f455f83136723ad3e164fa374d76f4e16c53aa781c3acacf8380841cd9969703ab7790340a2e4965a10e89e63a35b61b041 SHA512 54ea23328fe03c40cff111889dc94799184bfde5ca7c4896b9a817c62bc56c0491594973ea43baf9f22d203129ae626e53e98be1be599fc36cd81c1605752bf2
MISC metadata.xml 320 BLAKE2B 74e0f7eb2cfc2dbbea9b1c275a52625a8d649aa2f5ae467c2df348f034ba51cadc4a6b34f66c2c8dc7752dc62e17441c0d92edacc065e5f2b295bada6c4928cd SHA512 b4f9bc199e0af92d393023cefbb7879bcf1631f6043f400254d948aba10b90a858c6d3a7a41f9ad14334a653ece24d1036acd0e18d7ae06363c1ae6364a0a120
diff --git a/dev-php/tcpdf/tcpdf-6.2.26.ebuild b/dev-php/tcpdf/tcpdf-6.2.26.ebuild
new file mode 100644
index 000000000000..533692a50169
--- /dev/null
+++ b/dev-php/tcpdf/tcpdf-6.2.26.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="TCPDF is a FLOSS PHP class for generating PDF documents"
+HOMEPAGE="http://www.tcpdf.org/"
+SRC_URI="https://github.com/tecnickcom/TCPDF/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Main source is LGPL-3+, some included fonts have other licenses
+LICENSE="LGPL-3+ GPL-3 BitstreamVera GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php"
+
+S="${WORKDIR}/${P^^}"
+
+src_install() {
+ insinto /etc
+ doins config/tcpdf_config.php
+ # Create a symlink for the config file, because the library will only
+ # look for it in its own source tree (not in /etc where we've put it).
+ dosym ../../../../../etc/tcpdf_config.php "/usr/share/php/${PN}/config/tcpdf_config.php"
+
+ exeinto "/usr/share/php/${PN}/tools"
+ doexe tools/tcpdf_addfont.php
+
+ insinto "/usr/share/php/${PN}"
+ doins tcpdf*.php
+ doins -r include fonts
+ DOCS=( CHANGELOG.TXT README.md )
+
+ use examples && HTML_DOCS=( examples )
+ einstalldocs
+}