summaryrefslogtreecommitdiff
path: root/dev-php/symfony-config/symfony-config-2.8.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/symfony-config/symfony-config-2.8.20.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/symfony-config/symfony-config-2.8.20.ebuild')
-rw-r--r--dev-php/symfony-config/symfony-config-2.8.20.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/symfony-config/symfony-config-2.8.20.ebuild b/dev-php/symfony-config/symfony-config-2.8.20.ebuild
new file mode 100644
index 000000000000..0daa831d25f0
--- /dev/null
+++ b/dev-php/symfony-config/symfony-config-2.8.20.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Symfony Config Component"
+HOMEPAGE="https://github.com/symfony/config"
+SRC_URI="https://github.com/symfony/config/archive/v${PV}.tar.gz
+ -> symfony-config-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ dev-php/symfony-filesystem"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
+
+S="${WORKDIR}/config-${PV}"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Config"
+ doins -r . "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/autoload-test.php" || die 'test suite failed'
+}