summaryrefslogtreecommitdiff
path: root/dev-php/swoole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-php/swoole
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-php/swoole')
-rw-r--r--dev-php/swoole/Manifest2
-rw-r--r--dev-php/swoole/swoole-4.1.1.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/swoole/Manifest b/dev-php/swoole/Manifest
index 58f27d206acb..f242398ed01d 100644
--- a/dev-php/swoole/Manifest
+++ b/dev-php/swoole/Manifest
@@ -1,5 +1,7 @@
DIST swoole-4.0.1.tgz 899395 BLAKE2B 7e7320905cb83794115280977031cc5254a4947781fde05db6e7803f34ff0f5c0ecad84f8aa86adc3c21320b031fa3104fb6c953e9060791dbd9d5c497edbcfc SHA512 0df6ae1bf28ec52abebf1a597c0774e7e5de4bb8378c916a46896c7f84822c8466bbb0d3d188e671e7c39faafa94d2dc2245a468dacb2711c7f0fa617dc42aa8
DIST swoole-4.0.4.tgz 907216 BLAKE2B f078f712c61c7ec9c1a98d94370c892fedd7d1efee7de34438a19d96fea9d41a0553d53fdd34c3d32138c6685045bf45be5fad533b0430b07cb7e60d183433d5 SHA512 b448abeec1fdfe94e0fd5d05b9c2abc7cfc2bb9477d6847adc35cba051d38acfb9ff3bdfaeb10591a50f5a6238f21cef4e0b614e1ff53c71f62b0bcd846d785f
+DIST swoole-4.1.1.tgz 930623 BLAKE2B fb4fa99b7b687aeaf4473983659cc2ceb7d8ba9ba6e198b49bea175b28918ebf8316c51f3ab7b4f75a9b7566941ddbba698c0d57f6ee752767c416e68fa68ca1 SHA512 4afc986f6ce362e28085d4ce07c534867311d65be487a66edfb0c01df7cf6e6d2df92abb2aba22b72f2840daade82b5bc3a12883d9cb54fd8ed9e6b0cdf0870f
EBUILD swoole-4.0.1.ebuild 1695 BLAKE2B 7720c6946b04a5c35c012187873a351919f02a4c9b8cf041b20f4777b57db65e8f2376a1cd121af0203d802227bedae046fd1aa3b3ea3c0fecc6c677f9f029ce SHA512 fa2a870086d261175ff9ed262bd3051a62bd12ba979a384d8fbfca121ba9cba74ffe55cf8f84c687eec4b449d57904d73232c637d87fb6cd5d42e7d1bff19ee5
EBUILD swoole-4.0.4.ebuild 1818 BLAKE2B 94bfc9d9802443718edef78fdfa3b86375e822b6ee5983b97c3a001e04fd15ae42b94c7dfd12b8439f976a6c035ccf0f7055a21a44107c0cf1e50b7dede89aef SHA512 cd256d3486b92e544db3ecf8a55c994b0305c1be747c7cb1497977a6b9ae6c1a242ceb6978c5f7a57cdef2fe57c0f04af596df5a74049a56eb788a996b6c6bf9
+EBUILD swoole-4.1.1.ebuild 1947 BLAKE2B 1b1d9303354b30520a39e48713548324bfac21fb0393452a056ab69fd02e886d487cec5bd7fff7029426e7783aa4e23310b2f5ec526b0fa5898d0485fa4e98db SHA512 db7f7032d2ef33a1610c5fea8ba314616715f0ba8d2e0ba8cf7fbdc2a8139a96b89e1352dcc66abbbe1211ac9c6f154a9c108715c4fa3b5c839ff86407e08972
MISC metadata.xml 424 BLAKE2B abaaecb73dd8caf77e25775dc2b3307efa430399d197b24f3ade567b93989108c70216949327677f5c9540e6aaafaf2f77d9af17b01f99de2ac6f04a95abb03b SHA512 52dc7ac48b61458b810ba467bbe5cfaeaef808ae7db72f58ba4ad4dd8723c7149995e43e94c8b4552e7dfc38cd1c3e627dd5c9854652ee656f421f345dd72471
diff --git a/dev-php/swoole/swoole-4.1.1.ebuild b/dev-php/swoole/swoole-4.1.1.ebuild
new file mode 100644
index 000000000000..8dfde46c3406
--- /dev/null
+++ b/dev-php/swoole/swoole-4.1.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="swoole"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-0 php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests can hang. Disable until this no longer happens
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/libaio
+ dev-libs/boost:0=
+ dev-libs/libpcre
+ http2? ( net-libs/nghttp2:0= )
+ redis? ( dev-libs/hiredis:0= )
+ ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:0= ) )
+ php_targets_php7-0? ( dev-lang/php:7.0[cli,sockets?] )
+ php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
+ php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
+ php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
+ mysql? (
+ php_targets_php7-0? ( dev-lang/php:7.0[mysql,mysqli(+)] )
+ php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
+ php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
+ php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug http2 libressl mysql redis sockets ssl threads"
+
+src_configure() {
+ # PostgreSQL disabled due to Gentoo's slot system
+ local PHP_EXT_ECONF_ARGS=(
+ --with-swoole
+ --disable-coroutine-postgresql
+ $(use_enable debug swoole-debug)
+ $(use_enable http2)
+ $(use_enable mysql mysqlnd)
+ $(use_enable redis async_redis)
+ $(use_enable ssl openssl)
+ $(use_with ssl openssl-dir "${EROOT%/}/usr")
+ $(use_enable threads thread)
+ $(use_enable sockets)
+ )
+
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ [[ -f tests/template.phpt ]] && rm tests/template.phpt
+ SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+ done
+}