summaryrefslogtreecommitdiff
path: root/dev-php/swoole/swoole-4.4.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-php/swoole/swoole-4.4.15.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-php/swoole/swoole-4.4.15.ebuild')
-rw-r--r--dev-php/swoole/swoole-4.4.15.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-php/swoole/swoole-4.4.15.ebuild b/dev-php/swoole/swoole-4.4.15.ebuild
deleted file mode 100644
index 4d978ebbd611..000000000000
--- a/dev-php/swoole/swoole-4.4.15.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="swoole"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_SAPIS="cli"
-DOCS=( README.md )
-
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-HOMEPAGE="https://www.swoole.co.uk"
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
-LICENSE="Apache-2.0"
-SLOT="0"
-# Tests can hang. Disable until this no longer happens
-RESTRICT="test"
-
-DEPEND="
- app-arch/brotli:0=
- dev-libs/libaio
- dev-libs/boost:0=
- dev-libs/libpcre
- sys-libs/zlib:0=
- http2? ( net-libs/nghttp2:0= )
- ssl? (
- dev-libs/openssl:0=
- )
- php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
- php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
- php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
- php_targets_php7-4? ( dev-lang/php:7.4[cli,sockets?] )
- mysql? (
- php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
- php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
- php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
- php_targets_php7-4? ( dev-lang/php:7.4[mysql,mysqli(+)] )
- )
-"
-
-RDEPEND="${DEPEND}"
-
-IUSE="debug http2 mysql sockets ssl"
-
-src_configure() {
- # JEMalloc not included as it refuses to find a ${ESYSROOT}/usr/includes/jemalloc subdirectory
- local PHP_EXT_ECONF_ARGS=(
- --enable-swoole
- $(use_enable debug)
- $(use_enable http2)
- $(use_enable mysql mysqlnd)
- $(use_enable ssl openssl)
- $(use_with ssl openssl-dir "${ESYSROOT}/usr")
- $(use_enable sockets)
- )
-
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- [[ -f tests/template.phpt ]] && rm tests/template.phpt
- SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
- done
-}