summaryrefslogtreecommitdiff
path: root/dev-php/swoole-async
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-php/swoole-async
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-php/swoole-async')
-rw-r--r--dev-php/swoole-async/Manifest3
-rw-r--r--dev-php/swoole-async/metadata.xml8
-rw-r--r--dev-php/swoole-async/swoole-async-4.4.12.ebuild51
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-php/swoole-async/Manifest b/dev-php/swoole-async/Manifest
new file mode 100644
index 000000000000..429235fd59e7
--- /dev/null
+++ b/dev-php/swoole-async/Manifest
@@ -0,0 +1,3 @@
+DIST swoole-async-4.4.12.tar.gz 417674 BLAKE2B 77a96f53b1b159b558eb4759fe172e4a3b8f2648cd9f49252d89508eb56b4d342b178fa3c84d6a425c300a286063b4d32a05d09a3da4f3769be4c25a9800783c SHA512 adfb761803e5ec93c30aa2a4bbc312a2f43287a54cd237c0a87237dfcbfe1e6daa3d57ec2cdf15720202aa9a7830ed67ab2efdf2f7dd81989c3693e91bc22143
+EBUILD swoole-async-4.4.12.ebuild 1057 BLAKE2B d27170880db3dd533f0bf66b08e2656bc4694a4ed38a3e45b7aad1db5ed94b205633ce4041486c87697a29eed857c930d77f208fca94d5e29ee29de51c5e57a7 SHA512 edb52f3826228bd5a20d316f62467bef487792ed081934d9dd71d02a411bfc7ddc61fc696e4f70d3cf99f2a182b6033e8242f9553ed2b365a009f121b8a2686d
+MISC metadata.xml 247 BLAKE2B b04f62f80c1381c62e7020a89486538dd3b4968a281721cf8213e25782a6e5bdf1a7199b2ae675bdcfbb954bc429f2b8af387d78523abe990ac881effbbfe67b SHA512 910677640181b5d854b46c6808d68ab56d826998ef3806d3915a98183cdc05cc81aebb02c8e13cbb26ba5c56c6db7020c97e7ba058e472e00a5530cf341c4012
diff --git a/dev-php/swoole-async/metadata.xml b/dev-php/swoole-async/metadata.xml
new file mode 100644
index 000000000000..d355171f926f
--- /dev/null
+++ b/dev-php/swoole-async/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/swoole-async/swoole-async-4.4.12.ebuild b/dev-php/swoole-async/swoole-async-4.4.12.ebuild
new file mode 100644
index 000000000000..845bfc568cc0
--- /dev/null
+++ b/dev-php/swoole-async/swoole-async-4.4.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="swoole_async"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+SRC_URI="https://github.com/swoole/ext-async/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ext-async-${PV}"
+PHP_EXT_S="${S}"
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="An extension of Swoole, including the async callback style API"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests will require pre-configured endpoint
+RESTRICT="test"
+
+DEPEND=">=dev-php/swoole-4.3"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-swoole_async
+ $(use_enable debug)
+ )
+
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ [[ -f tests/template.phpt ]] && rm tests/template.phpt
+ SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+ done
+}