summaryrefslogtreecommitdiff
path: root/dev-php/suhosin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/suhosin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/suhosin')
-rw-r--r--dev-php/suhosin/Manifest4
-rw-r--r--dev-php/suhosin/files/suhosin-0.9.38-libcrypt.patch12
-rw-r--r--dev-php/suhosin/metadata.xml8
-rw-r--r--dev-php/suhosin/suhosin-0.9.38-r1.ebuild56
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-php/suhosin/Manifest b/dev-php/suhosin/Manifest
new file mode 100644
index 000000000000..489e1ffd4a84
--- /dev/null
+++ b/dev-php/suhosin/Manifest
@@ -0,0 +1,4 @@
+AUX suhosin-0.9.38-libcrypt.patch 590 BLAKE2B db02346c66f348fd0be16fea1647deb1a6e44c2b10077f410ab919e7800e160439780d7b1c807f455cd3efb115765288c869cd96d719f4315150edfd73693085 SHA512 fa834f26803e2f623a269bc1cc81e305e081397717e0058315cac8087f04c33ff7f2eeee2052dada75559e5b35dc85c55499d74635dacd0f08fcc226ec3d0de3
+DIST suhosin-0.9.38.tar.gz 122800 BLAKE2B e016091e370bbcfdaad91d10858541cd730951be1032e95b4d372b5a77fce719e300cfa0638bf3ebde68e91d76b95c94ca56ce239997da69fc7ce5068b26ab49 SHA512 cc4eb38b5d6673cc3f2dc395e5a8b5461d3221019ac9849b747b6d5bae423cd5bd01a75b9432414dc7c26c78bab9f2381a5414712a6906a999f3ec9dc77ebc45
+EBUILD suhosin-0.9.38-r1.ebuild 1330 BLAKE2B bee0345e89d02138a9d79b5c91cf4c75fad99626e42a503034c2047910bf96f00941a066518633e4c84f6cede39bff9fe3414ede6c38ceb3dcec944b75e68058 SHA512 79341927c5c6351514d9ef257be38884c27beab3a91b3d873d52b2b1c34b6977296a499fc226c0b3ecbe5b7ef49d1d3f1e5f00acd834d1372babca6b7f9ef53f
+MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/suhosin/files/suhosin-0.9.38-libcrypt.patch b/dev-php/suhosin/files/suhosin-0.9.38-libcrypt.patch
new file mode 100644
index 000000000000..691f70c1b4c5
--- /dev/null
+++ b/dev-php/suhosin/files/suhosin-0.9.38-libcrypt.patch
@@ -0,0 +1,12 @@
+Index: suhosin-0.9.32.1/config.m4
+===================================================================
+--- suhosin-0.9.33.orig/config.m4
++++ suhosin-0.9.33/config.m4
+@@ -6,4 +6,7 @@ PHP_ARG_ENABLE(suhosin, whether to enabl
+
+ if test "$PHP_SUHOSIN" != "no"; then
+ PHP_NEW_EXTENSION(suhosin, suhosin.c sha256.c memory_limit.c treat_data.c ifilter.c post_handler.c ufilter.c rfc1867_new.c log.c header.c execute.c ex_imp.c session.c aes.c crypt.c, $ext_shared)
++ PHP_CHECK_LIBRARY(crypt, crypt,
++ [PHP_ADD_LIBRARY(crypt,, SUHOSIN_SHARED_LIBADD)])
++ PHP_SUBST(SUHOSIN_SHARED_LIBADD)
+ fi
diff --git a/dev-php/suhosin/metadata.xml b/dev-php/suhosin/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/suhosin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/suhosin/suhosin-0.9.38-r1.ebuild b/dev-php/suhosin/suhosin-0.9.38-r1.ebuild
new file mode 100644
index 000000000000..3372f3abe755
--- /dev/null
+++ b/dev-php/suhosin/suhosin-0.9.38-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="no"
+PHP_EXT_ZENDEXT="no"
+USE_PHP="php5-6"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations"
+HOMEPAGE="https://www.suhosin.org/"
+SRC_URI="https://download.suhosin.org/${P}.tar.gz"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[unicode] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-libcrypt.patch )
+DOCS=( CREDITS )
+
+src_install() {
+ php-ext-source-r3_src_install
+
+ local slot inifile
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ for inifile in $(php_slot_ini_files "${slot}") ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+ done
+}
+
+src_test() {
+ # Makefile passes a hard-coded -d extension_dir=./modules, we move the lib
+ # away from there in src_compile
+ for slot in `php_get_slots`; do
+ php_init_slot_env ${slot}
+ NO_INTERACTION="yes" emake test || die "emake test failed for slot ${slot}"
+ done
+}