summaryrefslogtreecommitdiff
path: root/dev-php/spdx-licenses
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/spdx-licenses
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/spdx-licenses')
-rw-r--r--dev-php/spdx-licenses/Manifest5
-rw-r--r--dev-php/spdx-licenses/files/autoload.php8
-rw-r--r--dev-php/spdx-licenses/files/spdx-licenses-change-res-path.patch22
-rw-r--r--dev-php/spdx-licenses/metadata.xml21
-rw-r--r--dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild26
5 files changed, 82 insertions, 0 deletions
diff --git a/dev-php/spdx-licenses/Manifest b/dev-php/spdx-licenses/Manifest
new file mode 100644
index 000000000000..e0c34b2fdd0b
--- /dev/null
+++ b/dev-php/spdx-licenses/Manifest
@@ -0,0 +1,5 @@
+AUX autoload.php 264 SHA256 fec461be03416c65e41f7bd2f947f3458efa4a4f63aa4947eb7e90c00b0cc5a4 SHA512 6dd28dc205943fa5fa8fb7577a88926573533d553e86577ec2d2e34045ea744731ea08c9dfee277dd1550cac033ac53d1648aa8b28fc78eaa73d0613371aaaa7 WHIRLPOOL 661c8ab462f2ef881c56848d22294b7cbbc7e79a08fc34fa4ca8c20db7866bd0ed8e8982d27bd21b2bb295c8492b4ccc0ca3e8b6ad9876f7e277208fe063122b
+AUX spdx-licenses-change-res-path.patch 872 SHA256 c5c31059df2f232ce16ce6152741faa3b8906a866ce30cc15386b96f4e2042ca SHA512 9050ac3f4ab33172a8edee04434f3e0c3b38d53a51c590d2c65c4ba0bfb0b718c702275cfd448bf6b850549589569c5a8d15d2f82fcb35c36efd9cac9e6deb1e WHIRLPOOL 9075fc97e09fff0928d81349527322f7e5f39a99bb0d754c5e27f588774891d821334426202095531d6592cad2472169431a37db3caabb7186232f18206b66da
+DIST spdx-licenses-1.0.0.tar.gz 8244 SHA256 c292e3bfaa75b0e9b87b7426576a17390ca2f6df37ba002bd1d8561d0ffa4518 SHA512 1ef19555f252c5e03fe3b0376442f47bd50d894effa04bca58e7644e18fcc2a905239086d1aaf31277ce5928a7f9743e123c767e197c0fa063c015ad14851a14 WHIRLPOOL 6f69389f2fe5d55a729b10552cb2c54e8e6473fc5a9d9ace453de76f8bf6f89ae41135feeb89b833d025f8e4b25136730b4006ce0078eaceb236c5d1af52b7d2
+EBUILD spdx-licenses-1.0.0.ebuild 596 SHA256 5a22c8c709842131c2b26f2d6686649a5f801f74f795abfb9b6ff6454d14d3e3 SHA512 1ed43a022d3c0ff5c714cb278e68dcfba9ed7f8adfc78de1eac93fd7aaccdfb5197f42604cf0b9616b6bea07558c79a08c1f39f88012bb20e6d5575d76f4043d WHIRLPOOL b83a6f363ae033494fff3b66719f76c75a531b469807f59686208ff9b1f00c82675299d7a928716fe9eeaba97a79a41b5328e5b8dc7db31fc754d8a467b0c223
+MISC metadata.xml 673 SHA256 e8ae9a47dd2f17e6ea4daf181c116d4657e113edf510aa04a6e23858109878d4 SHA512 f4f7ba3fa5e3c9c85394cb868c02ee562ddfe7308b018320de5d7eab3b86b09eb6ac0fe94af1c162f639ef377dff670cded2185ad47ec78a0c287ad017bd6e48 WHIRLPOOL c6e68fcf2080c26899af91d6f0417814029da0d5bcbc9272b021b78ea1ee9e849a0db58a6344d7d1ba83f5cb33e4ce62b2876bd38d6e9d4768c28a5bb30d845a
diff --git a/dev-php/spdx-licenses/files/autoload.php b/dev-php/spdx-licenses/files/autoload.php
new file mode 100644
index 000000000000..6ebf96e7378c
--- /dev/null
+++ b/dev-php/spdx-licenses/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for composer/ca-bundle and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Composer\\Spdx\\', __DIR__);
diff --git a/dev-php/spdx-licenses/files/spdx-licenses-change-res-path.patch b/dev-php/spdx-licenses/files/spdx-licenses-change-res-path.patch
new file mode 100644
index 000000000000..284cdddda95e
--- /dev/null
+++ b/dev-php/spdx-licenses/files/spdx-licenses-change-res-path.patch
@@ -0,0 +1,22 @@
+# Fix the path of res/
+
+--- ./src/SpdxLicenses.php 2015-07-15 19:38:14.000000000 +0200
++++ ./src/SpdxLicenses.php 2016-11-13 19:24:17.659442468 +0100
+@@ -170,7 +170,7 @@
+ private function loadLicenses()
+ {
+ if (null === $this->licenses) {
+- $jsonFile = file_get_contents(__DIR__ . '/../res/spdx-licenses.json');
++ $jsonFile = file_get_contents(__DIR__ . '/res/spdx-licenses.json');
+ $this->licenses = json_decode($jsonFile, true);
+ }
+ }
+@@ -178,7 +178,7 @@
+ private function loadExceptions()
+ {
+ if (null === $this->exceptions) {
+- $jsonFile = file_get_contents(__DIR__ . '/../res/spdx-exceptions.json');
++ $jsonFile = file_get_contents(__DIR__ . '/res/spdx-exceptions.json');
+ $this->exceptions = json_decode($jsonFile, true);
+ }
+ }
diff --git a/dev-php/spdx-licenses/metadata.xml b/dev-php/spdx-licenses/metadata.xml
new file mode 100644
index 000000000000..6cb602111427
--- /dev/null
+++ b/dev-php/spdx-licenses/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Tools for working with the SPDX license list and validating licenses.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">composer/spdx-licenses</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild b/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild
new file mode 100644
index 000000000000..099ed89b2b7e
--- /dev/null
+++ b/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tools for working with and validating SPDX licenses"
+HOMEPAGE="https://github.com/composer/spdx-licenses"
+SRC_URI="https://github.com/composer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-change-res-path.patch"
+)
+
+src_install() {
+ insinto "/usr/share/php/Composer/Spdx"
+ doins -r src/. res "${FILESDIR}"/autoload.php
+ dodoc README.md
+}