summaryrefslogtreecommitdiff
path: root/dev-php/securimage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/securimage
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/securimage')
-rw-r--r--dev-php/securimage/Manifest3
-rw-r--r--dev-php/securimage/metadata.xml4
-rw-r--r--dev-php/securimage/securimage-3.6.5.ebuild28
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/securimage/Manifest b/dev-php/securimage/Manifest
new file mode 100644
index 000000000000..6a8884bd956e
--- /dev/null
+++ b/dev-php/securimage/Manifest
@@ -0,0 +1,3 @@
+DIST securimage-3.6.5.tar.gz 7590487 BLAKE2B 0285860497edf6c89e043b8cb660a6f5948e6ae7d80dacdd83ed37705856fd225e0c9ed43973eb837e85734f1d3c528d210f251d5cbc68c457cac224fea55fb7 SHA512 776130271f54d50cae5d9a71fed4bfe4870c187cbda55314b49706b3d88c8e76c283c09ead195f89b074fba8b16ddb22e25c268d80d01ee34e9dc5d624e12e7d
+EBUILD securimage-3.6.5.ebuild 635 BLAKE2B 8fc02aae3d8e8d53646feaf29d109ca6abe3a08f07815d57a78ba106a3db4d889d79265c5a53f01e45d55409387f275b2c59a5f432d3f38ddeed0d444f0a116c SHA512 c462622f8e1c59907563a99224fefd12eca557065b6971832a857f8b4c8da7ef1cc8e81524e72192150e80f71cb8c93e6c277c2c88f3615baa944b10e8829d8b
+MISC metadata.xml 139 BLAKE2B b4a59c22790dfec3fbcfaea41ef363401766736b68a85bedae00e1944d0a848aa97104c2f34244c0fe7b6363029281f965fc1b3545301d341cda371eaa976274 SHA512 8be912ace7468a4396eb1da00a9785030a8ce35da4357a01591876a1056fd45e44da65de2af3e1eb0506ce6551714962c40c3ae5a3aefa2ad231de35af2519be
diff --git a/dev-php/securimage/metadata.xml b/dev-php/securimage/metadata.xml
new file mode 100644
index 000000000000..097975e3adc2
--- /dev/null
+++ b/dev-php/securimage/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/dev-php/securimage/securimage-3.6.5.ebuild b/dev-php/securimage/securimage-3.6.5.ebuild
new file mode 100644
index 000000000000..29e513246e5c
--- /dev/null
+++ b/dev-php/securimage/securimage-3.6.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP captcha creator and validator library"
+HOMEPAGE="https://www.phpcaptcha.org/"
+SRC_URI="https://github.com/dapphp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[gd,truetype]
+ virtual/httpd-php"
+
+src_install()
+{
+ # Grab all PHP files except the examples.
+ set *.php
+ local php_files=${@/*example*/}
+
+ insinto /usr/share/php/${PN}
+ doins -r ${php_files} *.{ttf,swf} audio backgrounds database images words
+
+ dodoc README*
+}