summaryrefslogtreecommitdiff
path: root/dev-php/sebastian-type
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-php/sebastian-type
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-php/sebastian-type')
-rw-r--r--dev-php/sebastian-type/Manifest2
-rw-r--r--dev-php/sebastian-type/sebastian-type-1.1.4.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/sebastian-type/Manifest b/dev-php/sebastian-type/Manifest
index e35753f6d29e..96743b7446f8 100644
--- a/dev-php/sebastian-type/Manifest
+++ b/dev-php/sebastian-type/Manifest
@@ -1,4 +1,6 @@
AUX autoload.php 987 BLAKE2B 0df6eddcfe9551d42430d60c490def57e0b8426412f20964716b595345513bbbce293d8f6fb9157e1e7aaf1e1d08beeeac5cd4826e063542f05fdf66447bfe9e SHA512 104c4841f8c6994bd4b7b8b57253ec41adf823b14fb0545b1d5c8c31066a1dbc8ad79de6b2140eb395a4ad24093231cdc5a72f27f254b3cf7fa3299890871386
DIST sebastian-type-1.1.3.tar.gz 19031 BLAKE2B 5e0d191cbc9315661f226aca14849ac4afa6d9e1dc59ca6033c60e425c94ee8b9ad49ab1c2b94c7814654bbadbaadd0164fadb1494f88c9521b2583985ba0281 SHA512 27b455c7a5f1125c916ea56fd933ef9ffa659b3fa6addf8d2c5956e4efef5bd8ffadc686e5dddfc50ba09a300c8148af7dded4249f404e15923e77102ab777fc
+DIST sebastian-type-1.1.4.tar.gz 19091 BLAKE2B 17a10d98c7356002b474ebab2c128631593ee175033fe9088a6fdfc29f020e33f1f090c1fb47c9890c686d41d207f5c8d2f6fffccd1e53341b8244b2633f55a1 SHA512 5320cad60dc79b213f30ec7b962d9e178ca7e49053eac040a50df3cea05579741f39bdc13872fb1b2d7c779a8e201767ee9550f47bb39cfca9fdac763886390d
EBUILD sebastian-type-1.1.3.ebuild 643 BLAKE2B d3b7e19e6e08c54cf2e0e8df825a49c219b983ba684c941ee9339ecf7d310d7c4fc6bb855004f09c8eb82dedbc7ff8f90fd32fdd5bbd3c0693402c0f40992b0b SHA512 144b092cfad744f4b82ed13964f211b32bd6d5de663f981531a62ae232890db6b705cdfb08ca56f8a2416d82bdc0c37592f003e45f5a08d10ca0cbeb17c7d64c
+EBUILD sebastian-type-1.1.4.ebuild 805 BLAKE2B 6e1bf0da4d3de7b57b66590b2375c4f8c807a51646212f45082d3f294499e813c97dfee28409769bc7cd10ba5081fc40d9fe327bc9fae76e3f628898fb7a4dee SHA512 95d692c4bbd180208490ae1d4e296abd4cb27416a0a1ba3a3666c73d17dba5c86acce6c8bac345e6baa49d8ee2a3f2504075a0a9298ed40795b7c239e3781c16
MISC metadata.xml 350 BLAKE2B eb58243d81ac1addd4c61eb07d51fe0d542795e7b74f1cd436cad066f67a6ce74c4645c9530205c174cd1433cf50fec610eac79be91bfcb094cccf2b740a7659 SHA512 c6329de1536c442a1a1285f90b0d4df477310d0d7eb3e3edab6c21947f01e0e48fb75b76b6548ec7f70e0c170708050a97f2ed0f4b1ddd4a7fc412a9f6ed406c
diff --git a/dev-php/sebastian-type/sebastian-type-1.1.4.ebuild b/dev-php/sebastian-type/sebastian-type-1.1.4.ebuild
new file mode 100644
index 000000000000..2a0d5cf2d201
--- /dev/null
+++ b/dev-php/sebastian-type/sebastian-type-1.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-/}"
+
+DESCRIPTION="Collection of value objects that represent the types of the PHP type system"
+HOMEPAGE="https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.2:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+}
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Type
+ doins -r src/.
+
+ einstalldocs
+}