summaryrefslogtreecommitdiff
path: root/dev-php/sebastian-type
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-php/sebastian-type
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-php/sebastian-type')
-rw-r--r--dev-php/sebastian-type/Manifest4
-rw-r--r--dev-php/sebastian-type/files/autoload.php24
-rw-r--r--dev-php/sebastian-type/metadata.xml11
-rw-r--r--dev-php/sebastian-type/sebastian-type-1.1.3.ebuild26
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-php/sebastian-type/Manifest b/dev-php/sebastian-type/Manifest
new file mode 100644
index 000000000000..1db317c680e6
--- /dev/null
+++ b/dev-php/sebastian-type/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 987 BLAKE2B 0df6eddcfe9551d42430d60c490def57e0b8426412f20964716b595345513bbbce293d8f6fb9157e1e7aaf1e1d08beeeac5cd4826e063542f05fdf66447bfe9e SHA512 104c4841f8c6994bd4b7b8b57253ec41adf823b14fb0545b1d5c8c31066a1dbc8ad79de6b2140eb395a4ad24093231cdc5a72f27f254b3cf7fa3299890871386
+DIST sebastian-type-1.1.3.tar.gz 19031 BLAKE2B 5e0d191cbc9315661f226aca14849ac4afa6d9e1dc59ca6033c60e425c94ee8b9ad49ab1c2b94c7814654bbadbaadd0164fadb1494f88c9521b2583985ba0281 SHA512 27b455c7a5f1125c916ea56fd933ef9ffa659b3fa6addf8d2c5956e4efef5bd8ffadc686e5dddfc50ba09a300c8148af7dded4249f404e15923e77102ab777fc
+EBUILD sebastian-type-1.1.3.ebuild 652 BLAKE2B ab32e14b06e9a3bc6f7ee688953edd326352507b53847d9c354e353ec125e5a487a543f4af73911c2e91ac4d2a149ead762dfff6923d8432945bcc8f87152ea4 SHA512 13091d9185a11a0c282e0ac66828e64d4ea1cd99b2596f01a2f821bca7edbfbcbd258c9a461dd76ce42733b2db9cb63e240ddd27b86a343000ee6fa5d977b6d7
+MISC metadata.xml 326 BLAKE2B f8c5ba19312b005175c9631474a3ce08f75bd91d278e25e413e1c5b38862518993ca241ebcc4b15db5458e5a012937996bf3087bf2cecfd759a0d06b504bbd4f SHA512 8587dcecc21296546628406891914d9962adcaedeef9d3248e6e4f0d48992cffa90a2bb4c71a00fd78eedc2d02f16a1b3e49a089e84e1fca116118b52fa1841a
diff --git a/dev-php/sebastian-type/files/autoload.php b/dev-php/sebastian-type/files/autoload.php
new file mode 100644
index 000000000000..91b60dbf64b2
--- /dev/null
+++ b/dev-php/sebastian-type/files/autoload.php
@@ -0,0 +1,24 @@
+<?php
+/* Autoloader for dev-php/sebastian-version */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ [
+ 'sebastianbergmann\type\callabletype' => '/CallableType.php',
+ 'sebastianbergmann\type\genericobjecttype' => '/GenericObjectType.php',
+ 'sebastianbergmann\type\iterabletype' => '/IterableType.php',
+ 'sebastianbergmann\type\nulltype' => '/NullType.php',
+ 'sebastianbergmann\type\objecttype' => '/ObjectType.php',
+ 'sebastianbergmann\type\simpletype' => '/SimpleType.php',
+ 'sebastianbergmann\type\type' => '/Type.php',
+ 'sebastianbergmann\type\typename' => '/TypeName.php',
+ 'sebastianbergmann\type\unknowntype' => '/UnknownType.php',
+ 'sebastianbergmann\type\voidtype' => '/VoidType.php',
+ 'sebastianbergmann\type\exception' => '/exception/Exception.php',
+ 'sebastianbergmann\type\runtimeexception' => '/exception/RuntimeException.php',
+ ],
+ __DIR__
+);
diff --git a/dev-php/sebastian-type/metadata.xml b/dev-php/sebastian-type/metadata.xml
new file mode 100644
index 000000000000..59391408bb95
--- /dev/null
+++ b/dev-php/sebastian-type/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sebastianbergmann/type</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/sebastian-type/sebastian-type-1.1.3.ebuild b/dev-php/sebastian-type/sebastian-type-1.1.3.ebuild
new file mode 100644
index 000000000000..4721b8b1b52d
--- /dev/null
+++ b/dev-php/sebastian-type/sebastian-type-1.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="type"
+
+DESCRIPTION="Collection of value objects that represent the types of the PHP type system"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.2:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Type
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}