summaryrefslogtreecommitdiff
path: root/dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild')
-rw-r--r--dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild b/dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild
new file mode 100644
index 000000000000..1fedec0cb35f
--- /dev/null
+++ b/dev-php/sebastian-object-enumerator/sebastian-object-enumerator-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Traverses array structures and object graphs to enumerate all referenced objects"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/sebastian-recursion-context-3.0
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/ObjectEnumerator
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}