summaryrefslogtreecommitdiff
path: root/dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild')
-rw-r--r--dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild b/dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild
new file mode 100644
index 000000000000..380721a6128a
--- /dev/null
+++ b/dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Export PHP variables for visualization"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ =dev-php/sebastian-recursion-context-3*
+ =dev-lang/php-7*:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Exporter
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}