summaryrefslogtreecommitdiff
path: root/dev-php/sebastian-environment
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/sebastian-environment
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/sebastian-environment')
-rw-r--r--dev-php/sebastian-environment/Manifest4
-rw-r--r--dev-php/sebastian-environment/files/autoload.php14
-rw-r--r--dev-php/sebastian-environment/metadata.xml11
-rw-r--r--dev-php/sebastian-environment/sebastian-environment-2.0.0.ebuild26
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-php/sebastian-environment/Manifest b/dev-php/sebastian-environment/Manifest
new file mode 100644
index 000000000000..2bb5af06f683
--- /dev/null
+++ b/dev-php/sebastian-environment/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 372 BLAKE2B 3d2843946daf17f3c367b04f1b5295ac67bdff8e1a409537f895eb7ed06a946ca3bc52647e8454d398b574ca948588951b29156d553b0a5f4b741b9dc828c708 SHA512 7fc348367571b5c7409635ec61c2b06f7fea3b640998f93eca87423529ecc4c933cfb5b033152081dd42817e9861d2fdfddcfb5f0d08d51ccf60d5c12f56a76d
+DIST sebastian-environment-2.0.0.tar.gz 5607 BLAKE2B 3c34c6e61d9a0bdc5df8083331390935bd513d735a1509890a9af05be8b5a718bbb1d5826ab0cb80da2ee5c4cd436b22ef4ccb50c7b4e1c11d361a78b51621c3 SHA512 cf91f0a5f057007f318c5d6b11f8a1345b8df35d513c6291c5b725f0874ed301a64d1097c3fac1e6b32533caa96b3f78ac415d99b9b6ef63dc4a303b90d49c88
+EBUILD sebastian-environment-2.0.0.ebuild 656 BLAKE2B 49d6b5efe432e3e095a9386fe4f9fc6972d275df11d2c23c7b2416e5b764176b356c9a2a435b31ac3a656ba9035866f65a96a99746ad3592081a77449f651380 SHA512 5872fb40b001e6ff45ef3db6e69308c2e71e2694ad30020c052d0128a51ae873b030d79399955df5a4d7e893d1a534afc92c0334e48a65fc5696551226fbe6f6
+MISC metadata.xml 322 BLAKE2B b031a3917e07e8c98b19228e012a05a46e4ad57b59e394efc345092541c652f2df5f2fe4fe35be69eb9c62f64bf55f0a12636ff9cafa2f510d06b86916f869cb SHA512 e345c6459f1c0f795081e2874aa4a4023998d0a0f6b28462468ef89c7cfaf38366671a68d05516e6d0f3e03b0cdfcbe849c1e224f7b1e3a723232c7db32281b6
diff --git a/dev-php/sebastian-environment/files/autoload.php b/dev-php/sebastian-environment/files/autoload.php
new file mode 100644
index 000000000000..3abd16ee357b
--- /dev/null
+++ b/dev-php/sebastian-environment/files/autoload.php
@@ -0,0 +1,14 @@
+<?php
+/* Autoloader for dev-php/sebastian-environment */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ array(
+ 'sebastianbergmann\environment\console' => '/Console.php',
+ 'sebastianbergmann\environment\runtime' => '/Runtime.php',
+ ),
+ __DIR__
+);
diff --git a/dev-php/sebastian-environment/metadata.xml b/dev-php/sebastian-environment/metadata.xml
new file mode 100644
index 000000000000..f5ad6af5af2e
--- /dev/null
+++ b/dev-php/sebastian-environment/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sebastianbergmann/</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/sebastian-environment/sebastian-environment-2.0.0.ebuild b/dev-php/sebastian-environment/sebastian-environment-2.0.0.ebuild
new file mode 100644
index 000000000000..82b41ca2bfcd
--- /dev/null
+++ b/dev-php/sebastian-environment/sebastian-environment-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Helps writing PHP code that has runtime-specific execution paths"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Environment
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}