summaryrefslogtreecommitdiff
path: root/dev-php/scrypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-php/scrypt
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-php/scrypt')
-rw-r--r--dev-php/scrypt/Manifest5
-rw-r--r--dev-php/scrypt/files/scrypt-1.4.2-php8-0.patch49
-rw-r--r--dev-php/scrypt/metadata.xml22
-rw-r--r--dev-php/scrypt/scrypt-1.4.2.ebuild20
-rw-r--r--dev-php/scrypt/scrypt-9999.ebuild20
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-php/scrypt/Manifest b/dev-php/scrypt/Manifest
new file mode 100644
index 000000000000..414b4086348b
--- /dev/null
+++ b/dev-php/scrypt/Manifest
@@ -0,0 +1,5 @@
+AUX scrypt-1.4.2-php8-0.patch 1277 BLAKE2B 1bccdc8deb053f13e7075f0d52a14a0f0767fa1f2d2f487ef6387f5b6dcba84879350051f85689e3e2518a53a5952836adc566d4c42e2b8fb08ee81280929637 SHA512 75ed1c9da84fd121941df5bca59b26cb90158817fd4efec375cfe923868c439efdd9f6f06e2c153eda9bfd4e4cc095f22e32b37056c8ea3ed0eeeb1f13e77e0b
+DIST scrypt-1.4.2.tgz 21585 BLAKE2B 6297b15aac8470eedc619c498badc4e453476a390cab0cfe7fabef00012131ff9e363834b9423a566dba603ea2a4351eee416419cc1e6c1245a9aba54d63a5ab SHA512 34a87e63250dcfb21b3d36f90a4e5f4bac9f0623917ceb0d613d49112ce0e13df9a93fb0730fb797be6337d023dc490fb881902b5492309fe8bf3e6fd5e685a0
+EBUILD scrypt-1.4.2.ebuild 395 BLAKE2B dbb271382adf2201d669bcf774ad18e766434b9adc391f76eb81a7e6c31e485a192b298d15daa01be4e3cc467d003b8eecc522e8c808a52315c10498bd55eb39 SHA512 991c793096493e35138ec3998e13ed78ca9c6899223e0b3cc0340980de965fa1fcb3c30a08f5997381f00632b1a7606aef35aa2697e78e94b15cdea79c3e8df7
+EBUILD scrypt-9999.ebuild 414 BLAKE2B 5262f81f837afb03250dd545892d45586df821b04661edb35ea1d826c51b7b2638fc707779fa34307cd3e5924f4182fd9bd959a8135e58845a52361db32a3a1f SHA512 7711fc2f3b8094c691823440f3dd87d3973b54a1e0139e6d2689ecabd5a24241388dc2f77ee52f46435914cfdc2de8768628897398383c09afa7957a22f829eb
+MISC metadata.xml 791 BLAKE2B 54438dacf2c3e77edf475a1f695b58c4606f7492d39a74688ba4a2f36afeacf94560e63748fc097e962d6fd79883489281463c31449591f8fe6a84602c126658 SHA512 b551b92c17a66648f281b07d638af5f6e4fc703ecece2b594bd7d1b0753687c1f0e67e0607f4eeea5f708f76e348a8cc352ead97e5264368fb3e070d8d748419
diff --git a/dev-php/scrypt/files/scrypt-1.4.2-php8-0.patch b/dev-php/scrypt/files/scrypt-1.4.2-php8-0.patch
new file mode 100644
index 000000000000..a5e1ea665897
--- /dev/null
+++ b/dev-php/scrypt/files/scrypt-1.4.2-php8-0.patch
@@ -0,0 +1,49 @@
+From 5010f9fa0743518d149d994728ca930503adde1e Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 22 Sep 2020 14:55:32 +0200
+Subject: [PATCH] trivial fix for PHP 8
+
+---
+ crypto/crypto_scrypt-sse.c | 1 +
+ php_scrypt.h | 5 +++++
+ php_scrypt_utils.c | 1 +
+ 3 files changed, 7 insertions(+)
+
+diff --git a/crypto/crypto_scrypt-sse.c b/crypto/crypto_scrypt-sse.c
+index a52ce81..709a04f 100644
+--- a/crypto/crypto_scrypt-sse.c
++++ b/crypto/crypto_scrypt-sse.c
+@@ -44,6 +44,7 @@
+ #include "sysendian.h"
+
+ #include "crypto_scrypt.h"
++#include "php_scrypt.h"
+
+ static void blkcpy(void *, void *, size_t);
+ static void blkxor(void *, void *, size_t);
+diff --git a/php_scrypt.h b/php_scrypt.h
+index a1117c8..6cc1c4c 100644
+--- a/php_scrypt.h
++++ b/php_scrypt.h
+@@ -35,4 +35,9 @@ PHP_FUNCTION(scrypt_pickparams);
+ extern zend_module_entry scrypt_module_entry;
+ #define phpext_scrypt_ptr &scrypt_module_entry
+
++#ifndef TSRMLS_CC
++#define TSRMLS_CC
++#define TSRMLS_FETCH()
++#endif
++
+ #endif
+diff --git a/php_scrypt_utils.c b/php_scrypt_utils.c
+index 797e2c7..34fe347 100644
+--- a/php_scrypt_utils.c
++++ b/php_scrypt_utils.c
+@@ -25,6 +25,7 @@
+ */
+
+ #include "php_scrypt_utils.h"
++#include "php_scrypt.h"
+
+ /*
+ * Casts a long into a uint64_t.
diff --git a/dev-php/scrypt/metadata.xml b/dev-php/scrypt/metadata.xml
new file mode 100644
index 000000000000..7fd91a5b5f80
--- /dev/null
+++ b/dev-php/scrypt/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>spiderx@spiderx.dp.ua</email>
+ <name>Vladimir Pavljuchenkov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ A PHP library providing a wrapper to Colin Percival's scrypt
+ implementation. Scrypt is a key derivation function designed
+ to be far more secure against hardware brute-force attacks
+ than alternative functions such as PBKDF2 or bcrypt.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">DomBlack/php-scrypt</remote-id>
+ <remote-id type="pecl">scrypt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/scrypt/scrypt-1.4.2.ebuild b/dev-php/scrypt/scrypt-1.4.2.ebuild
new file mode 100644
index 000000000000..026a54355943
--- /dev/null
+++ b/dev-php/scrypt/scrypt-1.4.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_ECONF_ARGS="--enable-scrypt"
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="A PHP wrapper fo the scrypt hashing algorithm"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/re2c"
+
+PATCHES=( "${FILESDIR}"/"${P}"-php8-0.patch )
diff --git a/dev-php/scrypt/scrypt-9999.ebuild b/dev-php/scrypt/scrypt-9999.ebuild
new file mode 100644
index 000000000000..900385d5cf23
--- /dev/null
+++ b/dev-php/scrypt/scrypt-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_ECONF_ARGS="--enable-scrypt"
+USE_PHP="php7-3 php7-4 php8-0"
+EGIT_REPO_URI="https://github.com/DomBlack/php-scrypt.git"
+
+inherit git-r3 php-ext-pecl-r3
+
+DESCRIPTION="A PHP wrapper fo the scrypt hashing algorithm"
+SRC_URI=""
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-util/re2c"