summaryrefslogtreecommitdiff
path: root/dev-php/recaptcha
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-07 20:12:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-07 20:12:29 +0100
commit1f45d596fc838ad34ca4c17b7db7882f5048cec2 (patch)
treee5e2e397951ee044e0751efacb8b59ea81f9b605 /dev-php/recaptcha
parent32c7b79bcc8a67e6bc6516adbc729e83f957a368 (diff)
gentoo auto-resync : 07:08:2022 - 20:12:29
Diffstat (limited to 'dev-php/recaptcha')
-rw-r--r--dev-php/recaptcha/Manifest2
-rw-r--r--dev-php/recaptcha/recaptcha-1.2.4.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-php/recaptcha/Manifest b/dev-php/recaptcha/Manifest
index c3373984872a..50aa6c7f8da5 100644
--- a/dev-php/recaptcha/Manifest
+++ b/dev-php/recaptcha/Manifest
@@ -1,3 +1,5 @@
DIST recaptcha-1.2.1.tar.gz 19935 BLAKE2B 43077b25d484940951bf070fa440b5d13c6992c2a157e06b81961b9692683a277d9507e44102dd0ba0cde66c892fd4736ed34cae4b001bdce0d4ab619828b432 SHA512 62df22a6f4b05006a6051db689994e455ada43f76406dd62c5c13f1d90ae64401e9d75c6a92f2c620a14c070d2b49199c20e70eb6284e42e676d37412a98abe4
+DIST recaptcha-1.2.4.tar.gz 21762 BLAKE2B 46c00ac95f2d2643a719b8ea4b53f33f92357406168e057dbdb87fb1419dd6626d1032113ba5842c69bdacb385887563b52290a55a861b57ddcf494e325c0595 SHA512 7c0bee86e532547900a0131c2c52d9d3e427eb0465d7ae5ca2bd3ccbeb7620c8b3216313e4ab382013045310f928364c1284a77eee2f2216d5b241e2d275597d
EBUILD recaptcha-1.2.1.ebuild 961 BLAKE2B 1148399f70997bb7e82122b444191fd16e8da1656ac143aa8e521c0ab48f140dfb8a34a63e2a086dc63d3a4429ea50297270f2d7f5d60472b048375c8a309919 SHA512 2ac8660be8ce12e72dd56fcac4725aecc0271ee291ff0a7f1c40260aaad98cfbaac4a320e0a2cedcd5a447fdc2dcd8208068fddb5a92ed909a7ff248b197ff0f
+EBUILD recaptcha-1.2.4.ebuild 963 BLAKE2B bc45efc2e0e5e2fc5a2cb067ba74874d3f6b8be856da6b844b9a811bc27daccbed286677e45cdc84476937cc7050438e33b856497490bf5f8572acb5a84d62fc SHA512 998866c13cc5a0d4b9d8c5ad10b307e43f3659df03224a5bb8c5987a04da331192f2db25122977c814fd034df21d4410cf0d4a5f21b2e2edb6ab0cd891d34a75
MISC metadata.xml 338 BLAKE2B 4996f6af2e4d27d365e99f80193f68f46977e5b9def7750a44e1812da4a30874ba0c059ae54f182164acd3e74e8000023896376a25a980f0c622c93d43b289ba SHA512 fea2dfbde221e63be154fb8836b63e5db399daf6ad4cd602e7f7317c5b35c4a363a8b8eb21fcdfda471486dd006fee948a06339385bcbd202cb32d4f886ef7e2
diff --git a/dev-php/recaptcha/recaptcha-1.2.4.ebuild b/dev-php/recaptcha/recaptcha-1.2.4.ebuild
new file mode 100644
index 000000000000..de078821e3da
--- /dev/null
+++ b/dev-php/recaptcha/recaptcha-1.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PHP client library for Google's reCAPTCHA service"
+HOMEPAGE="https://github.com/google/recaptcha"
+SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/php"
+BDEPEND="test? ( ${RDEPEND} <dev-php/phpunit-8 )"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r src/autoload.php src/ReCaptcha
+ dodoc CONTRIBUTING.md README.md
+ use examples && dodoc -r examples
+}
+
+src_test() {
+ phpunit || die "test suite failed"
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/autoload.php'),"
+ elog "and then use the ${PN} class normally. Most of the examples in"
+ elog "the documentation should work without further modification."
+}