summaryrefslogtreecommitdiff
path: root/dev-php/realpath_turbo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-php/realpath_turbo
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-php/realpath_turbo')
-rw-r--r--dev-php/realpath_turbo/Manifest3
-rw-r--r--dev-php/realpath_turbo/metadata.xml15
-rw-r--r--dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild28
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-php/realpath_turbo/Manifest b/dev-php/realpath_turbo/Manifest
new file mode 100644
index 000000000000..e866cf62719b
--- /dev/null
+++ b/dev-php/realpath_turbo/Manifest
@@ -0,0 +1,3 @@
+DIST realpath_turbo-2.0.0.tar.bz2 9106 BLAKE2B 3275397ab72def1b120d2df1bfe6c233283754539b2ea7dfd558a0773d2f094f9f6b31850a516b883af470cd04d4ebb9d5a7d8492608169a797d1562c7236d11 SHA512 03a03d4a3a067ffac61222c4d71031ab9e289b745fd3b158b5b723f3abf1ad7bb1f691904e3f7b53a98c970f1b0f7c4fe558a4de696aac77d0f9a0f99159fb30
+EBUILD realpath_turbo-2.0.0.ebuild 620 BLAKE2B c837665ca1c5cd1c1cea567092ffe00f416a6039bd3e342e9865a6c711251e132ade0965d5e7ca5b8256388349960dde55acdcd331b7f4af6ae506f9a981f7e5 SHA512 221f2142723449a20e216e24c73a91e43fbaa5152057066bdb5be04e40923abc1ce2cbf884fb037a4b8523355d5ea4614eb632bb1403d89bde0461949ddd80ea
+MISC metadata.xml 453 BLAKE2B 053276e8d453110d9342cad1e6dcbbd51bba0e80b1c5c9c21be7f95b1ae5a64362f9f88f087d5eec7029fca8ca1537040b31cbf9d4c9d3574746abd5148a4de0 SHA512 e0e099f03622b5d90026ca07ca6cfc2277b19c01e414a6fac9994c3f2fcd9db386abe5f9d29c827fe4a75953ad2dcac1f64dd851a6d7d1a0deb60c420bf49008
diff --git a/dev-php/realpath_turbo/metadata.xml b/dev-php/realpath_turbo/metadata.xml
new file mode 100644
index 000000000000..9c672a724777
--- /dev/null
+++ b/dev-php/realpath_turbo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Whissi/realpath_turbo/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild b/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild
new file mode 100644
index 000000000000..629ec768de12
--- /dev/null
+++ b/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="realpath_turbo"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-source-r3
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="PHP extension to re-enable realpath cache when using open_basedir restriction"
+HOMEPAGE="https://github.com/Whissi/${PN}/"
+SRC_URI="https://github.com/Whissi/${PN}/releases/download/v${MY_PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( ChangeLog CREDITS LICENSE README.md )