summaryrefslogtreecommitdiff
path: root/dev-php/phpunit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phpunit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phpunit')
-rw-r--r--dev-php/phpunit/Manifest4
-rw-r--r--dev-php/phpunit/files/autoload.php170
-rw-r--r--dev-php/phpunit/metadata.xml11
-rw-r--r--dev-php/phpunit/phpunit-5.7.15-r1.ebuild55
4 files changed, 240 insertions, 0 deletions
diff --git a/dev-php/phpunit/Manifest b/dev-php/phpunit/Manifest
new file mode 100644
index 000000000000..1a998a740532
--- /dev/null
+++ b/dev-php/phpunit/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 11422 BLAKE2B 90c68a16ab1c2a81c31430984b426e0717881e29231ea008c6e75113d4180733af64a5edf7b1aabd8fd6e84b312ed79b80ee001d805d40f060b9b641c0c27948 SHA512 1d4fd0854a85bc404f5567b78effbc0eb41859601b8e56faaa4362e85ec4d07969864b21df3188fc5e82d5993c67655fa278a9c310b2ec7366aa2195c91e90da
+DIST phpunit-5.7.15.tar.gz 205474 BLAKE2B 0220edd59fc3f191b7621f275d3e4ee8f8bf514f74533d99bfb925e11cc54a235fb292ffd1bb54f6bec1e038c06e35a0dc43c1227618590f99e7e85638a7de28 SHA512 6a836e1ad1656fd1d1c5a58ced3c1826b4decc01798b6a804b487c9b4e094ec32f6eb8a84058e268eade62a2fe19d7bd1e760b8b9433299d9fe9c09afdf2bdd3
+EBUILD phpunit-5.7.15-r1.ebuild 1616 BLAKE2B 08105d6c0d1928bf94b7bba2ad8d04461e22df6cace49739c944213f55d9089e29c0f0fb89806dbecadc8af0288a65c88a2edccfc535e934b021665a8eb8ec60 SHA512 026a7ed14423a855d23cc254bb2b0c3062ad5f59af7092cb92fbc47b47db97a09e5c78db7202a99a11e82745f69a4c4029d69812baeff3ad87d965a81c5c0dc7
+MISC metadata.xml 329 BLAKE2B 45eb57929680d3c3d1c60a22dd1b760db42b1ce2a157c9b87209c391a08022c01a103972267b2f36cea142681d3cc3691a27c726b9a132974d7bb418e5316928 SHA512 007a4fea4de75a468e377398bb1539e25eedc8009ad6dcb6c170be653821b73d8eaaaeb236e207a2e33a509d2966f6a9571d8f0219d90b1662d4da1cdc7de896
diff --git a/dev-php/phpunit/files/autoload.php b/dev-php/phpunit/files/autoload.php
new file mode 100644
index 000000000000..f33b4c8881a1
--- /dev/null
+++ b/dev-php/phpunit/files/autoload.php
@@ -0,0 +1,170 @@
+<?php
+/* Autoloader for dev-php/phpunit and its dependencies */
+
+$include_dir = '/usr/share/php';
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once "${include_dir}/Fedora/Autoloader/autoload.php";
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ array(
+ 'phpunit\\framework\\assert' => '/ForwardCompatibility/Assert.php',
+ 'phpunit\\framework\\basetestlistener' => '/ForwardCompatibility/BaseTestListener.php',
+ 'phpunit\\framework\\testcase' => '/ForwardCompatibility/TestCase.php',
+ 'phpunit\\framework\\testlistener' => '/ForwardCompatibility/TestListener.php',
+ 'phpunit_exception' => '/Exception.php',
+ 'phpunit_extensions_grouptestsuite' => '/Extensions/GroupTestSuite.php',
+ 'phpunit_extensions_phpttestcase' => '/Extensions/PhptTestCase.php',
+ 'phpunit_extensions_phpttestsuite' => '/Extensions/PhptTestSuite.php',
+ 'phpunit_extensions_repeatedtest' => '/Extensions/RepeatedTest.php',
+ 'phpunit_extensions_testdecorator' => '/Extensions/TestDecorator.php',
+ 'phpunit_extensions_ticketlistener' => '/Extensions/TicketListener.php',
+ 'phpunit_framework_assert' => '/Framework/Assert.php',
+ 'phpunit_framework_assertionfailederror' => '/Framework/AssertionFailedError.php',
+ 'phpunit_framework_basetestlistener' => '/Framework/BaseTestListener.php',
+ 'phpunit_framework_codecoverageexception' => '/Framework/CodeCoverageException.php',
+ 'phpunit_framework_constraint' => '/Framework/Constraint.php',
+ 'phpunit_framework_constraint_and' => '/Framework/Constraint/And.php',
+ 'phpunit_framework_constraint_arrayhaskey' => '/Framework/Constraint/ArrayHasKey.php',
+ 'phpunit_framework_constraint_arraysubset' => '/Framework/Constraint/ArraySubset.php',
+ 'phpunit_framework_constraint_attribute' => '/Framework/Constraint/Attribute.php',
+ 'phpunit_framework_constraint_callback' => '/Framework/Constraint/Callback.php',
+ 'phpunit_framework_constraint_classhasattribute' => '/Framework/Constraint/ClassHasAttribute.php',
+ 'phpunit_framework_constraint_classhasstaticattribute' => '/Framework/Constraint/ClassHasStaticAttribute.php',
+ 'phpunit_framework_constraint_composite' => '/Framework/Constraint/Composite.php',
+ 'phpunit_framework_constraint_count' => '/Framework/Constraint/Count.php',
+ 'phpunit_framework_constraint_directoryexists' => '/Framework/Constraint/DirectoryExists.php',
+ 'phpunit_framework_constraint_exception' => '/Framework/Constraint/Exception.php',
+ 'phpunit_framework_constraint_exceptioncode' => '/Framework/Constraint/ExceptionCode.php',
+ 'phpunit_framework_constraint_exceptionmessage' => '/Framework/Constraint/ExceptionMessage.php',
+ 'phpunit_framework_constraint_exceptionmessageregexp' => '/Framework/Constraint/ExceptionMessageRegExp.php',
+ 'phpunit_framework_constraint_fileexists' => '/Framework/Constraint/FileExists.php',
+ 'phpunit_framework_constraint_greaterthan' => '/Framework/Constraint/GreaterThan.php',
+ 'phpunit_framework_constraint_isanything' => '/Framework/Constraint/IsAnything.php',
+ 'phpunit_framework_constraint_isempty' => '/Framework/Constraint/IsEmpty.php',
+ 'phpunit_framework_constraint_isequal' => '/Framework/Constraint/IsEqual.php',
+ 'phpunit_framework_constraint_isfalse' => '/Framework/Constraint/IsFalse.php',
+ 'phpunit_framework_constraint_isfinite' => '/Framework/Constraint/IsFinite.php',
+ 'phpunit_framework_constraint_isidentical' => '/Framework/Constraint/IsIdentical.php',
+ 'phpunit_framework_constraint_isinfinite' => '/Framework/Constraint/IsInfinite.php',
+ 'phpunit_framework_constraint_isinstanceof' => '/Framework/Constraint/IsInstanceOf.php',
+ 'phpunit_framework_constraint_isjson' => '/Framework/Constraint/IsJson.php',
+ 'phpunit_framework_constraint_isnan' => '/Framework/Constraint/IsNan.php',
+ 'phpunit_framework_constraint_isnull' => '/Framework/Constraint/IsNull.php',
+ 'phpunit_framework_constraint_isreadable' => '/Framework/Constraint/IsReadable.php',
+ 'phpunit_framework_constraint_istrue' => '/Framework/Constraint/IsTrue.php',
+ 'phpunit_framework_constraint_istype' => '/Framework/Constraint/IsType.php',
+ 'phpunit_framework_constraint_iswritable' => '/Framework/Constraint/IsWritable.php',
+ 'phpunit_framework_constraint_jsonmatches' => '/Framework/Constraint/JsonMatches.php',
+ 'phpunit_framework_constraint_jsonmatches_errormessageprovider' => '/Framework/Constraint/JsonMatches/ErrorMessageProvider.php',
+ 'phpunit_framework_constraint_lessthan' => '/Framework/Constraint/LessThan.php',
+ 'phpunit_framework_constraint_not' => '/Framework/Constraint/Not.php',
+ 'phpunit_framework_constraint_objecthasattribute' => '/Framework/Constraint/ObjectHasAttribute.php',
+ 'phpunit_framework_constraint_or' => '/Framework/Constraint/Or.php',
+ 'phpunit_framework_constraint_pcrematch' => '/Framework/Constraint/PCREMatch.php',
+ 'phpunit_framework_constraint_samesize' => '/Framework/Constraint/SameSize.php',
+ 'phpunit_framework_constraint_stringcontains' => '/Framework/Constraint/StringContains.php',
+ 'phpunit_framework_constraint_stringendswith' => '/Framework/Constraint/StringEndsWith.php',
+ 'phpunit_framework_constraint_stringmatches' => '/Framework/Constraint/StringMatches.php',
+ 'phpunit_framework_constraint_stringstartswith' => '/Framework/Constraint/StringStartsWith.php',
+ 'phpunit_framework_constraint_traversablecontains' => '/Framework/Constraint/TraversableContains.php',
+ 'phpunit_framework_constraint_traversablecontainsonly' => '/Framework/Constraint/TraversableContainsOnly.php',
+ 'phpunit_framework_constraint_xor' => '/Framework/Constraint/Xor.php',
+ 'phpunit_framework_coveredcodenotexecutedexception' => '/Framework/CoveredCodeNotExecutedException.php',
+ 'phpunit_framework_error' => '/Framework/Error.php',
+ 'phpunit_framework_error_deprecated' => '/Framework/Error/Deprecated.php',
+ 'phpunit_framework_error_notice' => '/Framework/Error/Notice.php',
+ 'phpunit_framework_error_warning' => '/Framework/Error/Warning.php',
+ 'phpunit_framework_exception' => '/Framework/Exception.php',
+ 'phpunit_framework_exceptionwrapper' => '/Framework/ExceptionWrapper.php',
+ 'phpunit_framework_expectationfailedexception' => '/Framework/ExpectationFailedException.php',
+ 'phpunit_framework_incompletetest' => '/Framework/IncompleteTest.php',
+ 'phpunit_framework_incompletetestcase' => '/Framework/IncompleteTestCase.php',
+ 'phpunit_framework_incompletetesterror' => '/Framework/IncompleteTestError.php',
+ 'phpunit_framework_invalidcoverstargetexception' => '/Framework/InvalidCoversTargetException.php',
+ 'phpunit_framework_missingcoversannotationexception' => '/Framework/MissingCoversAnnotationException.php',
+ 'phpunit_framework_outputerror' => '/Framework/OutputError.php',
+ 'phpunit_framework_riskytest' => '/Framework/RiskyTest.php',
+ 'phpunit_framework_riskytesterror' => '/Framework/RiskyTestError.php',
+ 'phpunit_framework_selfdescribing' => '/Framework/SelfDescribing.php',
+ 'phpunit_framework_skippedtest' => '/Framework/SkippedTest.php',
+ 'phpunit_framework_skippedtestcase' => '/Framework/SkippedTestCase.php',
+ 'phpunit_framework_skippedtesterror' => '/Framework/SkippedTestError.php',
+ 'phpunit_framework_skippedtestsuiteerror' => '/Framework/SkippedTestSuiteError.php',
+ 'phpunit_framework_syntheticerror' => '/Framework/SyntheticError.php',
+ 'phpunit_framework_test' => '/Framework/Test.php',
+ 'phpunit_framework_testcase' => '/Framework/TestCase.php',
+ 'phpunit_framework_testfailure' => '/Framework/TestFailure.php',
+ 'phpunit_framework_testlistener' => '/Framework/TestListener.php',
+ 'phpunit_framework_testresult' => '/Framework/TestResult.php',
+ 'phpunit_framework_testsuite' => '/Framework/TestSuite.php',
+ 'phpunit_framework_testsuite_dataprovider' => '/Framework/TestSuite/DataProvider.php',
+ 'phpunit_framework_unintentionallycoveredcodeerror' => '/Framework/UnintentionallyCoveredCodeError.php',
+ 'phpunit_framework_warning' => '/Framework/Warning.php',
+ 'phpunit_framework_warningtestcase' => '/Framework/WarningTestCase.php',
+ 'phpunit_runner_basetestrunner' => '/Runner/BaseTestRunner.php',
+ 'phpunit_runner_exception' => '/Runner/Exception.php',
+ 'phpunit_runner_filter_factory' => '/Runner/Filter/Factory.php',
+ 'phpunit_runner_filter_group_exclude' => '/Runner/Filter/Group/Exclude.php',
+ 'phpunit_runner_filter_group_include' => '/Runner/Filter/Group/Include.php',
+ 'phpunit_runner_filter_groupfilteriterator' => '/Runner/Filter/Group.php',
+ 'phpunit_runner_filter_test' => '/Runner/Filter/Test.php',
+ 'phpunit_runner_standardtestsuiteloader' => '/Runner/StandardTestSuiteLoader.php',
+ 'phpunit_runner_testsuiteloader' => '/Runner/TestSuiteLoader.php',
+ 'phpunit_runner_version' => '/Runner/Version.php',
+ 'phpunit_textui_command' => '/TextUI/Command.php',
+ 'phpunit_textui_resultprinter' => '/TextUI/ResultPrinter.php',
+ 'phpunit_textui_testrunner' => '/TextUI/TestRunner.php',
+ 'phpunit_util_blacklist' => '/Util/Blacklist.php',
+ 'phpunit_util_configuration' => '/Util/Configuration.php',
+ 'phpunit_util_configurationgenerator' => '/Util/ConfigurationGenerator.php',
+ 'phpunit_util_errorhandler' => '/Util/ErrorHandler.php',
+ 'phpunit_util_fileloader' => '/Util/Fileloader.php',
+ 'phpunit_util_filesystem' => '/Util/Filesystem.php',
+ 'phpunit_util_filter' => '/Util/Filter.php',
+ 'phpunit_util_getopt' => '/Util/Getopt.php',
+ 'phpunit_util_globalstate' => '/Util/GlobalState.php',
+ 'phpunit_util_invalidargumenthelper' => '/Util/InvalidArgumentHelper.php',
+ 'phpunit_util_log_json' => '/Util/Log/JSON.php',
+ 'phpunit_util_log_junit' => '/Util/Log/JUnit.php',
+ 'phpunit_util_log_tap' => '/Util/Log/TAP.php',
+ 'phpunit_util_log_teamcity' => '/Util/Log/TeamCity.php',
+ 'phpunit_util_php' => '/Util/PHP.php',
+ 'phpunit_util_php_default' => '/Util/PHP/Default.php',
+ 'phpunit_util_php_windows' => '/Util/PHP/Windows.php',
+ 'phpunit_util_printer' => '/Util/Printer.php',
+ 'phpunit_util_regex' => '/Util/Regex.php',
+ 'phpunit_util_string' => '/Util/String.php',
+ 'phpunit_util_test' => '/Util/Test.php',
+ 'phpunit_util_testdox_nameprettifier' => '/Util/TestDox/NamePrettifier.php',
+ 'phpunit_util_testdox_resultprinter' => '/Util/TestDox/ResultPrinter.php',
+ 'phpunit_util_testdox_resultprinter_html' => '/Util/TestDox/ResultPrinter/HTML.php',
+ 'phpunit_util_testdox_resultprinter_text' => '/Util/TestDox/ResultPrinter/Text.php',
+ 'phpunit_util_testdox_resultprinter_xml' => '/Util/TestDox/ResultPrinter/XML.php',
+ 'phpunit_util_testsuiteiterator' => '/Util/TestSuiteIterator.php',
+ 'phpunit_util_type' => '/Util/Type.php',
+ 'phpunit_util_xml' => '/Util/XML.php',
+),
+ "${include_dir}/PHPUnit"
+);
+
+// Dependencies
+\Fedora\Autoloader\Dependencies::required(array(
+ "${include_dir}/File/Iterator/autoload.php",
+ "${include_dir}/PHP/CodeCoverage/autoload.php",
+ "${include_dir}/PHP/Timer/autoload.php",
+ "${include_dir}/SebastianBergmann/Version/autoload.php",
+ "${include_dir}/SebastianBergmann/Diff/autoload.php",
+ "${include_dir}/SebastianBergmann/Environment/autoload.php",
+ "${include_dir}/SebastianBergmann/Exporter/autoload.php",
+ "${include_dir}/SebastianBergmann/GlobalState/autoload.php",
+ "${include_dir}/SebastianBergmann/Comparator/autoload.php",
+ "${include_dir}/SebastianBergmann/ObjectEnumerator/autoload.php",
+ "${include_dir}/SebastianBergmann/ResourceOperations/autoload.php",
+ "${include_dir}/Symfony/Component/Yaml/autoload.php",
+ "${include_dir}/Text/Template/autoload.php",
+ "${include_dir}/myclabs/DeepCopy/autoload.php",
+ "${include_dir}/PHPUnit/Framework/MockObject/autoload.php",
+ "${include_dir}/phpspec/Prophecy/autoload.php",
+));
diff --git a/dev-php/phpunit/metadata.xml b/dev-php/phpunit/metadata.xml
new file mode 100644
index 000000000000..44a54c50110f
--- /dev/null
+++ b/dev-php/phpunit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sebastianbergmann/phpunit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phpunit/phpunit-5.7.15-r1.ebuild b/dev-php/phpunit/phpunit-5.7.15-r1.ebuild
new file mode 100644
index 000000000000..6fa7de02877f
--- /dev/null
+++ b/dev-php/phpunit/phpunit-5.7.15-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A PHP Unit Testing framework"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-php/File_Iterator-1.4.0
+ !>=dev-php/File_Iterator-2.0
+ >=dev-php/Text_Template-1.2.0
+ !>=dev-php/Text_Template-2.0
+ >=dev-php/PHP_CodeCoverage-4.0.4
+ !>=dev-php/PHP_CodeCoverage-5.0
+ >=dev-php/PHP_Timer-1.0.6
+ !>=dev-php/PHP_Timer-2.0
+ <dev-php/myclabs-deepcopy-2.0
+ <dev-php/phpspec-prophecy-2.0
+ <dev-php/phpunit-mock-objects-4.0
+ <dev-php/sebastian-comparator-2.0
+ <dev-php/sebastian-diff-2.0
+ <dev-php/sebastian-environment-3.0
+ <dev-php/sebastian-exporter-3.0
+ <dev-php/sebastian-global-state-2.0
+ <dev-php/sebastian-object-enumerator-3.0
+ <dev-php/sebastian-resource-operations-2.0
+ <dev-php/sebastian-version-3.0
+ <dev-php/symfony-yaml-4.0
+ || (
+ dev-lang/php:5.6[cli,json,unicode,xml]
+ dev-lang/php:7.0[cli,json,unicode,xml]
+ dev-lang/php:7.1[cli,json,unicode,xml]
+ )"
+
+src_install() {
+ insinto /usr/share/php/PHPUnit
+ doins -r src/*
+ insinto /usr/share/php/PHPUnit/vendor
+ doins "${FILESDIR}/autoload.php"
+ exeinto /usr/share/php/PHPUnit
+ doexe phpunit
+ dosym ../share/php/PHPUnit/phpunit /usr/bin/phpunit
+}
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}