summaryrefslogtreecommitdiff
path: root/dev-php/phpspec-prophecy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phpspec-prophecy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phpspec-prophecy')
-rw-r--r--dev-php/phpspec-prophecy/Manifest4
-rw-r--r--dev-php/phpspec-prophecy/files/autoload.php15
-rw-r--r--dev-php/phpspec-prophecy/metadata.xml11
-rw-r--r--dev-php/phpspec-prophecy/phpspec-prophecy-1.7.0.ebuild31
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-php/phpspec-prophecy/Manifest b/dev-php/phpspec-prophecy/Manifest
new file mode 100644
index 000000000000..484330529c6f
--- /dev/null
+++ b/dev-php/phpspec-prophecy/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 544 BLAKE2B d6ec873ca93869028f105eb90480031805bf2a377ca73824ae363456388d0ecbebcc5a736ec0e9ba507f7bb00e2843aa6cb3a1cad15ea849d825080ff0c6cb09 SHA512 4c75d70b199ca708d6dbd8975df0fe1e73db9b91bbce1f4360dca7405e3bc782f10331e83399a09fe2ea7373064f70538ba0b7525be008614be75b52ee7267fb
+DIST phpspec-prophecy-1.7.0.tar.gz 60338 BLAKE2B 8171120d8407f2e554150d5e3ea1972c54d4e2ce0e6698763f0b3c7e1645340ce22404da7844fed8412579c46f372852b4553c6d8a65c8094ef3065b0dbbd80c SHA512 e8efb3882d869f10fe39dff7c2185e1ec6f044c794fd6a5785e1c1c69c71b91dc3997f61bd2566d3243dde0becce568beba9a18fa0fd152e6ce74ca43a9a0fb0
+EBUILD phpspec-prophecy-1.7.0.ebuild 811 BLAKE2B 53818c6a4f2dd8ed05c6e1789fe95d25bab7265c1d5f13641fc269d32eb34337537ef2911fe8e4003e1e8b858a80f7a72477896dd3613bbec1824c54402b9668 SHA512 38e47098997e435e5f91f6775ee2f63f41170c29af6868f942481fdaacad40167bcac7f9f48a52591a3ff39781c3cca2e5bc712ebe9046eb97ca87cfc889c765
+MISC metadata.xml 320 BLAKE2B 52dc068f02b6134f5fb38c8a527e6c2cd4f47e260654e0558377fa7b188d5beebcc1c503137014842ff6081f576986e8b1585f61047e019facf4261d54437c6f SHA512 1772f2d920e747cc7e4b1bd32dcc503f72f17c7bcb964e01c74df781a114e0c4879d6018bab9c9244be3adcdc52a5f36e0de9b4ea34743fa9b64313a6a691ad3
diff --git a/dev-php/phpspec-prophecy/files/autoload.php b/dev-php/phpspec-prophecy/files/autoload.php
new file mode 100644
index 000000000000..eb61ccb5eedb
--- /dev/null
+++ b/dev-php/phpspec-prophecy/files/autoload.php
@@ -0,0 +1,15 @@
+<?php
+/* Autoloader for dev-php/phpspec-prophecy */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+Fedora\Autoloader\Autoload::addPsr0('Prophecy\\', __DIR__);
+
+\Fedora\Autoloader\Dependencies::required(array(
+ '/usr/share/php/phpDocumentor/ReflectionDocBlock/autoload.php',
+ '/usr/share/php/SebastianBergmann/Comparator/autoload.php',
+ '/usr/share/php/Doctrine/Instantiator/autoload.php',
+ '/usr/share/php/SebastianBergmann/RecursionContext/autoload.php',
+));
diff --git a/dev-php/phpspec-prophecy/metadata.xml b/dev-php/phpspec-prophecy/metadata.xml
new file mode 100644
index 000000000000..d8cce3e62197
--- /dev/null
+++ b/dev-php/phpspec-prophecy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phpspec/prophecy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phpspec-prophecy/phpspec-prophecy-1.7.0.ebuild b/dev-php/phpspec-prophecy/phpspec-prophecy-1.7.0.ebuild
new file mode 100644
index 000000000000..da0780af3c9f
--- /dev/null
+++ b/dev-php/phpspec-prophecy/phpspec-prophecy-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="prophecy"
+MY_VENDOR="phpspec"
+
+DESCRIPTION="Highly opinionated mocking framework"
+HOMEPAGE="https://github.com/${MY_VENDOR}/${MY_PN}"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/doctrine-instantiator-2
+ <dev-php/phpdocumentor-reflection-docblock-4
+ <dev-php/sebastian-comparator-3
+ <dev-php/sebastian-recursion-context-4
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/Prophecy
+ doins -r src/Prophecy/*
+ doins "${FILESDIR}/autoload.php"
+}