summaryrefslogtreecommitdiff
path: root/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-25 11:50:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-25 11:50:47 +0000
commitd42200bec37eef2a7478d88988ff00addd0a9202 (patch)
tree10394660b3cbe4b50173c06950b31302cd25d0d1 /dev-php/phpspec-prophecy/phpspec-prophecy-1.10.1.ebuild
parent580f05ea8f512d11e23e8da80177d27835cbdbbc (diff)
gentoo resync : 25.01.2020
Diffstat (limited to 'dev-php/phpspec-prophecy/phpspec-prophecy-1.10.1.ebuild')
-rw-r--r--dev-php/phpspec-prophecy/phpspec-prophecy-1.10.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.1.ebuild b/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.1.ebuild
new file mode 100644
index 000000000000..0e13a51b2a3e
--- /dev/null
+++ b/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="prophecy"
+MY_VENDOR="phpspec"
+
+DESCRIPTION="Highly opinionated mocking framework"
+HOMEPAGE="https://github.com/phpspec/prophecy"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/doctrine-instantiator-2
+ <dev-php/phpdocumentor-reflection-docblock-6
+ <dev-php/sebastian-comparator-4
+ <dev-php/sebastian-recursion-context-4
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/Prophecy
+ doins -r src/Prophecy/*
+ newins "${FILESDIR}/autoload-1.10.0.php" autoload.php
+}