summaryrefslogtreecommitdiff
path: root/dev-php/phpdocumentor-reflection-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phpdocumentor-reflection-common
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phpdocumentor-reflection-common')
-rw-r--r--dev-php/phpdocumentor-reflection-common/Manifest4
-rw-r--r--dev-php/phpdocumentor-reflection-common/files/autoload.php8
-rw-r--r--dev-php/phpdocumentor-reflection-common/metadata.xml11
-rw-r--r--dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild27
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-php/phpdocumentor-reflection-common/Manifest b/dev-php/phpdocumentor-reflection-common/Manifest
new file mode 100644
index 000000000000..4a58a3131e94
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 271 BLAKE2B 755d18da274f77605c5873c2ddfde9ff2f47ea325f647d405a1519b660d51bd057a2e299cc4797ad4578ee3af1d56e05ce6cf272fd7e4019d2ad86f4e12dd324 SHA512 7aae3acc76199fd18558d5ae048e6d32d122a2b5310709f7b6129e3ea53be140e290b0ef8e1f69a153f9ee387de959047a6a8c4ec780df98e51c9f56a7af6e81
+DIST phpdocumentor-reflection-common-1.0.tar.gz 7746 BLAKE2B 0e7119b9a55e4408160c7e04f569831b491c801f4a12e4b17af21eb4a1fcd9b7f84f23548551f829506649d3accbd3a890bae7ba8ef4390051f45f68143f76a2 SHA512 63d76282d0921535af70e084d3621d8cc6b07f49bc5348429a340730212f3c99f8e64636e43cebb3140fa4f6363b4f2a0c02cbe38036a28123e7bbeb67c61a0d
+EBUILD phpdocumentor-reflection-common-1.0.ebuild 685 BLAKE2B e0bb9d856ca939e7e66ca5278b74a592675b96fcb6fb7abef1072542e2df7cf0103307fcff83079fd08bf2b6274b193294f8d2fd20ab97d512263f2e15f3033b SHA512 409593e77da518cacb28f8185b61717b3d225190037f93040fe320e5e2629d77adbc9b8c06d941977896b8e05622eb7998fad314f553a53739423103a2392e9c
+MISC metadata.xml 334 BLAKE2B 1b34b1832ed2c8cde0a91717334174f49fb69986aceac768cecf15e1898acf8b5e1ed12ff361be20cce83e8e8b7c31c87408b924b5e6a8d17700b5d6a88285bc SHA512 9db658eed874814225b9a118d88b900e7a6965cd629da7aa98cbbac2f1708425ae463a9dee7ce12cf9dc9b78cd2c123a0b5bd4056ca25feb47e5747112a4d0e5
diff --git a/dev-php/phpdocumentor-reflection-common/files/autoload.php b/dev-php/phpdocumentor-reflection-common/files/autoload.php
new file mode 100644
index 000000000000..356515b7a000
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for dev-php/phpdocumentor-reflection-common */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+Fedora\Autoloader\Autoload::addPsr4('phpDocumentor\\Reflection\\', __DIR__);
diff --git a/dev-php/phpdocumentor-reflection-common/metadata.xml b/dev-php/phpdocumentor-reflection-common/metadata.xml
new file mode 100644
index 000000000000..99183602ecfc
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phpDocumentor/ReflectionCommon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild b/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild
new file mode 100644
index 000000000000..13c895fea14d
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="ReflectionCommon"
+MY_VENDOR="phpDocumentor"
+
+DESCRIPTION="Common reflection classes used by phpdocumentor to reflect the code structure"
+HOMEPAGE="https://www.phpdoc.org"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}