summaryrefslogtreecommitdiff
path: root/dev-php/phpdocumentor-reflection-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/phpdocumentor-reflection-common
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/phpdocumentor-reflection-common')
-rw-r--r--dev-php/phpdocumentor-reflection-common/Manifest4
-rw-r--r--dev-php/phpdocumentor-reflection-common/files/autoload.php8
-rw-r--r--dev-php/phpdocumentor-reflection-common/metadata.xml11
-rw-r--r--dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild27
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-php/phpdocumentor-reflection-common/Manifest b/dev-php/phpdocumentor-reflection-common/Manifest
new file mode 100644
index 000000000000..15dbb0f14b8b
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 271 SHA256 1164052255db5deb0dd1bffa8a591820fb121dc7dfa1fab7641c16227898f1fb SHA512 7aae3acc76199fd18558d5ae048e6d32d122a2b5310709f7b6129e3ea53be140e290b0ef8e1f69a153f9ee387de959047a6a8c4ec780df98e51c9f56a7af6e81 WHIRLPOOL 01aece97eac553e5601f42fa72d70ef9566eb4c182548d893553d9f72af08e98b05cd547d13368749a373c0db8cba1e01f0a11138871e9647e77b93306125581
+DIST phpdocumentor-reflection-common-1.0.tar.gz 7746 SHA256 f53df95e812fc0208ba6aeef9e9fab95e5896ba3327d3f724ce03f0a17000b97 SHA512 63d76282d0921535af70e084d3621d8cc6b07f49bc5348429a340730212f3c99f8e64636e43cebb3140fa4f6363b4f2a0c02cbe38036a28123e7bbeb67c61a0d WHIRLPOOL e895a96359b4474012be2ad806cd4d4148564090a4b517f3651f531ada0ec3a2ada889b236b85219a4b1fe61272aa5c70192ad193177b66b571960eee7eb56ae
+EBUILD phpdocumentor-reflection-common-1.0.ebuild 694 SHA256 4ac2d8e952911e3aaff261ed42fc8e95203f44eb684b04071b8ff018e74c739a SHA512 0ded3561ee9f0e0f0e602fbaee78680590d653109817d087417c7ef6ef8ece7654604ef6e7dd977de101695649c561898f9bea3ee11357b78b94caea84c525c6 WHIRLPOOL bcbc31ca13c4a83bc4643caf43c74a950630c345b4d8a1a31c699dfee4d8cec3d8c724fb28c2953e5d3267fd588b2efdc321a08bbc1ddf03d7edc27cd87a2fea
+MISC metadata.xml 334 SHA256 56111bb89523cfcae9f3ad99379caa2c0dad440cc0c0a87444a49b81e6abb166 SHA512 9db658eed874814225b9a118d88b900e7a6965cd629da7aa98cbbac2f1708425ae463a9dee7ce12cf9dc9b78cd2c123a0b5bd4056ca25feb47e5747112a4d0e5 WHIRLPOOL f41771b6675af2d19fc57662767c83d87272aaed5433affbf8184cdf4413594d3acf0df1eed98f373cf2d23366f4cc9b93fd1edd6a4be46c42cdb435d6107e1a
diff --git a/dev-php/phpdocumentor-reflection-common/files/autoload.php b/dev-php/phpdocumentor-reflection-common/files/autoload.php
new file mode 100644
index 000000000000..356515b7a000
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for dev-php/phpdocumentor-reflection-common */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+Fedora\Autoloader\Autoload::addPsr4('phpDocumentor\\Reflection\\', __DIR__);
diff --git a/dev-php/phpdocumentor-reflection-common/metadata.xml b/dev-php/phpdocumentor-reflection-common/metadata.xml
new file mode 100644
index 000000000000..99183602ecfc
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phpDocumentor/ReflectionCommon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild b/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild
new file mode 100644
index 000000000000..84e9f110e98a
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-common/phpdocumentor-reflection-common-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="ReflectionCommon"
+MY_VENDOR="phpDocumentor"
+
+DESCRIPTION="Common reflection classes used by phpdocumentor to reflect the code structure"
+HOMEPAGE="https://www.phpdoc.org"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}