summaryrefslogtreecommitdiff
path: root/dev-php/phpDocumentor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phpDocumentor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phpDocumentor')
-rw-r--r--dev-php/phpDocumentor/Manifest3
-rw-r--r--dev-php/phpDocumentor/metadata.xml11
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/phpDocumentor/Manifest b/dev-php/phpDocumentor/Manifest
new file mode 100644
index 000000000000..130f35e9912e
--- /dev/null
+++ b/dev-php/phpDocumentor/Manifest
@@ -0,0 +1,3 @@
+DIST phpDocumentor-2.9.0.phar 18276081 BLAKE2B 988d9ae15a369c94d6dd83d68b64054d4d1829d651ae28a5082913ebd47666a73f5e48d331c09561777b58c6716707f4751b047e1aad9545d83ac9c964933b80 SHA512 62efc492d387675f753094bf4c42f890808bc3f45ae4a6908a519722af11ffbda41b47100e68f12e5b73a2eaa49fe8afc8143c751518a2a68b10afa18f896f10
+EBUILD phpDocumentor-2.9.0.ebuild 745 BLAKE2B be399471b00f8acdc9912cc1a841e926fc11f61e57cc3abc5a5fc77c8c81bdb03a1af40ead995fa36a93896319dbf583ea32dda5ab2e731970a658829d4f872b SHA512 46250496a8aabb2aa3c342aa48dca3b0afb00e28a2bdb90404482d115489ee5c0c52b2580d52d9d0c1e0e4ca0a00f5b290552bbc23fd1a68741cbe4f5da24e57
+MISC metadata.xml 342 BLAKE2B f63e91a30eafcf4313f7b1d1da9a1403cf3b74277d6e45063002413f5c5f12343e59cc58a0d2893c6d9b8798c0b732bf370f4f4b2a41d4a9534b720e53ed8979 SHA512 100907bbb2b93327787d11f6046e7058a350d9525baab105ff5033a0ed61bf33a1e04f7fc6626b751f40187c981298d636e6c311be514020303cea222ec12e58
diff --git a/dev-php/phpDocumentor/metadata.xml b/dev-php/phpDocumentor/metadata.xml
new file mode 100644
index 000000000000..5b3f6d868306
--- /dev/null
+++ b/dev-php/phpDocumentor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phpDocumentor/phpDocumentor2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
new file mode 100644
index 000000000000..48f99127a9eb
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Automatic documenting of php api directly from the source"
+HOMEPAGE="http://phpdoc.org"
+SRC_URI="https://github.com/${PN}/${PN}2/releases/download/v${PV}/${PN}.phar -> ${P}.phar"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# block old version that provides the same binary
+RDEPEND="!dev-php/PEAR-PhpDocumentor
+ media-gfx/graphviz
+ dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_install() {
+ exeinto /usr/share/php/${PN}
+ newexe "${DISTDIR}/${P}.phar" ${PN}.phar
+ dosym "../share/php/${PN}/${PN}.phar" /usr/bin/phpdoc
+}